LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-16-2010, 12:49 PM   #1
Moiseshb
LQ Newbie
 
Registered: May 2010
Distribution: Arch Linux x86_64
Posts: 12

Rep: Reputation: 0
No value for $TERM variable


Hi everybody
I'm using Slackware64-current and everything is fine except by the $TERM variable. When I try to run sbopkg, for example, i get this error message:
Code:
root pedro # sbopkg
tput: No value for $TERM and no -T specified
TERM environment variable not set.
tput: No value for $TERM and no -T specified
I made a quick fix putting "export TERM=xterm" on .bashrc but this is bothering me because all terminal windows had "Untitled window" as name.
Here is a screenshot: http://h.imagehost.org/0998/xfce.png
Thanks

PS:Sorry for my bad english,i'm brazilian,i hope you have understood

Last edited by Moiseshb; 05-17-2010 at 03:27 PM.
 
Old 05-16-2010, 02:34 PM   #2
GazL
Senior Member
 
Registered: May 2008
Posts: 3,231

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
If you look in edit/preferences then click on the advanced tab you'll see there's a field to set $TERM.

I use the good old fashioned xterm rather than terminal myself and that seems to look after itself.
 
Old 05-16-2010, 06:22 PM   #3
Moiseshb
LQ Newbie
 
Registered: May 2010
Distribution: Arch Linux x86_64
Posts: 12

Original Poster
Rep: Reputation: 0
Oh i'm feeling so dumb now
Thanks
EDIT:Problem partially solved I'm still getting "Ultitled window" but I don't care
SOLVED

Last edited by Moiseshb; 05-16-2010 at 06:35 PM.
 
Old 05-16-2010, 09:39 PM   #4
ivandi
LQ Newbie
 
Registered: Jul 2009
Location: Québec, Canada
Distribution: Slackware-current
Posts: 28

Rep: Reputation: 4
It looks like a bug in XFCE Terminal. Every time I open the Preferences these variables (TitleInitial and Term) are reset. So I have to manually edit ~/.config/Terminal/terminalrc to set them. I am not sure but I think it happened after the update from May 6.
 
Old 05-16-2010, 11:20 PM   #5
the3dfxdude
Member
 
Registered: May 2007
Posts: 304

Rep: Reputation: 66
If xfce is built against gtk+ 2.18, this bug surfaces. A patch is already in the Terminal git tree, and I notified Pat. I suppose that on May 6 the bug surfaced when xfce was recompiled. But this patch needs to be applied and Terminal recompiled. Too bad I took so long at getting around to this. I knew about this problem for a few weeks when I built xfce 4.6.1 on another distro.
 
Old 05-17-2010, 03:27 PM   #6
Moiseshb
LQ Newbie
 
Registered: May 2010
Distribution: Arch Linux x86_64
Posts: 12

Original Poster
Rep: Reputation: 0
Yes it's a bug ¬¬
It was solved but now is back
I'm still using "export TERM=xterm" on .bashrc
 
Old 05-17-2010, 09:11 PM   #7
the3dfxdude
Member
 
Registered: May 2007
Posts: 304

Rep: Reputation: 66
Moiseshb, download xfce-4.6.1-i486-8, upgradepkg, and restart xfce. You can test the fix by opening and closing the preference dialog.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Use of TERM environment variable saandeep_jan Linux - Newbie 1 08-30-2007 03:55 PM
Where is global TERM variable set? tonyfreeman Red Hat 1 02-20-2007 02:20 PM
Shell Term variable help neilcpp Linux - Software 1 03-15-2006 07:14 AM
$TERM variable change, or other solution? mikshaw Linux - Software 4 01-22-2004 09:08 PM
$TERM Variable Problems LinuxTechie Red Hat 2 11-02-2003 10:29 AM


All times are GMT -5. The time now is 06:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration