LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   GraphiX Boost Switch on Asus UL80vt (http://www.linuxquestions.org/questions/slackware-14/graphix-boost-switch-on-asus-ul80vt-768674/)

willysr 11-12-2009 09:53 AM

GraphiX Boost Switch on Asus UL80vt
 
Hello everybody,

i just bought a new laptop, Asus UL80vt which has GraphiX Boost switch which enables me to switch from NVidia G210M Graphics to Intel GMA 4500MHD and vice versa.

The problem is that this switch only works on Windows (it comes with Windows 7 pre-installed), but i have removed them and use only Slackware 13.0 on this new laptop. I would like to enable NVidia rather than using Intel GMA.

Does anybody have experienced this before?

slackd 11-13-2009 06:15 AM

Quote:

We currently do not have plans to support Hybrid Power on Linux. However, you should be able to configure X to use your motherboard GPU.

AaronP
NVIDIA Corporation
Post Your Problem Here:

See this also->

slackd 11-13-2009 06:35 AM

ok, did a little digging and found this:

Code:

Finally I managed to make it work, thanks to all the help i got.
So to resume everything that one must to make the nvidia drivers work for Linux 8.10 on a Studio XPS 13:

1.Exit the GUI, type: "Ctrl+Alt+F1"
( to return press Ctrl+Alt+F7)

2. $ sudo killall x
(to stop the GUI)

3. $ sudo apt-get install nvidia-180 modaliases
(this will download the driver from internet, and since I'm not sure how to connect with wifi, use ethernet)

4. $ sudo apt-get install nvidia-glx-180
(this will install the driver, just enter y when it is asked)

5. When the install is finished:
$ sudo nvidia-xconfig
(there will be an error, doesn't matter)
Type in the same command again
(this time it will work)

6. $ sudo reboot
(restarts the computer)

7.At this point it will give the error, 'no screens'
enter your username and password then:

$ sudo nano /etc/X11/xorg.conf
(this will edit the xserver configuration page)

8.Go down to "Section Device"
And add a the very end the line:
BusID "PCI:03:00:0"
(remember this is for the studio xps 13)

9.Quit the editor with:
Ctrl+X <Enter>
then:
Y <Enter>
then:
<Enter>

10. reboot the computer once more and tadaaa, it works

I spent such a time to make this work, I was very happy when it finally worked, thanks alot for the help from everybody.

P.S If this doesn't work just reboot the computer choose the restricted partition, and just do do "Repair X"

*Remember* this is from a ubuntu forum, so please adapt accordingly.

AlvaroG 11-13-2009 07:05 AM

killall x to stop X? no "close session" first in the desktop?
reboot twice?

damn, those Ubuntu kids should learn about 'telinit' :-D

slackd 11-13-2009 07:09 AM

Quote:

Originally Posted by AlvaroG (Post 3755516)
killall x to stop X? no "close session" first in the desktop?
reboot twice?

damn, those Ubuntu kids should learn about 'telinit' :-D

that is exactly why i gave the *Remember* part..lol

willysr 11-13-2009 04:55 PM

have you managed to solve this on Slackware? since i can't reproduce your steps above

johncudd 01-26-2010 06:33 PM

Does this solution fix the GraphiX Boost Switch and allow you to turn the Nvidia graphics ON and OFF? Or does it just enable the Nvidia graphics permanently? Thanks for the help.


All times are GMT -5. The time now is 09:35 AM.