LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-12-2009, 10:53 AM   #1
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,619

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
GraphiX Boost Switch on Asus UL80vt


Hello everybody,

i just bought a new laptop, Asus UL80vt which has GraphiX Boost switch which enables me to switch from NVidia G210M Graphics to Intel GMA 4500MHD and vice versa.

The problem is that this switch only works on Windows (it comes with Windows 7 pre-installed), but i have removed them and use only Slackware 13.0 on this new laptop. I would like to enable NVidia rather than using Intel GMA.

Does anybody have experienced this before?
 
Old 11-13-2009, 07:15 AM   #2
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Quote:
We currently do not have plans to support Hybrid Power on Linux. However, you should be able to configure X to use your motherboard GPU.

AaronP
NVIDIA Corporation
Post Your Problem Here:

See this also->

Last edited by slackd; 11-13-2009 at 08:06 AM.
 
Old 11-13-2009, 07:35 AM   #3
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Thumbs up

ok, did a little digging and found this:

Code:
Finally I managed to make it work, thanks to all the help i got.
So to resume everything that one must to make the nvidia drivers work for Linux 8.10 on a Studio XPS 13:

1.Exit the GUI, type: "Ctrl+Alt+F1"
( to return press Ctrl+Alt+F7)

2. $ sudo killall x
(to stop the GUI)

3. $ sudo apt-get install nvidia-180 modaliases
(this will download the driver from internet, and since I'm not sure how to connect with wifi, use ethernet)

4. $ sudo apt-get install nvidia-glx-180
(this will install the driver, just enter y when it is asked)

5. When the install is finished:
$ sudo nvidia-xconfig
(there will be an error, doesn't matter)
Type in the same command again
(this time it will work)

6. $ sudo reboot
(restarts the computer)

7.At this point it will give the error, 'no screens'
enter your username and password then:

$ sudo nano /etc/X11/xorg.conf
(this will edit the xserver configuration page)

8.Go down to "Section Device"
And add a the very end the line:
BusID "PCI:03:00:0"
(remember this is for the studio xps 13)

9.Quit the editor with:
Ctrl+X <Enter>
then:
Y <Enter>
then:
<Enter>

10. reboot the computer once more and tadaaa, it works

I spent such a time to make this work, I was very happy when it finally worked, thanks alot for the help from everybody.

P.S If this doesn't work just reboot the computer choose the restricted partition, and just do do "Repair X"
*Remember* this is from a ubuntu forum, so please adapt accordingly.

Last edited by slackd; 11-13-2009 at 08:17 AM.
 
Old 11-13-2009, 08:05 AM   #4
AlvaroG
Member
 
Registered: Jul 2009
Location: Canelones, Uruguay
Distribution: Slackware
Posts: 128

Rep: Reputation: 31
killall x to stop X? no "close session" first in the desktop?
reboot twice?

damn, those Ubuntu kids should learn about 'telinit' :-D
 
Old 11-13-2009, 08:09 AM   #5
slackd
Member
 
Registered: Sep 2009
Location: Bhubaneswar, India
Distribution: Slackware, Ubuntu, Windows
Posts: 260
Blog Entries: 1

Rep: Reputation: 60
Quote:
Originally Posted by AlvaroG View Post
killall x to stop X? no "close session" first in the desktop?
reboot twice?

damn, those Ubuntu kids should learn about 'telinit' :-D
that is exactly why i gave the *Remember* part..lol
 
Old 11-13-2009, 05:55 PM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,619

Original Poster
Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
have you managed to solve this on Slackware? since i can't reproduce your steps above
 
Old 01-26-2010, 07:33 PM   #7
johncudd
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Rep: Reputation: 0
Does this solution fix the GraphiX Boost Switch and allow you to turn the Nvidia graphics ON and OFF? Or does it just enable the Nvidia graphics permanently? Thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
resolution of graphix card sickcom Linux - Newbie 8 02-10-2009 06:18 AM
ASUS Laptop Graphix screwup remisandotbe Linux - Newbie 1 12-03-2007 01:58 AM
Can't turn off RF Kill switch on Asus Z33A with Intel 2200BG wireless kmierle Linux - Laptop and Netbook 2 09-22-2005 11:11 PM
GraphiX Programming NGraphiX Linux - General 0 08-23-2002 04:41 AM
graphix screwup justin19fl Linux - Newbie 8 06-14-2001 12:02 AM


All times are GMT -5. The time now is 09:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration