LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Atheros wireless driving me crazy (http://www.linuxquestions.org/questions/slackware-14/atheros-wireless-driving-me-crazy-387598/)

tw001_tw 11-29-2005 11:13 AM

Atheros wireless driving me crazy
 
Is it really this hard????
I need some serious help here.

Heres my lspci:
Code:

01:05.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)
Heres my lsmod:
Code:

ath_pci                68252  0
ath_rate_sample        13704  1 ath_pci
wlan                  126876  3 ath_pci,ath_rate_sample
ath_hal              146512  3 ath_pci,ath_rate_sample

I'm using a clean install of Slack 10.2, upgraded to the default 2.6.13 kernel from CD#2.

I've installed (in this order):
madwifi-20051008_2.6.13-i486-1.tgz
wireless-tools-28.pre10-i486-1.tgz
wpa_supplicant-20051008-i486-1.tgz

If I'm reading it right, The following links says it should work on unsecured AP's?
http://madwifi.org/wiki/UserDocs/Distro/Slackware

iwconfig gives me this:
Code:

ath0      IEEE 802.11g  ESSID:"linksys"  Nickname:"lap-cat"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:06:25:DB:C8:19
          Bit Rate:11 Mb/s  Tx-Power:18 dBm  Sensitivity=0/3
          Retry:off  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=71/94  Signal level=-24 dBm  Noise level=-95 dBm
          Rx invalid nwid:32  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

Notice it does specify the linksys router I'm trying to connect to, but mozilla times out.
(yes, I unplug the network cable to ensure Its a wireless connection).
The laptop has an intel 10/100 NIC & the wireless.

Where am I going wrong?
-tw

Hangdog42 11-29-2005 11:47 AM

Are you requesting or assigning an IP address?

tw001_tw 11-29-2005 11:48 AM

I believe I am requesting one. Although I am open to the option.... whichever is easier
for accessing your average AP's (hotels, etc.)

-tw

Hangdog42 11-29-2005 11:55 AM

Usually requesting one is easier so something like:

dhcpcd ath0 -d

(the -d makes dhcpcd a touch more verbose)

If you're not sure if your doing this, then odds are you aren't. A quick check of ifconfig will show if you have an IP or not.

tw001_tw 11-29-2005 12:25 PM

GOT IT!

I know I tried dhcpcd ath0 at some point in time, but never the "-d".
I can't explain way, but its working now.
I just hope it stays working ina regular fashion.

thanks for the 'hand holding' Hangdog42, its appreciated.
-tw

(I'll solve someone elses problem later on to return the favor!)

Hangdog42 11-29-2005 12:34 PM

Congrats on getting up and running! I'm guessing that earlier attempts with dhcpcd went awry for some other reason because all the -d flag is supposed to do is cause dhcpcd to log more information than it usually does. It shouldn't affect the process of getting an IP address at all.

Quote:

(I'll solve someone elses problem later on to return the favor!)
That's exactly why I hang out on this board. The amount of help I've gotten far outweighs the help I've given.

Alien Bob 11-29-2005 04:10 PM

Seeing that the "dhcpcd -d ath0" was all you needed, did you edit the file /etc/rc.d/rc.inet1.conf to setup your (wireless) network card for DHCP at all?

You should have something in there (assuming you have already configured your eth0 device in there too and it's occupying all the [0] entries):
Code:

# Config information for ath0:
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[0]=""

That will cause the dhcpcd -d ath0 to be run on boot, so that you do not need to do that manually each time.

Eric


All times are GMT -5. The time now is 11:37 AM.