LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-29-2005, 12:13 PM   #1
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
Atheros wireless driving me crazy


Is it really this hard????
I need some serious help here.

Heres my lspci:
Code:
01:05.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)
Heres my lsmod:
Code:
ath_pci                68252  0
ath_rate_sample        13704  1 ath_pci
wlan                  126876  3 ath_pci,ath_rate_sample
ath_hal               146512  3 ath_pci,ath_rate_sample
I'm using a clean install of Slack 10.2, upgraded to the default 2.6.13 kernel from CD#2.

I've installed (in this order):
madwifi-20051008_2.6.13-i486-1.tgz
wireless-tools-28.pre10-i486-1.tgz
wpa_supplicant-20051008-i486-1.tgz

If I'm reading it right, The following links says it should work on unsecured AP's?
http://madwifi.org/wiki/UserDocs/Distro/Slackware

iwconfig gives me this:
Code:
ath0      IEEE 802.11g  ESSID:"linksys"  Nickname:"lap-cat"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:06:25:DB:C8:19
          Bit Rate:11 Mb/s   Tx-Power:18 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=71/94  Signal level=-24 dBm  Noise level=-95 dBm
          Rx invalid nwid:32  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Notice it does specify the linksys router I'm trying to connect to, but mozilla times out.
(yes, I unplug the network cable to ensure Its a wireless connection).
The laptop has an intel 10/100 NIC & the wireless.

Where am I going wrong?
-tw

Last edited by tw001_tw; 11-29-2005 at 12:25 PM.
 
Old 11-29-2005, 12:47 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Are you requesting or assigning an IP address?
 
Old 11-29-2005, 12:48 PM   #3
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Original Poster
Rep: Reputation: 31
I believe I am requesting one. Although I am open to the option.... whichever is easier
for accessing your average AP's (hotels, etc.)

-tw
 
Old 11-29-2005, 12:55 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Usually requesting one is easier so something like:

dhcpcd ath0 -d

(the -d makes dhcpcd a touch more verbose)

If you're not sure if your doing this, then odds are you aren't. A quick check of ifconfig will show if you have an IP or not.
 
Old 11-29-2005, 01:25 PM   #5
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Original Poster
Rep: Reputation: 31
GOT IT!

I know I tried dhcpcd ath0 at some point in time, but never the "-d".
I can't explain way, but its working now.
I just hope it stays working ina regular fashion.

thanks for the 'hand holding' Hangdog42, its appreciated.
-tw

(I'll solve someone elses problem later on to return the favor!)
 
Old 11-29-2005, 01:34 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Congrats on getting up and running! I'm guessing that earlier attempts with dhcpcd went awry for some other reason because all the -d flag is supposed to do is cause dhcpcd to log more information than it usually does. It shouldn't affect the process of getting an IP address at all.

Quote:
(I'll solve someone elses problem later on to return the favor!)
That's exactly why I hang out on this board. The amount of help I've gotten far outweighs the help I've given.
 
Old 11-29-2005, 05:10 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,390

Rep: Reputation: Disabled
Seeing that the "dhcpcd -d ath0" was all you needed, did you edit the file /etc/rc.d/rc.inet1.conf to setup your (wireless) network card for DHCP at all?

You should have something in there (assuming you have already configured your eth0 device in there too and it's occupying all the [0] entries):
Code:
# Config information for ath0:
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[0]=""
That will cause the dhcpcd -d ath0 to be run on boot, so that you do not need to do that manually each time.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ ] @ are driving me crazy FireInTheDark Linux - Software 1 11-28-2004 10:42 AM
Help this is driving me crazy!!!!!! Wolfy Linux - Hardware 1 07-07-2004 02:32 AM
.htaccess driving me crazy! Help! WorldBuilder Linux - Networking 9 09-18-2003 09:20 AM
wlan-ng is driving me crazy! andrew001 Linux - Hardware 19 04-28-2003 04:23 PM
Help with Linksys wireless card- driving me crazy ChepChep Linux - Wireless Networking 3 02-14-2003 08:53 PM


All times are GMT -5. The time now is 01:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration