LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   pkg-config query, installing the gtk+ library (http://www.linuxquestions.org/questions/linux-software-2/pkg-config-query-installing-the-gtk-library-464446/)

cypherpunk 07-15-2006 10:15 PM

pkg-config query, installing the gtk+ library
 
I am tring to install the gtk+ libraries and development file. Upon ./configure i get:

configure: error: Package requirements (glib-2.0 >= 2.7.1 atk >= 1.0.1 pango >= 1.9.0 cairo >= 0.9.2) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

I looked up /usr/lib/pkgconfig that contains .pc files. The glib i have is 2.10 , and the others too are of higher version. Then why this eror. I looked up the enviornment variables and PKG_CONFIG_PATH wasnt defined. I thus set it to '/usr/lib/pkgconfig' and '/usr/lib/pkgconfig/' and tried ./configure again. Yet i get the same error.

If it helps i'm on ubuntu 6.06LTS.

-----------my /usr/lib/pkgconfig/glib-2.0.pc ------------
prefix=/usr
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include

glib_genmarshal=glib-genmarshal
gobject_query=gobject-query
glib_mkenums=glib-mkenums

Name: GLib
Description: C Utility Library
Version: 2.10.3
Libs: -L${libdir} -lglib-2.0
Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include

-----------my /usr/lib/pkgconfig/cairo.pc --------------
prefix=/usr
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include

Name: cairo
Description: Multi-platform 2D graphics library
Version: 1.0.4

Requires.private: freetype2 >= 8.0.2 fontconfig xrender libpng12
Libs: -L${libdir} -lcairo
Cflags: -I${includedir}/cairo


Regards

ugenn 07-16-2006 02:17 AM

Check your config.log for details.


All times are GMT -5. The time now is 11:33 AM.