LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   not able to install any application (http://www.linuxquestions.org/questions/linux-software-2/not-able-to-install-any-application-927919/)

vpriya 02-06-2012 12:53 PM

not able to install any application
 
i have recently installed ubuntu 10.04. i tried to install few softwares it worked, then i got a problem and searched forums it said to delete the var/lib/dpkg/info(i guess). i did that and it worked. again now i'm not able to install softwares. i got the following error when i tried to update:

~$ sudo apt-get update
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the list directory


i again surfed nd found : :~$ sudo killall dpkg

but i got error: "dpkg: no process found"

what to do now?

klearview 02-06-2012 01:09 PM

Could you post the result of this command here:

Quote:

ps ax | egrep 'apt|dpkg|deb'

vpriya 02-06-2012 01:13 PM

priya@ubuntu:~$ ps ax | egrep 'apt|dpkg|deb'
4501 ? S 0:00 /usr/bin/python /usr/share/apt-xapian-index/update-apt-xapian-index-dbus
8872 pts/1 R+ 0:00 egrep --color=auto apt|dpkg|deb

klearview 02-06-2012 05:26 PM

If update manager is not running (or another package management utility), and it does not seem to be, you can remove apt lock:
Quote:

sudo rm /var/lib/apt/lists/lock
but keep in mind that this can cause system issues so only do it if you are sure no package management application is running.

vpriya 02-07-2012 02:00 AM

i tried update manager before trying the command u mentioned but i got a new error:

E: /var/cache/apt/archives/xz-utils_4.999.9beta+20091116-1_i386.deb: unable to create updated files list file for package xz-utils
E: /var/cache/apt/archives/patch_2.6-2ubuntu1_i386.deb: unable to create updated files list file for package patch
E: /var/cache/apt/archives/dpkg-dev_1.15.5.6ubuntu4.5_all.deb: unable to create updated files list file for package dpkg-dev
E: /var/cache/apt/archives/build-essential_11.4build1_i386.deb: unable to create updated files list file for package build-essential
E: /var/cache/apt/archives/dkms_2.1.1.2-2ubuntu1_all.deb: unable to create updated files list file for package dkms
E: /var/cache/apt/archives/fakeroot_1.14.4-1ubuntu1_i386.deb: unable to create updated files list file for package fakeroot
E: /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu5_i386.deb: unable to create updated files list file for package fglrx
E: /var/cache/apt/archives/fglrx-amdcccle_2%3a8.723.1-0ubuntu5_i386.deb: unable to create updated files list file for package fglrx-amdcccle
E: /var/cache/apt/archives/liberror-perl_0.17-1_all.deb: unable to create updated files list file for package liberror-perl
E: /var/cache/apt/archives/libdigest-sha1-perl_2.12-1build1_i386.deb: unable to create updated files list file for package libdigest-sha1-perl
E: /var/cache/apt/archives/git-core_1%3a1.7.0.4-1ubuntu0.2_i386.deb: unable to create updated files list file for package git-core
E: /var/cache/apt/archives/libboost1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost1.42-dev
E: /var/cache/apt/archives/libboost-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-dev
E: /var/cache/apt/archives/libboost-serialization1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-serialization1.42-dev
E: /var/cache/apt/archives/libboost-date-time1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-date-time1.42-dev
E: /var/cache/apt/archives/libboost-date-time-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-date-time-dev
E: /var/cache/apt/archives/libboost-system1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-system1.42-dev
E: /var/cache/apt/archives/libboost-filesystem1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-filesystem1.42-dev
E: /var/cache/apt/archives/libboost-filesystem-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-filesystem-dev
E: /var/cache/apt/archives/libboost-test1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-test1.42-dev
E: /var/cache/apt/archives/libboost-graph1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-graph1.42-dev
E: /var/cache/apt/archives/libboost-graph-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-graph-dev
E: /var/cache/apt/archives/libboost-graph-parallel1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-graph-parallel1.42-dev
E: /var/cache/apt/archives/libboost-graph-parallel-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-graph-parallel-dev
E: /var/cache/apt/archives/libboost-regex1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-regex1.42-dev
E: /var/cache/apt/archives/libboost-iostreams1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-iostreams1.42-dev
E: /var/cache/apt/archives/libboost-iostreams-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-iostreams-dev
E: /var/cache/apt/archives/libboost-math1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-math1.42-dev
E: /var/cache/apt/archives/libboost-math-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-math-dev
E: /var/cache/apt/archives/libboost-mpi1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-mpi1.42-dev
E: /var/cache/apt/archives/libboost-mpi-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-mpi-dev
E: /var/cache/apt/archives/libboost-mpi-python-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-mpi-python-dev
E: /var/cache/apt/archives/libboost-program-options1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-program-options1.42-dev
E: /var/cache/apt/archives/libboost-program-options-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-program-options-dev
E: /var/cache/apt/archives/libboost-python1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-python1.42-dev
E: /var/cache/apt/archives/libboost-python-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-python-dev
E: /var/cache/apt/archives/libboost-regex-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-regex-dev
E: /var/cache/apt/archives/libboost-serialization-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-serialization-dev
E: /var/cache/apt/archives/libboost-signals1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-signals1.42-dev
E: /var/cache/apt/archives/libboost-signals-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-signals-dev
E: /var/cache/apt/archives/libboost-system-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-system-dev
E: /var/cache/apt/archives/libboost-test-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-test-dev
E: /var/cache/apt/archives/libboost-thread1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-thread1.42-dev
E: /var/cache/apt/archives/libboost-thread-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-thread-dev
E: /var/cache/apt/archives/libboost-wave1.42-dev_1.42.0-3~lucid1_i386.deb: unable to create updated files list file for package libboost-wave1.42-dev
E: /var/cache/apt/archives/libboost-wave-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-wave-dev
E: /var/cache/apt/archives/libboost-all-dev_1.42.0.1~lucid1_i386.deb: unable to create updated files list file for package libboost-all-dev
E: /var/cache/apt/archives/libyaml-0-2_0.1.3-1_i386.deb: unable to create updated files list file for package libyaml-0-2
E: /var/cache/apt/archives/mercurial-common_1.4.3-1_all.deb: unable to create updated files list file for package mercurial-common
E: /var/cache/apt/archives/mercurial_1.4.3-1_i386.deb: unable to create updated files list file for package mercurial
E: /var/cache/apt/archives/python-setuptools_0.6.10-4ubuntu1_all.deb: unable to create updated files list file for package python-setuptools

actually i'm trying to install ROS but i have errors in update stage itself..then when i tried few ros installation commands it showed in between

51 not fully installed or removed...

what should i do to remove them or install?

vpriya 02-07-2012 02:05 AM

in terminal when i gave sudo apt-get update i got this:

priya@ubuntu:~$ sudo apt-get update
[sudo] password for priya:
Hit http://packages.ros.org lucid Release.gpg
Ign http://packages.ros.org/ros/ubuntu/ lucid/main Translation-en_US
Hit http://us.archive.ubuntu.com lucid Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Hit http://security.ubuntu.com lucid-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Hit http://ppa.launchpad.net lucid Release.gpg
Ign http://ppa.launchpad.net/gezakovacs/boost/ubuntu/ lucid/main Translation-en_US
Hit http://ppa.launchpad.net lucid Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com lucid-updates Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com lucid Release
Hit http://security.ubuntu.com lucid-security Release
Ign http://ppa.launchpad.net/openrave/release/ubuntu/ lucid/main Translation-en_US
Hit http://packages.ros.org lucid Release
Hit http://ppa.launchpad.net lucid Release
Hit http://us.archive.ubuntu.com lucid-updates Release
Hit http://ppa.launchpad.net lucid Release
Hit http://security.ubuntu.com lucid-security/main Packages
Ign http://packages.ros.org lucid/main Packages
Hit http://us.archive.ubuntu.com lucid/main Packages
Hit http://us.archive.ubuntu.com lucid/restricted Packages
Hit http://us.archive.ubuntu.com lucid/main Sources
Hit http://us.archive.ubuntu.com lucid/restricted Sources
Hit http://us.archive.ubuntu.com lucid/universe Packages
Hit http://us.archive.ubuntu.com lucid/universe Sources
Hit http://ppa.launchpad.net lucid/main Packages
Hit http://security.ubuntu.com lucid-security/restricted Packages
Hit http://security.ubuntu.com lucid-security/main Sources
Hit http://security.ubuntu.com lucid-security/restricted Sources
Hit http://security.ubuntu.com lucid-security/universe Packages
Hit http://security.ubuntu.com lucid-security/universe Sources
Hit http://us.archive.ubuntu.com lucid/multiverse Packages
Hit http://security.ubuntu.com lucid-security/multiverse Packages
Hit http://us.archive.ubuntu.com lucid/multiverse Sources
Ign http://packages.ros.org lucid/main Packages
Hit http://us.archive.ubuntu.com lucid-updates/main Packages
Hit http://us.archive.ubuntu.com lucid-updates/restricted Packages
Hit http://us.archive.ubuntu.com lucid-updates/main Sources
Hit http://us.archive.ubuntu.com lucid-updates/restricted Sources
Hit http://us.archive.ubuntu.com lucid-updates/universe Packages
Hit http://ppa.launchpad.net lucid/main Packages
Hit http://us.archive.ubuntu.com lucid-updates/universe Sources
Hit http://security.ubuntu.com lucid-security/multiverse Sources
Hit http://us.archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://us.archive.ubuntu.com lucid-updates/multiverse Sources
Hit http://packages.ros.org lucid/main Packages
Reading package lists... Done
priya@ubuntu:~$


does this mean its installed. but when i give install updates in update manager i got errors as i hav posted above. i hav no clue of whats going on. can anyone help me get rid of those errors???

klearview 02-07-2012 02:38 AM

now do:

Quote:

sudo dpkg --configure -a

vpriya 02-07-2012 04:45 AM

nothing happened after this command

priya@ubuntu:~$ sudo dpkg --configure -a
priya@ubuntu:~$

i still get the same errors
what to do?

vpriya 02-10-2012 12:28 AM

after i did all the commands u gave i'm still getting errors...

i initially tried to install my mts datacard i had a problem. i couldn't install crossplatformui. so i googled and i found the e/librror and replies. it said to delete var/lib/dpkg/info folder. i did that after that i was able to install and it worked. does that has anything to do with these errors. i'm new so i'm not able to understand. i just followed the replies.

pls can anyone reply. i'm not even able to install missing plugins like adobe flash.

vpriya 02-10-2012 01:25 AM

after i did all the commands u gave i'm still getting errors...

i initially tried to install my mts datacard i had a problem. i couldn't install crossplatformui. so i googled and i found the e/librror and replies. it said to delete var/lib/dpkg/info folder. i did that after that i was able to install and it worked. does that has anything to do with these errors. i'm new so i'm not able to understand. i just followed the replies.

pls can anyone reply. i'm not even able to install missing plugins like adobe flash.

vpriya 02-10-2012 01:30 AM

i'm still getting errors

i initially tried to install my datacard but i had problem with crossplatformui installation.so i googled and fonud a solution. according to that i removed the folder var/lib/dpkg/info.i got my modem connected then.does that has anything to with these errors.

pls can anyone reply me. i'm not even able to install any software.

frankbell 02-10-2012 09:33 PM

Post the contents of the /etc/apt/sources.list file.

vpriya 02-11-2012 12:47 AM

i hav pasted below the files and their contents present in etc/apt/sources.list.d

gezakovacs-boost-lucid.list
deb http://ppa.launchpad.net/gezakovacs/boost/ubuntu lucid main
gezakovacs-boost-lucid.list.save
deb http://ppa.launchpad.net/gezakovacs/boost/ubuntu lucid main
openrave-release-lucid.list
deb http://ppa.launchpad.net/openrave/release/ubuntu lucid main
openrave-release-lucid.list.save
deb http://ppa.launchpad.net/openrave/release/ubuntu lucid main
ros-latest.list
deb http://packages.ros.org/ros/ubuntu lucid main


All times are GMT -5. The time now is 12:25 AM.