LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   mplayer problem (http://www.linuxquestions.org/questions/linux-software-2/mplayer-problem-49620/)

ramu_ak 03-13-2003 11:26 AM

mplayer problem
 
hi there
i installed mplayer0.90 recently in my rh 8.0 linux. gmplayer is working properly but gives some errors and it gets stucked some times. i installed mplayer with arial font source file unzipped in the directory /usr/share/mplayer.also when i enter gmplayer <file-name> in my terminal i m getting the following errors

Reading /root/.mplayer/codecs.conf: 50 audio & 135 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
Loading config '/mnt/wintemp/docume~1/mtech/desktop/2.avi.conf'
Reading config file /mnt/wintemp/docume~1/mtech/desktop/2.avi.conf
option without parameter
parse error
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed

thnx for any help in advance
bye

LordOfAtlantis 04-01-2003 06:40 AM

Looks to me like you put the fonts in the wrong directory.

At the end of the man page of mplayer, you find the default directories where mplayer looks for the fonts.

In my man page it says: ~/.mplayer/font/

So you should unzip the fontpackage to this directory. If you're a normal user this is /home/username/.mplayer/font/, if you're root this is /root/.mplayer/font/.

In the output it looks like you can also install a systemwide font. This font should be unzipped in the directory /usr/local/share/mplayer/font/ (I guess you forgot the /local/ in between the /usr/ and the /share/).

Hope this helps.

LoA

zokik 06-22-2003 01:41 PM

I have the same problem. How did you work it out?

I unzipped the fonts archive. There are 4 directories for various font sizes, I chose size 24. So I copied the files from font-arial-24-iso-8859-2 to /usr/local/share/mplayer/font/ and I get this every time I start gmplayer:

New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.

Then I copied also to /usr/local/share/mplayer/font/font-arial-24-iso-8859-2 and to ~/.mplayer/font/ and still get that error message.

All those font files have read permissions for everyone.

I don't have that subfont.ttf file gmplayer is complaining about. Is that required and if yes, how to get or generate it?

MadNewbie 06-22-2003 06:56 PM

Hi

I had the same message popping up when I opened gmplayer, but as it worked well just to click ok on the popup message box, and me beeing too lazy to install the fonts I never bothered to do anything about it until i read this thread though.

All I did was to choose my fontsize from the various packages, and copy those 5 or 6 files to ~/.mplayer/font/ and the error message dissappers.

Hope this helps.

zokik 06-22-2003 07:40 PM

The problem was in ~/.mplayer/gui.conf, there was a line

font_name = "/usr/share/mplayer/font/font.desc"

it should be of course

font_name = "/usr/local/share/mplayer/font/font.desc"

From the mplayer README:
Quote:

____________________________________________
STEP5: Installing the onscreen display fonts
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Unpack the archive and choose one of the available font sizes. Then copy the
font files of the corresponding size into /usr/local/share/mplayer/font/ or
~/.mplayer/font/ (or whatever you set with './configure --datadir=DIR').
Since I did a plain ordinary
,/configure --enable-gui
make
su
make install
I guess it was not really my fault...

tux0r 06-11-2004 03:31 AM

I just used "apt-get install mplayer"
and I didn't get any errors


All times are GMT -5. The time now is 03:54 AM.