LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-13-2003, 10:26 AM   #1
ramu_ak
Member
 
Registered: Feb 2003
Posts: 38

Rep: Reputation: 15
mplayer problem


hi there
i installed mplayer0.90 recently in my rh 8.0 linux. gmplayer is working properly but gives some errors and it gets stucked some times. i installed mplayer with arial font source file unzipped in the directory /usr/share/mplayer.also when i enter gmplayer <file-name> in my terminal i m getting the following errors

Reading /root/.mplayer/codecs.conf: 50 audio & 135 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
Loading config '/mnt/wintemp/docume~1/mtech/desktop/2.avi.conf'
Reading config file /mnt/wintemp/docume~1/mtech/desktop/2.avi.conf
option without parameter
parse error
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed

thnx for any help in advance
bye
 
Old 04-01-2003, 05:40 AM   #2
LordOfAtlantis
LQ Newbie
 
Registered: Apr 2003
Location: Belgium
Distribution: SuSE, Mandrake
Posts: 3

Rep: Reputation: 0
Looks to me like you put the fonts in the wrong directory.

At the end of the man page of mplayer, you find the default directories where mplayer looks for the fonts.

In my man page it says: ~/.mplayer/font/

So you should unzip the fontpackage to this directory. If you're a normal user this is /home/username/.mplayer/font/, if you're root this is /root/.mplayer/font/.

In the output it looks like you can also install a systemwide font. This font should be unzipped in the directory /usr/local/share/mplayer/font/ (I guess you forgot the /local/ in between the /usr/ and the /share/).

Hope this helps.

LoA
 
Old 06-22-2003, 12:41 PM   #3
zokik
Member
 
Registered: Dec 2002
Distribution: SuSE 8.2
Posts: 58

Rep: Reputation: 15
I have the same problem. How did you work it out?

I unzipped the fonts archive. There are 4 directories for various font sizes, I chose size 24. So I copied the files from font-arial-24-iso-8859-2 to /usr/local/share/mplayer/font/ and I get this every time I start gmplayer:

New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.

Then I copied also to /usr/local/share/mplayer/font/font-arial-24-iso-8859-2 and to ~/.mplayer/font/ and still get that error message.

All those font files have read permissions for everyone.

I don't have that subfont.ttf file gmplayer is complaining about. Is that required and if yes, how to get or generate it?
 
Old 06-22-2003, 05:56 PM   #4
MadNewbie
Member
 
Registered: Jun 2003
Posts: 31

Rep: Reputation: 15
Hi

I had the same message popping up when I opened gmplayer, but as it worked well just to click ok on the popup message box, and me beeing too lazy to install the fonts I never bothered to do anything about it until i read this thread though.

All I did was to choose my fontsize from the various packages, and copy those 5 or 6 files to ~/.mplayer/font/ and the error message dissappers.

Hope this helps.
 
Old 06-22-2003, 06:40 PM   #5
zokik
Member
 
Registered: Dec 2002
Distribution: SuSE 8.2
Posts: 58

Rep: Reputation: 15
The problem was in ~/.mplayer/gui.conf, there was a line

font_name = "/usr/share/mplayer/font/font.desc"

it should be of course

font_name = "/usr/local/share/mplayer/font/font.desc"

From the mplayer README:
Quote:
____________________________________________
STEP5: Installing the onscreen display fonts
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Unpack the archive and choose one of the available font sizes. Then copy the
font files of the corresponding size into /usr/local/share/mplayer/font/ or
~/.mplayer/font/ (or whatever you set with './configure --datadir=DIR').
Since I did a plain ordinary
,/configure --enable-gui
make
su
make install
I guess it was not really my fault...
 
Old 06-11-2004, 02:31 AM   #6
tux0r
LQ Newbie
 
Registered: Jun 2004
Posts: 2

Rep: Reputation: 0
Wink

I just used "apt-get install mplayer"
and I didn't get any errors
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer problem saipraveen Linux - Newbie 10 06-13-2005 11:56 PM
yet another MPlayer problem raffi Slackware 5 01-13-2005 03:19 PM
mplayer problem cool_ashwin22 Fedora 0 10-20-2004 09:50 AM
Mplayer Problem. Itsu Linux - Software 5 02-02-2004 09:27 PM
MPlayer Problem #1 Micro420 Linux - Software 9 09-12-2003 04:54 PM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration