LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Missing initrd option in 2.6.4 kernel (http://www.linuxquestions.org/questions/linux-software-2/missing-initrd-option-in-2-6-4-kernel-163945/)

HokieEngr 03-29-2004 08:09 PM

Missing initrd option in 2.6.4 kernel
 
I have just unpacked the full code for 2.6.4 and typed 'make xconfig'. However, under block devices where initrd support normally lives, there is so such option! Also, upon examining the .config file that was created, I noticed the option CONFIG_BLK_DEV_INITRD is missing.

Has anyone else run into this?? Any idea what is going on??

Thanks!
Bob

rberry88 03-29-2004 08:45 PM

Is there a specific reason that you need to use a initrd line when you boot your kernel?? It seems the initrd is going the way of the dodo, I mean it is being seen in fewer and fewer places now. I haven't used one since I upgraded from kernel 2.4.20->2.4.24.

rberry88

HokieEngr 03-29-2004 10:53 PM

Yeah, I agree. However, to the best of my knowledge, bootsplash (www.bootsplash.org) requires the use of an initrd image. If this is not the case, let me know!

Thanks!
Bob

mardanian 03-29-2004 11:11 PM

after upgrading to .4 and running #make install
initrd image creating for me in /boot directory. However I didn't select anything for it in menuconfig

mardanian 03-29-2004 11:17 PM

Go to "Console drivers" -> "Frame-Buffer support" and select "VESA VGA graphics console" (or possibly another framebuffer driver, if one is available for your graphics hardware) and turn on "Use splash screen instead of boot logo". Also be sure to enable "Initial Ramdisk support" in "Block Devices" Save your new config and compile a new kernel. Copy the kernel to your /boot directory and make sure that you have a boot entry for it in your bootloader config.

HokieEngr 03-29-2004 11:22 PM

Yes, see thats the problem. There is no Initrd option in block devices anymore!! I'm not sure why...or where it went!

Bob

mustang335 03-30-2004 10:03 AM

I am rather new at this linux stuff, been checking it out over the last couple of years. I have redhat 9.0 installed with a linux-2.4.20-8 kernal. I recompiled a kernal with 2.6.2 on the trying to get lilo to boot i find i lack 2 things. one is a file initrd-2.6.2 . the initrd-2.4.20-8 is in /boot . the /etc/lilo.conf refers to it in order to boot. I also do not have a 2.6.2 img file which the /etc/lilo.conf refers to also on boot. There is a 2.4.20-8.img file in my /boot but I can't find anything similar to bring over from /home/marty/linux-2.6.2/arch/386/boot where my boot files are stored. I would appreciate any info. Buffalo has a version of linux with 2.6.2 installed by default. Also I am trying to create a bootable disk for a version of linux called damned small linux. any Ideas would be appreciated. I've learned a lot from this site. keep up the good work Marty

LinuxSrilanka 04-06-2004 02:20 AM

Did u select Ram Disk support ...

mustang335 04-06-2004 02:29 AM

I fixed that problem. Yes it was to load ramdisk support into the kernal not as a module. That took care of that but I must have missed installing a couple items cause i have ip table errors and usb uhci or some thing of that nature. Have tried to load modutils new but rpm doesn't work now and the compiling is still a little new to me. I can boot either the 2.4.20-8 kernal or the 2.6.2 kernal. seems a bit of work is necessary to upgrade. I had no problems with 2.4 sound now doesn't work. I think i enabled ossa emulation in kernal. Oh well its all a fun challenge anyhow. At least one can in time repair things. Gives me something to do. Thanks for the help Marty


All times are GMT -5. The time now is 09:21 PM.