LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-29-2004, 07:09 PM   #1
HokieEngr
LQ Newbie
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 8

Rep: Reputation: 0
Missing initrd option in 2.6.4 kernel


I have just unpacked the full code for 2.6.4 and typed 'make xconfig'. However, under block devices where initrd support normally lives, there is so such option! Also, upon examining the .config file that was created, I noticed the option CONFIG_BLK_DEV_INITRD is missing.

Has anyone else run into this?? Any idea what is going on??

Thanks!
Bob
 
Old 03-29-2004, 07:45 PM   #2
rberry88
Member
 
Registered: Aug 2003
Location: Arlington Heights, IL USA
Distribution: Fedora Core 1 & WinXP Pro & Gentoo 1.4 & Arch Linux
Posts: 558

Rep: Reputation: 30
Is there a specific reason that you need to use a initrd line when you boot your kernel?? It seems the initrd is going the way of the dodo, I mean it is being seen in fewer and fewer places now. I haven't used one since I upgraded from kernel 2.4.20->2.4.24.

rberry88
 
Old 03-29-2004, 09:53 PM   #3
HokieEngr
LQ Newbie
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
Yeah, I agree. However, to the best of my knowledge, bootsplash (www.bootsplash.org) requires the use of an initrd image. If this is not the case, let me know!

Thanks!
Bob
 
Old 03-29-2004, 10:11 PM   #4
mardanian
Member
 
Registered: Mar 2004
Distribution: Fedora
Posts: 254

Rep: Reputation: 30
after upgrading to .4 and running #make install
initrd image creating for me in /boot directory. However I didn't select anything for it in menuconfig
 
Old 03-29-2004, 10:17 PM   #5
mardanian
Member
 
Registered: Mar 2004
Distribution: Fedora
Posts: 254

Rep: Reputation: 30
Go to "Console drivers" -> "Frame-Buffer support" and select "VESA VGA graphics console" (or possibly another framebuffer driver, if one is available for your graphics hardware) and turn on "Use splash screen instead of boot logo". Also be sure to enable "Initial Ramdisk support" in "Block Devices" Save your new config and compile a new kernel. Copy the kernel to your /boot directory and make sure that you have a boot entry for it in your bootloader config.
 
Old 03-29-2004, 10:22 PM   #6
HokieEngr
LQ Newbie
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 8

Original Poster
Rep: Reputation: 0
Yes, see thats the problem. There is no Initrd option in block devices anymore!! I'm not sure why...or where it went!

Bob
 
Old 03-30-2004, 09:03 AM   #7
mustang335
LQ Newbie
 
Registered: Mar 2004
Location: coventry, connecticut, usa
Distribution: Puppy 5.6.1
Posts: 27

Rep: Reputation: 15
I am rather new at this linux stuff, been checking it out over the last couple of years. I have redhat 9.0 installed with a linux-2.4.20-8 kernal. I recompiled a kernal with 2.6.2 on the trying to get lilo to boot i find i lack 2 things. one is a file initrd-2.6.2 . the initrd-2.4.20-8 is in /boot . the /etc/lilo.conf refers to it in order to boot. I also do not have a 2.6.2 img file which the /etc/lilo.conf refers to also on boot. There is a 2.4.20-8.img file in my /boot but I can't find anything similar to bring over from /home/marty/linux-2.6.2/arch/386/boot where my boot files are stored. I would appreciate any info. Buffalo has a version of linux with 2.6.2 installed by default. Also I am trying to create a bootable disk for a version of linux called damned small linux. any Ideas would be appreciated. I've learned a lot from this site. keep up the good work Marty
 
Old 04-06-2004, 01:20 AM   #8
LinuxSrilanka
LQ Newbie
 
Registered: Mar 2004
Posts: 26

Rep: Reputation: 15
Did u select Ram Disk support ...
 
Old 04-06-2004, 01:29 AM   #9
mustang335
LQ Newbie
 
Registered: Mar 2004
Location: coventry, connecticut, usa
Distribution: Puppy 5.6.1
Posts: 27

Rep: Reputation: 15
I fixed that problem. Yes it was to load ramdisk support into the kernal not as a module. That took care of that but I must have missed installing a couple items cause i have ip table errors and usb uhci or some thing of that nature. Have tried to load modutils new but rpm doesn't work now and the compiling is still a little new to me. I can boot either the 2.4.20-8 kernal or the 2.6.2 kernal. seems a bit of work is necessary to upgrade. I had no problems with 2.4 sound now doesn't work. I think i enabled ossa emulation in kernal. Oh well its all a fun challenge anyhow. At least one can in time repair things. Gives me something to do. Thanks for the help Marty
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic - Missing "initrd.img-2.6.8-2-686" in /boot MKSrivastava Debian 2 12-02-2005 03:09 PM
missing initrd HmmLinux Linux - General 2 11-14-2004 10:40 AM
Missing iocharset option in mount [kernel-2.6.6] symworks Linux - General 1 06-06-2004 02:50 AM
kernel 2.4.22 initrd missing ??? qwijibow Linux - Software 6 11-02-2003 08:37 PM
Slack /RH dual boot initrd missing issue FuzzyTheBear Slackware 1 03-06-2003 02:10 PM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration