LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   keep having to reconfigure alsa everytime i turn computer on (http://www.linuxquestions.org/questions/linux-software-2/keep-having-to-reconfigure-alsa-everytime-i-turn-computer-on-719565/)

rich13348 04-16-2009 07:59 AM

keep having to reconfigure alsa everytime i turn computer on
 
I have configured alsa to get my sound card working but every time i turn the computer on again i have to reconfigure it get my sound working again i am using debian lenny my soundcard is a cm8738 chipset genius 4.1 soundmaker

bathory 04-16-2009 08:23 AM

Once you have configured alsa, run:
Code:

alsactl store
to store your settings
On reboot your distro should run "alsactl restore" to bring up your settings. If it doesn't, you can add it to your init scripts.

rich13348 04-16-2009 09:15 AM

i tried this and it didnt work i also tried running alsactl restore as well but that did not work either the only thing that seems to work is running alsaconf again

bathory 04-16-2009 12:11 PM

I don't know about debian specifically, but in general, you can run alsamixer to unmute and adjust sound settings and then "alsactl store" to store these setting in /etc/asound.state and "alsactl restore" on boot to bring up these settings. Alsaconf is to identify the correct kernel modules for your sound card.

Quakeboy02 04-16-2009 12:23 PM

If you're using Gnome, the following should save your session options. You can also check the box to always save them.

System->Preferences->Sessions->Session Options->Remember Currently Running Applications

rich13348 04-16-2009 12:37 PM

Quote:

Originally Posted by Quakeboy02 (Post 3511212)
If you're using Gnome, the following should save your session options. You can also check the box to always save them.

System->Preferences->Sessions->Session Options->Remember Currently Running Applications

tried this as well but it does not seem to remember the settings set by alsaconf because i have to run that every time to get it to work unless something else is wrong.

Quakeboy02 04-16-2009 04:13 PM

Quote:

Originally Posted by rich13348 (Post 3511229)
tried this as well but it does not seem to remember the settings set by alsaconf because i have to run that every time to get it to work unless something else is wrong.

I'm kinda concerned about my post, anyway. It used to say save settings. I'll look around some more to see if they moved it.

Quakeboy02 04-16-2009 04:18 PM

OK try this one:

System->Preferences->Sound

rich13348 04-16-2009 06:26 PM

ok i looked at system>preferences>sound before i restarted and the default mixer tracks device was set to CMI8738 which is my sound card. i did a restart and found that it has now changed to NVidia CK804 so it seems i have to get alsa to set it to my sound card every time so not sure how to make that stick.

505 04-16-2009 07:45 PM

alsa problems
 
I do not know how relevant this is. But here goes.
The latest Fedora 10 also had a problem with alsa.
Using xmms the music was skipping, I have not run
across this problem in 8 years of using open
source OS's. No matter what I tried I was unable
to get alsa working right.

I finally fixed the problem by switching over to
OSS. I know this is an older sound system, but if
it works it works. It is possible to change the
sound server in xmms only, it is also possible to
make this change systemwide. Click the K button,
then click Control Center, click Sound and
Multimedia, Click Sound System, Click the
Hardware tab, Select the audio device drop down
menu, choose Open Sound System.

rich13348 04-17-2009 05:06 AM

Quote:

Originally Posted by 505 (Post 3511640)
I do not know how relevant this is. But here goes.
The latest Fedora 10 also had a problem with alsa.
Using xmms the music was skipping, I have not run
across this problem in 8 years of using open
source OS's. No matter what I tried I was unable
to get alsa working right.

I finally fixed the problem by switching over to
OSS. I know this is an older sound system, but if
it works it works. It is possible to change the
sound server in xmms only, it is also possible to
make this change systemwide. Click the K button,
then click Control Center, click Sound and
Multimedia, Click Sound System, Click the
Hardware tab, Select the audio device drop down
menu, choose Open Sound System.

ok but the thing is i dont have fedora so the bit where you tell me what to do doesnt mean much to me not sue if someone knows the equivalent for debian that would help thanks


All times are GMT -5. The time now is 06:42 PM.