LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-16-2009, 07:59 AM   #1
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Rep: Reputation: 15
keep having to reconfigure alsa everytime i turn computer on


I have configured alsa to get my sound card working but every time i turn the computer on again i have to reconfigure it get my sound working again i am using debian lenny my soundcard is a cm8738 chipset genius 4.1 soundmaker
 
Old 04-16-2009, 08:23 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,905

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Once you have configured alsa, run:
Code:
alsactl store
to store your settings
On reboot your distro should run "alsactl restore" to bring up your settings. If it doesn't, you can add it to your init scripts.
 
Old 04-16-2009, 09:15 AM   #3
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Original Poster
Rep: Reputation: 15
i tried this and it didnt work i also tried running alsactl restore as well but that did not work either the only thing that seems to work is running alsaconf again
 
Old 04-16-2009, 12:11 PM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,905

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
I don't know about debian specifically, but in general, you can run alsamixer to unmute and adjust sound settings and then "alsactl store" to store these setting in /etc/asound.state and "alsactl restore" on boot to bring up these settings. Alsaconf is to identify the correct kernel modules for your sound card.
 
Old 04-16-2009, 12:23 PM   #5
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
If you're using Gnome, the following should save your session options. You can also check the box to always save them.

System->Preferences->Sessions->Session Options->Remember Currently Running Applications
 
Old 04-16-2009, 12:37 PM   #6
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Quakeboy02 View Post
If you're using Gnome, the following should save your session options. You can also check the box to always save them.

System->Preferences->Sessions->Session Options->Remember Currently Running Applications
tried this as well but it does not seem to remember the settings set by alsaconf because i have to run that every time to get it to work unless something else is wrong.
 
Old 04-16-2009, 04:13 PM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
Quote:
Originally Posted by rich13348 View Post
tried this as well but it does not seem to remember the settings set by alsaconf because i have to run that every time to get it to work unless something else is wrong.
I'm kinda concerned about my post, anyway. It used to say save settings. I'll look around some more to see if they moved it.
 
Old 04-16-2009, 04:18 PM   #8
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,240

Rep: Reputation: 121Reputation: 121
OK try this one:

System->Preferences->Sound
 
Old 04-16-2009, 06:26 PM   #9
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Original Poster
Rep: Reputation: 15
ok i looked at system>preferences>sound before i restarted and the default mixer tracks device was set to CMI8738 which is my sound card. i did a restart and found that it has now changed to NVidia CK804 so it seems i have to get alsa to set it to my sound card every time so not sure how to make that stick.
 
Old 04-16-2009, 07:45 PM   #10
505
LQ Newbie
 
Registered: Apr 2009
Posts: 13

Rep: Reputation: 1
alsa problems

I do not know how relevant this is. But here goes.
The latest Fedora 10 also had a problem with alsa.
Using xmms the music was skipping, I have not run
across this problem in 8 years of using open
source OS's. No matter what I tried I was unable
to get alsa working right.

I finally fixed the problem by switching over to
OSS. I know this is an older sound system, but if
it works it works. It is possible to change the
sound server in xmms only, it is also possible to
make this change systemwide. Click the K button,
then click Control Center, click Sound and
Multimedia, Click Sound System, Click the
Hardware tab, Select the audio device drop down
menu, choose Open Sound System.
 
Old 04-17-2009, 05:06 AM   #11
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by 505 View Post
I do not know how relevant this is. But here goes.
The latest Fedora 10 also had a problem with alsa.
Using xmms the music was skipping, I have not run
across this problem in 8 years of using open
source OS's. No matter what I tried I was unable
to get alsa working right.

I finally fixed the problem by switching over to
OSS. I know this is an older sound system, but if
it works it works. It is possible to change the
sound server in xmms only, it is also possible to
make this change systemwide. Click the K button,
then click Control Center, click Sound and
Multimedia, Click Sound System, Click the
Hardware tab, Select the audio device drop down
menu, choose Open Sound System.
ok but the thing is i dont have fedora so the bit where you tell me what to do doesnt mean much to me not sue if someone knows the equivalent for debian that would help thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
run everytime i start the computer sagar.1986 Ubuntu 2 04-29-2007 07:47 AM
Computer restarting everytime frjbms@yahoo.com Linux - Hardware 2 01-19-2007 02:18 AM
alsa dies everytime i close xmms mipia Debian 3 12-25-2004 08:02 PM
turn off computer spidna Slackware 2 08-12-2004 12:18 PM
Everytime restart MDK, I have to reconfigure my SBLive 5.1 card to get sound Fear58 Linux - Hardware 3 07-12-2004 09:37 PM


All times are GMT -5. The time now is 11:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration