LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ubuntu will not mount my other hard drive (http://www.linuxquestions.org/questions/linux-newbie-8/ubuntu-will-not-mount-my-other-hard-drive-294992/)

Trance56k 02-25-2005 10:40 PM

Ubuntu will not mount my other hard drive
 
I just installed Ubuntu. The install was a succes! But I have one problem. I have a bunch of music I would like to listen to off my windows hard drive. I check fstab and its not listed. I checked device manager and saw both my hard drives including the the hard drive with windows. Any ideas :Pengy:




:newbie:

s_deepak_123 02-25-2005 11:18 PM

First, you need to find out in which partition music is stored. Usually, it's like this:
C drive-> /dev/hda1
D drive-> /dev/hda5
E drive-> /dev/hda6
F drive-> /dev/hda7
Note that this is for Primary Master.
If the hard drive is Primary slave, replace hda by hdb
For secondary master, it is hdc and for secondary slave, it is hdd
Now, assuming that your music is stored in E drive,
1: login ass root
2: Create a mount point. This is done by typing "mkdir /mnt/edrive" (without quotes)
3: mount the device on the mount point. This is done by "mount /dev/hda6 /mnt/edrive"
Now, all your music is found at /mnt/edrive.
To mount the partition every time automatically, you need to add the following line at the end of the file /etc/fstab

/dev/hda6 /mnt/edrive vfat defaults 0 0

You can change the file system type if it is not vfat. You can try auto.

Trance56k 02-26-2005 01:03 AM

Thanks for the help that worked but now the it says I dont have the correct permission to acces the folder. How would I got fixing this? This is the error that it pops up "You do not have the permissions necessary to view the contents of "edrive"." How do I go about changing the permisions?

Trance56k 02-26-2005 01:33 AM

Also the permissions are not set to allow me to edit the fstab file as well.

acid_kewpie 02-26-2005 03:10 AM

you need to be root to edit that use "su -" in a terminal to become root.

why do people still insist on asying "linux us on my F: drive" or whatever..?? clearly that is just impossible, as windows can't see it, therefore can't give it a drive letter.... :confused:

kevinlyfellow 02-26-2005 12:38 PM

put in a line similar to this into the fstab. gid is the group identification number for the group you want to be able to access it. This one works well for me

/dev/hda2 /windows ntfs ro,gid=1000,auto,umask=003 0 0

The owner for this will be the root, but gid sets it up to the group you specify. Umask will set the appropriate permisions. The filesystem will be mount automatically (to the directory you specify, here it is /windows {note that you need to create to folder first before it can be mounted there}). Read through the man pages for mount to get all of the options.

Trance56k 02-26-2005 01:08 PM

Thanks for the help. I am now able to listen to my music!:D


All times are GMT -5. The time now is 05:28 AM.