LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-25-2005, 10:40 PM   #1
Trance56k
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Rep: Reputation: 0
Ubuntu will not mount my other hard drive


I just installed Ubuntu. The install was a succes! But I have one problem. I have a bunch of music I would like to listen to off my windows hard drive. I check fstab and its not listed. I checked device manager and saw both my hard drives including the the hard drive with windows. Any ideas




 
Old 02-25-2005, 11:18 PM   #2
s_deepak_123
Member
 
Registered: Oct 2004
Location: Mysore, India
Distribution: Fedora Core 1, Xandros desktop OS 2
Posts: 54

Rep: Reputation: 15
First, you need to find out in which partition music is stored. Usually, it's like this:
C drive-> /dev/hda1
D drive-> /dev/hda5
E drive-> /dev/hda6
F drive-> /dev/hda7
Note that this is for Primary Master.
If the hard drive is Primary slave, replace hda by hdb
For secondary master, it is hdc and for secondary slave, it is hdd
Now, assuming that your music is stored in E drive,
1: login ass root
2: Create a mount point. This is done by typing "mkdir /mnt/edrive" (without quotes)
3: mount the device on the mount point. This is done by "mount /dev/hda6 /mnt/edrive"
Now, all your music is found at /mnt/edrive.
To mount the partition every time automatically, you need to add the following line at the end of the file /etc/fstab

/dev/hda6 /mnt/edrive vfat defaults 0 0

You can change the file system type if it is not vfat. You can try auto.
 
Old 02-26-2005, 01:03 AM   #3
Trance56k
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks for the help that worked but now the it says I dont have the correct permission to acces the folder. How would I got fixing this? This is the error that it pops up "You do not have the permissions necessary to view the contents of "edrive"." How do I go about changing the permisions?
 
Old 02-26-2005, 01:33 AM   #4
Trance56k
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Original Poster
Rep: Reputation: 0
Also the permissions are not set to allow me to edit the fstab file as well.
 
Old 02-26-2005, 03:10 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
you need to be root to edit that use "su -" in a terminal to become root.

why do people still insist on asying "linux us on my F: drive" or whatever..?? clearly that is just impossible, as windows can't see it, therefore can't give it a drive letter....
 
Old 02-26-2005, 12:38 PM   #6
kevinlyfellow
Member
 
Registered: Sep 2003
Distribution: Ubuntu 5.10
Posts: 56

Rep: Reputation: 15
put in a line similar to this into the fstab. gid is the group identification number for the group you want to be able to access it. This one works well for me

/dev/hda2 /windows ntfs ro,gid=1000,auto,umask=003 0 0

The owner for this will be the root, but gid sets it up to the group you specify. Umask will set the appropriate permisions. The filesystem will be mount automatically (to the directory you specify, here it is /windows {note that you need to create to folder first before it can be mounted there}). Read through the man pages for mount to get all of the options.

Last edited by kevinlyfellow; 02-26-2005 at 12:46 PM.
 
Old 02-26-2005, 01:08 PM   #7
Trance56k
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks for the help. I am now able to listen to my music!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Live ~ Hard drive access sleeplesscitizen Ubuntu 9 11-11-2012 09:35 AM
I can't get ubuntu to work with my external hard drive! Kingrames Ubuntu 7 11-14-2005 10:35 PM
Writing to a USB hard drive in Ubuntu rockatship Linux - Hardware 3 09-18-2005 03:18 PM
USB Hard drive in Ubuntu NeoChaosX Linux - Hardware 1 06-26-2005 11:37 AM
Changing Fstab in ubuntu to mount vfat drive mikeymorgan Linux - Newbie 13 06-23-2005 07:50 AM


All times are GMT -5. The time now is 07:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration