LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Screen starts flickering, problem with Xorg and integrated intel graphics (http://www.linuxquestions.org/questions/linux-newbie-8/screen-starts-flickering-problem-with-xorg-and-integrated-intel-graphics-926203/)

snoop234 01-28-2012 01:41 PM

Screen starts flickering, problem with Xorg and integrated intel graphics
 
Hi I'm experiencing a bug that makes working with my laptop a pain in the ***.
I'm using linux mint 12 with gnome 3. Kernel Version: 3.0.0-13-generic on an dell vostro 3550 laptop with intel core i7 and amd radeon hd 6600m (hybrid graphics)

Because I don't want to use the radeon card (too much power consumption i used this fix for hybrid graphics that turns off the radeon card and lets linux use the intel integrated card:
added "blacklist radeon" to /etc/modprobe.d/blacklist.conf
added:
Code:

modprobe radeon
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

to rc.local


After I boot everything works fine for about 20-60 minutes then, without any good reason, my screen starts flickering when editing text or browsing or similar stuff. (How often depends on the stuff I do, if i use a text editor it's like once per second). The bad thing is that i loose mouse focus every time it flickers. If I want to mark some text it will stop marking it, if i right click to open any menu it will be closed before i can click on an item. It's very annoying.
Every time the screen flickers these lines are added to the Xorg.0.log:
Code:

[ 12867.010] (II) intel(0): EDID vendor "LGD", prod id 739
[ 12867.010] (II) intel(0): Printing DDC gathered Modelines:
[ 12867.010] (II) intel(0): Modeline "1366x768"x0.0  76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz)
[ 12867.010] (II) intel(0): Modeline "1366x768"x0.0  51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz)

I searched the web and asked in forums but there doesn't seem to be an easy solution to this. Most of the people say it's a driver issue, so I thought about upgrading the intel driver. The thing is that I'm kind of a linux noob and I don't want to mess things up if I compile the driver from source.

My questions are:

what should i do to fix it?

Do you think it's a driver issue and will be resolved by installing those intel drivers: http://intellinuxgraphics.org/2011Q4.html

How can I install them? I tried ./configure for the xf86-video-intel driver and it says:
Code:

configure: error: Package requirements (xorg-server >= 1.6 xproto fontsproto pixman-1 >= 0.16 ) were not met:
But xorg-server should be installed right?

Maybe it has something to do with the hybrid graphics stuff and the fix i used to turn of the radeon card?


related forum posts:
http://askubuntu.com/questions/94306...vo-y460-laptop
http://ubuntuforums.org/archive/inde...t-1559264.html
http://ubuntuforums.org/showthread.php?p=11550127

bigrigdriver 01-29-2012 08:05 PM

I found this website which suggests adding this to your kernel boot options:
Quote:

Notes

The Intel GPU supports C6 sleep states wich is currently disabled (3.0 and some before). To save energy put i915.i915_enable_rc6=1 to the boot options of your Kernel.
You might want to try restoring the functionality of your Radeon card, and adding the above to your kernel boot options.

snoop234 01-30-2012 12:46 PM

Hi thanks for the answer, i will try it out.

snoop234 01-31-2012 02:57 PM

Hi again, adding i915.i915_enable_rc6=1 to the boot options doesn't change anything. With or without the radeon card enabled i still get the flickering screen.

This answers the question wether or not disabeling the radeon card has anything to do with it. Apperently not. I will keep it turned off because I don't want to use it anyway and it uses too much power.

I noticed though that the flickering happens more often if I open eclipse. So laptop runs normally until I open Eclipse, then it starts flickering and the above mentioned messages get added to Xorg.log. But it's not necessary to open eclipse for the bug to appear.

I think my best bet would be to install the new driver from the intel site can anyone help me do that please?

impert 01-31-2012 03:11 PM

You could try:
Code:

dpkg-reconfigure -phigh xserver-xorg

snoop234 01-31-2012 03:35 PM

Quote:

Originally Posted by impert (Post 4589628)
You could try:
Code:

dpkg-reconfigure -phigh xserver-xorg

Hi,

I ran this command but the screen keeps on flickering. I restarted the laptop and its still there.

I noticed that some other lines get sometimes mixed with the above mentioned lines in Xorg.log:

Code:

XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
Code:


[  2116.810] (II) XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
[  2116.810] (II) intel(0): EDID vendor "LGD", prod id 739
[  2116.810] (II) intel(0): Printing DDC gathered Modelines:
[  2116.810] (II) intel(0): Modeline "1366x768"x0.0  76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz)
[  2116.810] (II) intel(0): Modeline "1366x768"x0.0  51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz)
[  2117.459] (II) XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
[  2118.252] (II) XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
[  2118.254] (II) intel(0): EDID vendor "LGD", prod id 739
[  2118.254] (II) intel(0): Printing DDC gathered Modelines:
[  2118.254] (II) intel(0): Modeline "1366x768"x0.0  76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz)
[  2118.254] (II) intel(0): Modeline "1366x768"x0.0  51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz)
[  2118.441] (II) XKB: reuse xkmfile /var/lib/xkb/serve


snoop234 01-31-2012 05:54 PM

I'm using a Workaround for the problem right now.
I switched my desktop environment to xfce. I switched from ubuntu to mint because I hate unity but gnome 3 kinda sucked to. So I'm very happy with xfce now and will keep it.
I don't have the flickering with xfce and lxde but with lxde i couldn't change some configurations like mouse speed and i think xfce looks better (more similar to gnome 2). I won't mark this thread solved for now, because the problem still exists with gnome 3

tailinlinux 01-31-2012 08:26 PM

Please check the video cable.

snoop234 02-01-2012 07:52 AM

Quote:

Originally Posted by tailinlinux (Post 4589849)
Please check the video cable.

haha you're funny

tailinlinux 02-03-2012 01:06 AM

Quote:

Originally Posted by snoop234 (Post 4590401)
haha you're funny

Just kidding.


All times are GMT -5. The time now is 05:07 AM.