LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-28-2012, 12:41 PM   #1
snoop234
LQ Newbie
 
Registered: Jan 2012
Posts: 10

Rep: Reputation: Disabled
Exclamation Screen starts flickering, problem with Xorg and integrated intel graphics


Hi I'm experiencing a bug that makes working with my laptop a pain in the ***.
I'm using linux mint 12 with gnome 3. Kernel Version: 3.0.0-13-generic on an dell vostro 3550 laptop with intel core i7 and amd radeon hd 6600m (hybrid graphics)

Because I don't want to use the radeon card (too much power consumption i used this fix for hybrid graphics that turns off the radeon card and lets linux use the intel integrated card:
added "blacklist radeon" to /etc/modprobe.d/blacklist.conf
added:
Code:
modprobe radeon
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
to rc.local


After I boot everything works fine for about 20-60 minutes then, without any good reason, my screen starts flickering when editing text or browsing or similar stuff. (How often depends on the stuff I do, if i use a text editor it's like once per second). The bad thing is that i loose mouse focus every time it flickers. If I want to mark some text it will stop marking it, if i right click to open any menu it will be closed before i can click on an item. It's very annoying.
Every time the screen flickers these lines are added to the Xorg.0.log:
Code:
[ 12867.010] (II) intel(0): EDID vendor "LGD", prod id 739
[ 12867.010] (II) intel(0): Printing DDC gathered Modelines:
[ 12867.010] (II) intel(0): Modeline "1366x768"x0.0   76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz)
[ 12867.010] (II) intel(0): Modeline "1366x768"x0.0   51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz)
I searched the web and asked in forums but there doesn't seem to be an easy solution to this. Most of the people say it's a driver issue, so I thought about upgrading the intel driver. The thing is that I'm kind of a linux noob and I don't want to mess things up if I compile the driver from source.

My questions are:

what should i do to fix it?

Do you think it's a driver issue and will be resolved by installing those intel drivers: http://intellinuxgraphics.org/2011Q4.html

How can I install them? I tried ./configure for the xf86-video-intel driver and it says:
Code:
configure: error: Package requirements (xorg-server >= 1.6 xproto fontsproto pixman-1 >= 0.16 ) were not met:
But xorg-server should be installed right?

Maybe it has something to do with the hybrid graphics stuff and the fix i used to turn of the radeon card?


related forum posts:
http://askubuntu.com/questions/94306...vo-y460-laptop
http://ubuntuforums.org/archive/inde...t-1559264.html
http://ubuntuforums.org/showthread.php?p=11550127
 
Old 01-29-2012, 07:05 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,783

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
I found this website which suggests adding this to your kernel boot options:
Quote:
Notes

The Intel GPU supports C6 sleep states wich is currently disabled (3.0 and some before). To save energy put i915.i915_enable_rc6=1 to the boot options of your Kernel.
You might want to try restoring the functionality of your Radeon card, and adding the above to your kernel boot options.
 
Old 01-30-2012, 11:46 AM   #3
snoop234
LQ Newbie
 
Registered: Jan 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Hi thanks for the answer, i will try it out.
 
Old 01-31-2012, 01:57 PM   #4
snoop234
LQ Newbie
 
Registered: Jan 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Hi again, adding i915.i915_enable_rc6=1 to the boot options doesn't change anything. With or without the radeon card enabled i still get the flickering screen.

This answers the question wether or not disabeling the radeon card has anything to do with it. Apperently not. I will keep it turned off because I don't want to use it anyway and it uses too much power.

I noticed though that the flickering happens more often if I open eclipse. So laptop runs normally until I open Eclipse, then it starts flickering and the above mentioned messages get added to Xorg.log. But it's not necessary to open eclipse for the bug to appear.

I think my best bet would be to install the new driver from the intel site can anyone help me do that please?
 
Old 01-31-2012, 02:11 PM   #5
impert
Member
 
Registered: Feb 2009
Posts: 282

Rep: Reputation: 53
You could try:
Code:
dpkg-reconfigure -phigh xserver-xorg
 
Old 01-31-2012, 02:35 PM   #6
snoop234
LQ Newbie
 
Registered: Jan 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by impert View Post
You could try:
Code:
dpkg-reconfigure -phigh xserver-xorg
Hi,

I ran this command but the screen keeps on flickering. I restarted the laptop and its still there.

I noticed that some other lines get sometimes mixed with the above mentioned lines in Xorg.log:

Code:
XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
Code:
 
[  2116.810] (II) XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
[  2116.810] (II) intel(0): EDID vendor "LGD", prod id 739
[  2116.810] (II) intel(0): Printing DDC gathered Modelines:
[  2116.810] (II) intel(0): Modeline "1366x768"x0.0   76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz)
[  2116.810] (II) intel(0): Modeline "1366x768"x0.0   51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz)
[  2117.459] (II) XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
[  2118.252] (II) XKB: reuse xkmfile /var/lib/xkb/server-6EDD3E719D2B0973D03641546DA8CCADCE7019E5.xkm
[  2118.254] (II) intel(0): EDID vendor "LGD", prod id 739
[  2118.254] (II) intel(0): Printing DDC gathered Modelines:
[  2118.254] (II) intel(0): Modeline "1366x768"x0.0   76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz)
[  2118.254] (II) intel(0): Modeline "1366x768"x0.0   51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz)
[  2118.441] (II) XKB: reuse xkmfile /var/lib/xkb/serve
 
Old 01-31-2012, 04:54 PM   #7
snoop234
LQ Newbie
 
Registered: Jan 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
I'm using a Workaround for the problem right now.
I switched my desktop environment to xfce. I switched from ubuntu to mint because I hate unity but gnome 3 kinda sucked to. So I'm very happy with xfce now and will keep it.
I don't have the flickering with xfce and lxde but with lxde i couldn't change some configurations like mouse speed and i think xfce looks better (more similar to gnome 2). I won't mark this thread solved for now, because the problem still exists with gnome 3

Last edited by snoop234; 01-31-2012 at 05:00 PM.
 
Old 01-31-2012, 07:26 PM   #8
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 386
Blog Entries: 3

Rep: Reputation: 25
Please check the video cable.
 
Old 02-01-2012, 06:52 AM   #9
snoop234
LQ Newbie
 
Registered: Jan 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tailinlinux View Post
Please check the video cable.
haha you're funny
 
Old 02-03-2012, 12:06 AM   #10
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 386
Blog Entries: 3

Rep: Reputation: 25
Quote:
Originally Posted by snoop234 View Post
haha you're funny
Just kidding.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Integrated Graphics - Problem spandey Linux - Hardware 2 04-12-2011 07:16 PM
KMS not working, screen turns blank. Intel i3 330 Integrated Graphics equal1zer Linux - Hardware 6 01-22-2011 09:58 AM
Help! Black screen instead of login screen! Intel integrated graphics coolblue Suse/Novell 10 05-03-2007 05:30 PM
[SOLVED] Integrated Intel graphics & LCD glossy screen MBA Whore Linux - Hardware 5 09-13-2006 12:58 AM
any monitor flickering problem with Intel® Extreme Graphics 2 & Redhat 9.0? jkmin Linux - Hardware 4 08-23-2005 12:07 PM


All times are GMT -5. The time now is 09:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration