LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   mount: input/output error? (http://www.linuxquestions.org/questions/linux-newbie-8/mount-input-output-error-269790/)

chunlee 12-23-2004 11:25 PM

mount: input/output error?
 
hi there:

i have been trying to mount my cdrom but for somereason i could not get it to work. in my /etc/fstab, i have

/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0

and when i try

mount /dev/cdroms/cdrom0

i got
/dev/cdroms/cdrom0: Input/output error

can anyone help?

many thanks

CHUN

ps, i have got the feeling that the cd drive driver might not have been installed configured properly. is there any command to see if its on the system?

akudewan 12-23-2004 11:51 PM

Are you sure that /dev/cdroms/cdrom0 is the proper device?

(Also, Fedora usually configures the CDRom properly in fstab)

As far as mounting is concerned, try "mount -a" Or try this:
"mount -t iso9660 /dev/cdroms/cdrom0 /mnt/cdrom"

chunlee 12-24-2004 01:31 AM

thanks for your reply!

oops, forgot to say that i am trying out Gentoo, so this is for Gentoo.

i set up my fstab according to this:

http://www.gentoo.org/doc/en/handboo...?part=1&chap=8

and

mount -t iso9660 /dev/cdroms/cdrom0 /mnt/cdrom

i got

mount: block device /dev/cdroms/cdrom0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0, or too many mounted file systems

mount -a

does not give me anything.....


cheers

CHUN

akudewan 12-24-2004 03:37 AM

Quote:

mount: block device /dev/cdroms/cdrom0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0, or too many mounted file systems
I thought of testing out the command that I gave you. So I put in a blank CD in my drive and I got the same error that you got!!

Then I put in a proper CD and mounted, and it worked

So you aren't using a blank CD to test this out, right? Also, I'll explain what this command does:

Code:

mount -t iso9660 /dev/cdroms/cdrom0 /mnt/cdrom
Here, the "-t" specifies the filesystem type. It can be anything from vfat to ext3 to iso9660. CDs use iso9660 mostly. Instead you can also specify "auto" So the command will be
Code:

mount -t auto /dev/cdroms/cdrom0 /mnt/cdrom
The error you got: "wrong fs type" was concerning the filesystem. Try using "auto". And don't use a blank CD, since it has no filesystem created on it. Also, if you post your /etc/fstab here, it will help.

chunlee 12-24-2004 06:37 AM

thanks for you reply!

i have also tried


Code:

mount -t auto /dev/cdroms/cdrom0 /mnt/cdrom
and i got

Code:

mount: you must specify the filesystem type
and its not blank cd, i use a audio cd to test.

my fstab looks like this


/dev/hda1 /boot ext2 defaults,noatime 1 2
/dev/hda2 none swap sw 0 0
/dev/hda3 / ext3 noatime 0 1
/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0

cheers

CHUN

akudewan 12-26-2004 11:47 PM

This is the line in my fstab concerning the cdrom:

Code:

/dev/scd0      /mnt/cdrom      iso9660    users,owner,rw,umask=000 0 0
Change the /dev/scd0 to your device, /dev/cdroms/cdrom0 and try if it works. Remember to make a backup.


All times are GMT -5. The time now is 05:49 PM.