LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-23-2004, 11:25 PM   #1
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Rep: Reputation: 15
mount: input/output error?


hi there:

i have been trying to mount my cdrom but for somereason i could not get it to work. in my /etc/fstab, i have

/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0

and when i try

mount /dev/cdroms/cdrom0

i got
/dev/cdroms/cdrom0: Input/output error

can anyone help?

many thanks

CHUN

ps, i have got the feeling that the cd drive driver might not have been installed configured properly. is there any command to see if its on the system?
 
Old 12-23-2004, 11:51 PM   #2
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Are you sure that /dev/cdroms/cdrom0 is the proper device?

(Also, Fedora usually configures the CDRom properly in fstab)

As far as mounting is concerned, try "mount -a" Or try this:
"mount -t iso9660 /dev/cdroms/cdrom0 /mnt/cdrom"
 
Old 12-24-2004, 01:31 AM   #3
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
thanks for your reply!

oops, forgot to say that i am trying out Gentoo, so this is for Gentoo.

i set up my fstab according to this:

http://www.gentoo.org/doc/en/handboo...?part=1&chap=8

and

mount -t iso9660 /dev/cdroms/cdrom0 /mnt/cdrom

i got

mount: block device /dev/cdroms/cdrom0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0, or too many mounted file systems

mount -a

does not give me anything.....


cheers

CHUN
 
Old 12-24-2004, 03:37 AM   #4
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Quote:
mount: block device /dev/cdroms/cdrom0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdroms/cdrom0, or too many mounted file systems
I thought of testing out the command that I gave you. So I put in a blank CD in my drive and I got the same error that you got!!

Then I put in a proper CD and mounted, and it worked

So you aren't using a blank CD to test this out, right? Also, I'll explain what this command does:

Code:
mount -t iso9660 /dev/cdroms/cdrom0 /mnt/cdrom
Here, the "-t" specifies the filesystem type. It can be anything from vfat to ext3 to iso9660. CDs use iso9660 mostly. Instead you can also specify "auto" So the command will be
Code:
mount -t auto /dev/cdroms/cdrom0 /mnt/cdrom
The error you got: "wrong fs type" was concerning the filesystem. Try using "auto". And don't use a blank CD, since it has no filesystem created on it. Also, if you post your /etc/fstab here, it will help.
 
Old 12-24-2004, 06:37 AM   #5
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
thanks for you reply!

i have also tried


Code:
mount -t auto /dev/cdroms/cdrom0 /mnt/cdrom
and i got

Code:
mount: you must specify the filesystem type
and its not blank cd, i use a audio cd to test.

my fstab looks like this


/dev/hda1 /boot ext2 defaults,noatime 1 2
/dev/hda2 none swap sw 0 0
/dev/hda3 / ext3 noatime 0 1
/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0

cheers

CHUN
 
Old 12-26-2004, 11:47 PM   #6
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
This is the line in my fstab concerning the cdrom:

Code:
/dev/scd0       /mnt/cdrom       iso9660     users,owner,rw,umask=000 0 0
Change the /dev/scd0 to your device, /dev/cdroms/cdrom0 and try if it works. Remember to make a backup.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
aplay: pcm_write:1029: write error: Input/output error mimithebrain Linux - Software 2 12-04-2007 11:51 AM
cp - error reading /mnt/cdrom/mpegav/avseq01.dat input/output error manishsingh4u Linux - General 2 10-17-2005 05:02 AM
dd input/output error matazar42 Linux - General 3 10-08-2005 05:22 PM
can anyone help, /dev/cdrom:input/output error mount speedyhot Linux - Newbie 3 03-01-2004 02:03 PM
My mount point of /dev/hda1(win98) is /mnt/c,but now it says input/output error whepin Linux - General 2 12-20-2001 12:41 PM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration