LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Grub Boot Loader Problems (http://www.linuxquestions.org/questions/linux-newbie-8/grub-boot-loader-problems-397056/)

tylerjroach 12-27-2005 11:03 PM

Grub Boot Loader Problems
 
I am having trouble changing the order of the bootloader. I have the instructions for it and I know how to do it, but it says I need to be the root user. I do not know how to access it to change it. I do not like linux loading up first before windows. Also, anyone knows why sometimes when I load up linux it is fine, but sometimes when I load it up the monitor is blurry and it doesn't get the right resolution or the refresh rate. The OS is Ubuntu 5.10

bigrigdriver 12-27-2005 11:38 PM

To change the boot default, you need to edit the file /boot/grub/grub.conf.

Since you indicate you aren't familiar with command-line operations, login as the root user (this avoids volumns of instructions on how to su to root, and do command-line editing).

In grub.conf, there is a line near the top: default=0. 0 is the first OS in the menu; 1 is the second, etc.

If windows is second in the list, change the default line to default=1 to make windows the default.

Or

Cut and paste. Cut out the windows part of the menu list, and paste it back in as the first OS in the list.

Either way will work.

m_a_b 12-28-2005 12:33 AM

just a tip:

since I absolutely HATE vi, I finally realized that you can open a terminal, type su and your password, then type gedit (it is probably my favorite editor, but I am sure this works with other editors), and it opens an instance of the editor that has su privledges. It is much easier than trying to deal with the cryptic vi commands!

So once you get your su instance of your GUI editor running, you can browse to the file you want to edit, and make your changes and save it all from the gui editor. This little tip would have saved me SO much time when I was starting out!

Nylex 12-28-2005 01:22 AM

Quote:

Originally Posted by m_a_b
type su and your password

For Ubuntu, you have to use sudo instead of su, so it would be:

$ sudo gedit

If you have nano or pico installed, you could also use them as they're command line editors but easier to use than vi.

xine_luo 12-28-2005 01:39 AM

Quote:

To change the boot default, you need to edit the file /boot/grub/grub.conf
Ubuntu5.10 doesn't have grub.conf,the menu.lst instead

following these steps:
Quote:

sudo cp /boot/grub/menu.lst /boot/grub/menu.lst_backup
sudo gedit /boot/grub/menu.lst
modify default=0(or 1,2..)

for example,if your menu.lst like this:
Quote:

title Ubuntu, kernel 2.6.10-5-686
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-686 root=/dev/hda5 ro quiet splash
initrd /boot/initrd.img-2.6.10-5-686
savedefault
boot

title Ubuntu, kernel 2.6.10-5-686 (recovery mode)
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-686 root=/dev/hda5 ro single
initrd /boot/initrd.img-2.6.10-5-686
savedefault
boot

title Ubuntu, kernel 2.6.10-5-386
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-386 root=/dev/hda5 ro quiet splash
initrd /boot/initrd.img-2.6.10-5-386
savedefault
boot

title Ubuntu, kernel 2.6.10-5-386 (recovery mode)
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-386 root=/dev/hda5 ro single
initrd /boot/initrd.img-2.6.10-5-386
savedefault
boot

title Ubuntu, kernel memtest86+
root (hd0,4)
kernel /boot/memtest86+.bin
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Microsoft Windows XP Pro
root (hd0,0)
savedefault
makeactive
chainloader +1
so ,the default=6,windows loading up first,

tylerjroach 12-28-2005 10:30 AM

Thank you, I have had this problem for a while and now it won't annoy me anymore.

markquestion 01-03-2006 01:53 AM

:newbie:

how to modify timeout in GRUB Loader???

timmeke 01-03-2006 02:54 AM

Try the "timeout" option in your GRUB config:
"timeout 5"
for 5 seconds...

See also:
info grub
section on "configuration".


All times are GMT -5. The time now is 03:44 AM.