LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-27-2005, 11:03 PM   #1
tylerjroach
LQ Newbie
 
Registered: Dec 2005
Distribution: Ubuntu 6.06 (Dapper Drake)
Posts: 20

Rep: Reputation: 0
Exclamation Grub Boot Loader Problems


I am having trouble changing the order of the bootloader. I have the instructions for it and I know how to do it, but it says I need to be the root user. I do not know how to access it to change it. I do not like linux loading up first before windows. Also, anyone knows why sometimes when I load up linux it is fine, but sometimes when I load it up the monitor is blurry and it doesn't get the right resolution or the refresh rate. The OS is Ubuntu 5.10

Last edited by tylerjroach; 12-27-2005 at 11:04 PM.
 
Old 12-27-2005, 11:38 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,770

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
To change the boot default, you need to edit the file /boot/grub/grub.conf.

Since you indicate you aren't familiar with command-line operations, login as the root user (this avoids volumns of instructions on how to su to root, and do command-line editing).

In grub.conf, there is a line near the top: default=0. 0 is the first OS in the menu; 1 is the second, etc.

If windows is second in the list, change the default line to default=1 to make windows the default.

Or

Cut and paste. Cut out the windows part of the menu list, and paste it back in as the first OS in the list.

Either way will work.
 
Old 12-28-2005, 12:33 AM   #3
m_a_b
Member
 
Registered: Aug 2003
Distribution: Ubuntu 6.10 Edgy
Posts: 90

Rep: Reputation: 15
just a tip:

since I absolutely HATE vi, I finally realized that you can open a terminal, type su and your password, then type gedit (it is probably my favorite editor, but I am sure this works with other editors), and it opens an instance of the editor that has su privledges. It is much easier than trying to deal with the cryptic vi commands!

So once you get your su instance of your GUI editor running, you can browse to the file you want to edit, and make your changes and save it all from the gui editor. This little tip would have saved me SO much time when I was starting out!
 
Old 12-28-2005, 01:22 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by m_a_b
type su and your password
For Ubuntu, you have to use sudo instead of su, so it would be:

$ sudo gedit

If you have nano or pico installed, you could also use them as they're command line editors but easier to use than vi.
 
Old 12-28-2005, 01:39 AM   #5
xine_luo
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Rep: Reputation: 0
Quote:
To change the boot default, you need to edit the file /boot/grub/grub.conf
Ubuntu5.10 doesn't have grub.conf,the menu.lst instead

following these steps:
Quote:
sudo cp /boot/grub/menu.lst /boot/grub/menu.lst_backup
sudo gedit /boot/grub/menu.lst
modify default=0(or 1,2..)

for example,if your menu.lst like this:
Quote:
title Ubuntu, kernel 2.6.10-5-686
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-686 root=/dev/hda5 ro quiet splash
initrd /boot/initrd.img-2.6.10-5-686
savedefault
boot

title Ubuntu, kernel 2.6.10-5-686 (recovery mode)
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-686 root=/dev/hda5 ro single
initrd /boot/initrd.img-2.6.10-5-686
savedefault
boot

title Ubuntu, kernel 2.6.10-5-386
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-386 root=/dev/hda5 ro quiet splash
initrd /boot/initrd.img-2.6.10-5-386
savedefault
boot

title Ubuntu, kernel 2.6.10-5-386 (recovery mode)
root (hd0,4)
kernel /boot/vmlinuz-2.6.10-5-386 root=/dev/hda5 ro single
initrd /boot/initrd.img-2.6.10-5-386
savedefault
boot

title Ubuntu, kernel memtest86+
root (hd0,4)
kernel /boot/memtest86+.bin
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Microsoft Windows XP Pro
root (hd0,0)
savedefault
makeactive
chainloader +1
so ,the default=6,windows loading up first,

Last edited by xine_luo; 12-28-2005 at 01:45 AM.
 
Old 12-28-2005, 10:30 AM   #6
tylerjroach
LQ Newbie
 
Registered: Dec 2005
Distribution: Ubuntu 6.06 (Dapper Drake)
Posts: 20

Original Poster
Rep: Reputation: 0
Thank you, I have had this problem for a while and now it won't annoy me anymore.

Last edited by tylerjroach; 12-29-2005 at 03:14 PM.
 
Old 01-03-2006, 01:53 AM   #7
markquestion
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0


how to modify timeout in GRUB Loader???
 
Old 01-03-2006, 02:54 AM   #8
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Try the "timeout" option in your GRUB config:
"timeout 5"
for 5 seconds...

See also:
info grub
section on "configuration".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
GRUB boot loader blocking windows boot julienroger Linux - Newbie 3 10-12-2004 01:11 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM
Need help with boot loader. Multi boot questions. Grub? 1993gt40 Linux - Software 1 10-16-2003 08:28 PM
How to add a boot record which used to startup windows under my Grub boot loader? yunxiang Linux - Newbie 6 02-01-2003 02:22 AM


All times are GMT -5. The time now is 09:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration