LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   iptables issue (http://www.linuxquestions.org/questions/linux-networking-3/iptables-issue-688281/)

pushpraj 12-04-2008 07:17 AM

iptables issue
 
Hello All,
I installed fedora 10 recently and disabled services which i dont require including iptables. but now when fedora 10 starts iptables service also starts automatically. "chkconfig" ,"ntsysv" ,"system- config-services" all shows that iptables is disabled but i dont know how it starts. after booting when i run "iptables -L" it shows iptable is running or "service iptables status" also shows it's running.iptables scripts inside rc directory is K92iptables.
Stopping service is one option but i think it's not solution.
SElinux and ip6tables are disabled.

Regards,
Pushpraj N

sydney-troz 12-04-2008 08:36 AM

iptables is merely a front-end to the kernel's firewall -- the only way to disable it would be to compile it out (not sure if that even works), but in most cases that would be a bad idea.

SharpyWarpy 12-04-2008 09:08 AM

Are you booting into the gui or command line?
What I do to keep processes from starting at boot is go into /etc/rc.d and into the appropriate directory, rc3.d being command line boot, no gui, and change the names of whatever is there I don't want. Like for example if I don't want iptables to start I change the name of /etc/rc.d/rc3.d/S10iptables to /etc/rc.d/rc3.d/s10iptables. Notice the lower case in there. That disables it. If you boot into a gui you want to do that in /etc/rc.d/rc5.d. Or both, to be sure.
If you're running KDE you can do this with Menu-Administration-Server Settings-Services Service Management but it does the same thing except it changes the names to use an upper case "K" instead of a lower case "s" like I do. Hope this helps.


All times are GMT -5. The time now is 05:26 AM.