LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-04-2008, 07:17 AM   #1
pushpraj
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Rep: Reputation: 15
iptables issue


Hello All,
I installed fedora 10 recently and disabled services which i dont require including iptables. but now when fedora 10 starts iptables service also starts automatically. "chkconfig" ,"ntsysv" ,"system- config-services" all shows that iptables is disabled but i dont know how it starts. after booting when i run "iptables -L" it shows iptable is running or "service iptables status" also shows it's running.iptables scripts inside rc directory is K92iptables.
Stopping service is one option but i think it's not solution.
SElinux and ip6tables are disabled.

Regards,
Pushpraj N
 
Old 12-04-2008, 08:36 AM   #2
sydney-troz
Member
 
Registered: Feb 2007
Distribution: Kubuntu, it's obese barely-usable sibling, Ubuntu
Posts: 142

Rep: Reputation: 15
iptables is merely a front-end to the kernel's firewall -- the only way to disable it would be to compile it out (not sure if that even works), but in most cases that would be a bad idea.
 
Old 12-04-2008, 09:08 AM   #3
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Rep: Reputation: 90
Are you booting into the gui or command line?
What I do to keep processes from starting at boot is go into /etc/rc.d and into the appropriate directory, rc3.d being command line boot, no gui, and change the names of whatever is there I don't want. Like for example if I don't want iptables to start I change the name of /etc/rc.d/rc3.d/S10iptables to /etc/rc.d/rc3.d/s10iptables. Notice the lower case in there. That disables it. If you boot into a gui you want to do that in /etc/rc.d/rc5.d. Or both, to be sure.
If you're running KDE you can do this with Menu-Administration-Server Settings-Services Service Management but it does the same thing except it changes the names to use an upper case "K" instead of a lower case "s" like I do. Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with iptables SentralOrigin Linux - Networking 6 07-14-2007 03:42 PM
iptables samba issue shio Linux - Networking 1 07-12-2007 10:10 PM
iptables issue rkemp Linux - Networking 3 11-29-2003 06:50 PM
Advanced Iptables Issue Seather Linux - Networking 5 08-30-2003 07:09 AM
iptables issue f1uke Linux - Security 3 08-11-2003 07:58 PM


All times are GMT -5. The time now is 10:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration