LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Compaq LapTop 2580US display problem (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/compaq-laptop-2580us-display-problem-173650/)

SuLa028 04-23-2004 07:44 AM

Compaq LapTop 2580US display problem
 
hi there ,

My name is Sead and I am new on Linux ( beginner).I installed Red Hat9 first and after that Fedora on my Compaq Laptop yesterday.First I had a problem with the Fire Wire but Brian1 helped this other guy on this issues and also it helped me , ( thank you Brian1 ).After I got rid of that problem I am facing another problem, display problem.My resolution is 640 with 480 because I don't know the manufacturer of the monitor.Even on Win XP it doesen't show the manufacturer name and I got some regular/no name driver for it. If anyone had a same problem with Compaq Presario 2500 series ( 2580US ) please let me know what should I do to get good resolution, what driver or manufacturer should I use.
thank you

edal 04-23-2004 10:27 AM

Can I Help ?
 
From what I have seen resolution is a combination of two things, what your monitor is set to and what display driver you are using. Taking my Compaq Armada 1750 as an example the settings are as follows:

Monitor: Generic laptop Display 1024x768
Video card: ATI Mach 64 4Mb Memory

Native resolution for my fourteen inch display is 1024x768, if you have a twelve inch display then it will probably be 800x600. For other display sizes adjust accordingly. The correct video card driver should be picked up during installation but if it isn't then you may have to manually select it. If you want more help with this problem then I will need your PID code, this is normally found on the bottom of your laptop and is in the format xxxx/x/xxxx/x/x/x

Ed Almos
Budapest, Hungary

SuLa028 04-23-2004 10:41 AM

My Graphic Card is "ATI Radeon IGP345M". Monitor is 15 inch. On my WinXP partition i have monitor listed as "Digital Flat Panel (1024x768)". Unfortunatly I can not find the PID number! I can provide you whith another numbers, model,serial, etc.
Model# is Compaq Presario 2580US ( 2500 series ). I don't thinkthat I saw a listing of the driver on linux under the same name like in Win XP.
If you need any other info let me know pls.
Thank you for your fast response :-)

edal 04-23-2004 10:52 AM

OK
 
OK, three more questions.

Firstly, when you boot into MS Windows XP what does it say for your Display adaptor ? I need as much detail as possible here including (if you can find it) what display driver XP is using.

Secondly, can you go into your CMOS/BIOS setup and tell me what video information is displayed ?

Lastly, when you installed your Linux Distro what did the install program detect as your display adaptor ?

We're getting there. For now go into the Linux display setup and set the monitor as 'Generic 1024x768 laptop display' and we will carry on from there.

Ed Almos
Budapest, Hungary

SuLa028 04-23-2004 12:23 PM

I got the resolution right but now I am having another problem :(.When I am clicking on Activate Eth0 or Eth1 I get a small window that scrolls down wery fast some errors like Error line 10 etc and cant activate the cards.

xtec2 04-24-2004 06:57 PM

Help me too!
 
Hi,

I've installed RedHat 9.0 on my Compaq laptop and I also have a display problem.

I have tried resetting the resolution but everytime I reset and log out, it goes right back to the default 800x600.

I've tried this several times and I'm getting nowhere. How did you finally get your resolution problem corrected?

Thanks for any help you can provide.

XTEC2

edal 04-25-2004 07:14 AM

Default Resolution
 
It could be that your default resolution under X is set wrong, either that or you have the wrong settings for your display panel.

Ed Almos
Budapest, Hungary

SuLa028 04-28-2004 12:35 AM

Hi ,
I am back after a while. I am sorry but could not answer earlier.
I fixed the resolution problem by playing around whith the monitor setup ( a set it on generic monitor 1024 by 768 ) and it worked out. I guess that I had a wrong monitor from the list.
Anyways, unfortunatly I removed Linux from my lap top for now . After I get rid of some things I will be back again on installing linux :-)
thank you for your help people


All times are GMT -5. The time now is 04:07 PM.