LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   kernel panic - not syncing: Fatal exception in interrupt (http://www.linuxquestions.org/questions/linux-kernel-70/kernel-panic-not-syncing-fatal-exception-in-interrupt-587458/)

sinister1 09-26-2007 06:22 AM

kernel panic - not syncing: Fatal exception in interrupt
 
Hello,


Since a few weeks we have the following problem:

Once in a while our hda (Operating System disc) becomes Read Only.

After a reboot the filesystem is writable again.

In logs there are a few errors:

kernel panic - not syncing: Fatal exception in interrupt
BUG: warning at arch/i386/kernel/smp.c:547/smp_call_function()

i have checked different forums but with no concrete result.

Can anyone help me..

Thanks

Jaap

ramram29 09-26-2007 10:01 AM

Looks like you have a problem with smp (symmetric multiprocessing). You can add the following to the kernel stanza in grub 'nosmp'. Restart and test try again. Your os is being mounted readonly because /etc/fstab is configured to mount it that way when there is a problem.

sinister1 09-26-2007 11:09 AM

Quote:

Originally Posted by ramram29 (Post 2904339)
Looks like you have a problem with smp (symmetric multiprocessing). You can add the following to the kernel stanza in grub 'nosmp'. Restart and test try again. Your os is being mounted readonly because /etc/fstab is configured to mount it that way when there is a problem.

Oke thanks for replying.

i am looking in the /boot/grub/menu.lst so where do i have to put nosmp?

It's a production server so it's a little bit hard to reboot. i will try in the evening and let you know what the result is.

TheDirtyScreech 09-26-2007 04:28 PM

It should go on the grub line starting with "kernel." If you have a simple kernel line, it may look something like this:

Code:

...
title=Your linux flavor
root (hd0,0)
kernel /boot/vmlinuz
initrd /boot/initrd
...

You would want to change it to look like this:
Code:

...
title=Your Linux flavor
root (hd0,0)
kernel /boot/vmlinuz nosmp
initrd /boot/initrd
...

-TDS-

sinister1 09-27-2007 03:43 AM

Quote:

Originally Posted by TheDirtyScreech (Post 2904729)
It should go on the grub line starting with "kernel." If you have a simple kernel line, it may look something like this:

Code:

...
title=Your linux flavor
root (hd0,0)
kernel /boot/vmlinuz
initrd /boot/initrd
...

You would want to change it to look like this:
Code:

...
title=Your Linux flavor
root (hd0,0)
kernel /boot/vmlinuz nosmp
initrd /boot/initrd
...

-TDS-

Oke thanks.


I've edditted the menu.lst and put nosmp in it.

Now i have to plan a downtime for this reboot.

thanks everyone.

TheDirtyScreech 09-27-2007 09:59 AM

Just to clarify and make sure you know what's happening, the "nosmp" option is disabling symmetric multi-processing. This won't matter if your running one CPU, but if your rocking two or more CPUs (multi-cores included), you'll essentially be limiting your machine to one.

If you're fine with only one CPU, booting with nosmp everytime won't matter (conversely, you should be able to just disable SMP in the kernel config and rebuild the kernel). If you need/want the other CPUs (assuming your hardware actually has other CPUs), you should only be booting this "nosmp" option to test for a while to confirm that smp.c is really the problem (should be according to your error messages). You'll then want to fix the problem (upgrading kernel source and recompiling your kernel should do it) and reboot with smp enabled.

I wasn't sure if you knew the full consequences of this solution, so sorry if I just wasted your time.

-TDS-

sinister1 09-27-2007 11:54 AM

Quote:

Originally Posted by TheDirtyScreech (Post 2905415)
Just to clarify and make sure you know what's happening, the "nosmp" option is disabling symmetric multi-processing. This won't matter if your running one CPU, but if your rocking two or more CPUs (multi-cores included), you'll essentially be limiting your machine to one.

If you're fine with only one CPU, booting with nosmp everytime won't matter (conversely, you should be able to just disable SMP in the kernel config and rebuild the kernel). If you need/want the other CPUs (assuming your hardware actually has other CPUs), you should only be booting this "nosmp" option to test for a while to confirm that smp.c is really the problem (should be according to your error messages). You'll then want to fix the problem (upgrading kernel source and recompiling your kernel should do it) and reboot with smp enabled.

I wasn't sure if you knew the full consequences of this solution, so sorry if I just wasted your time.

-TDS-

Wasting my time, i think not!

Great that you are taking the time to explain it to me.

Our server has only 1 cpu and last week i upgraded our kernel but probably with smp enabled.

so thanks for your messages. I am going to test and let you know the results.

Sinister1


All times are GMT -5. The time now is 07:34 AM.