LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound Card - can hear sounds and test fine - no cd sound (http://www.linuxquestions.org/questions/linux-hardware-18/sound-card-can-hear-sounds-and-test-fine-no-cd-sound-247298/)

PAB 10-25-2004 09:49 PM

Sound Card - can hear sounds and test fine - no cd sound
 
I have a soundblaster live card. When I do a soundcard detection, i can hear the test sound (although it lists 3 different sound cards). I can also hear system sounds (beeps, other noises when I shut down, etc). However, when I try to play a CD, I get no sound. The CD player functions (ie when I input the CD, the CD player starts and the track begins). However, no sound.

I am using Fedora 2 on a Pentium 4 system. lspci lists the sound card. I cannot, however, run sndconfig (it says command not found). I have tried adjusting the volume for all three listed sound cards and all different things (even headphone, line1, etc), and nothing works.

Does anyone have any help?

Thanks.

Paul

LavaDevil94 10-25-2004 10:20 PM

Are you sure that mixer setting is turned up? Try this command:
alsamixer
Then look for a slider that says CD and turn it up to the max.

Lenard Spencer 10-26-2004 12:56 AM

Is the audio cable installed between the CD-ROM and the sound card? I know Windoze allows digital reading through the IDE bus, but I haven't yet seen that feature in Linux....

fatblueduck 10-26-2004 02:21 AM

if the command "alsamixer" or "amixer" doesn't bring any information, then you seriously need to install the ALSA driver. You can go here
www.alsa-project.org

Hammett 10-26-2004 04:00 AM

Quote:

Originally posted by Lenard Spencer
Is the audio cable installed between the CD-ROM and the sound card? I know Windoze allows digital reading through the IDE bus, but I haven't yet seen that feature in Linux....
I use digital reading for audio CD with xmms 1.2.10 and works perfectly.

PAB 10-26-2004 06:54 AM

Thanks everyone for the input! I checked alsamixer, and the CD was all the way up. Now, I have two cd players in my computer and I have tried with both and neither works. Just an idea - my motherboard came with integrated sound, and I also installed the SB Live card. Could Linux be using the wrong sound card (say, for example, the integrated one) while the CD players are using the SBLive card? If that's the case, how do I tell Linux which card to use?

I don't think that I need to install the alsa drivers since the other sounds work on my computer, and the soundcard detection plays the test sound. I haven't checked the audio cable (not sure what I'm looking for there and find it difficult to believe that is the problem since Windows works fine, although the point about digital is well taken), but will do it if no one can come back with a better idea.

Any other suggestions? Thanks.

PAB

PAB 10-26-2004 04:20 PM

I've done a bit more searching and thought that the best way to find out if Linux can handle the digital connection is to use xmms 1.2.10. However, I have no idea how to get it or if I have it, how to start it. I'll do a bit more searching, but if anyone wants to help me out on this, I would appreciate it.

Hammett 10-26-2004 05:46 PM

You can get xmms at www.xmms.org.

Once you have it installed (via source code or rpm), do:
Options ---> Preferences
On Audio I/O Plugins (name may vary, I have it in Spanish and translation may be diferent), select CD player [libcdaudio.so] and press configure button
Now you can select which way you want to play audio CDs. Also put the device and mount point.
Once you're done with that, it should work.

Kilahchris 10-26-2004 05:56 PM

Quote:

I use digital reading for audio CD with xmms 1.2.10 and works perfectly.

It depends on the version of xmms you are using. I have used xmms with both RedHat 8 and 9 (I dont remember version) and i was unable to hear sound from cdrom with xmms. only after plugging in my audio cable i heard.

PAB 10-26-2004 10:12 PM

It is solved! It seems that it is due to the fact that I am using the digital connection. For anyone else who had this problem, this is what I did:
In terminal, type xmms, then press enter
press Ctrl+P, select the input plugin 'CD Audio Player' and press the configure button. Select 'digital audio extraction' and press the ok button. Click on the Apply button followed by the OK button. Press the Shift_L key combo and select the /mnt/cdrom(1,2,3) to play the audio CD.
This is courtesy of another forum, and solved the problem. Now if I can just get my modem to work!

PAB

Hammett 10-27-2004 03:51 AM

Quote:

Originally posted by Kilahchris
It depends on the version of xmms you are using. I have used xmms with both RedHat 8 and 9 (I dont remember version) and i was unable to hear sound from cdrom with xmms. only after plugging in my audio cable i heard.
If you read carefully my post, you'll see that I've already said which version of xmms has digital extraction...

Quote:

Originally posted by PAB
In terminal, type xmms, then press enter
press Ctrl+P, select the input plugin 'CD Audio Player' and press the configure button. Select 'digital audio extraction' and press the ok button. Click on the Apply button followed by the OK button. Press the Shift_L key combo and select the /mnt/cdrom(1,2,3) to play the audio CD.
This is courtesy of another forum, and solved the problem

This is actually what I've said in my previous post....you didn't need to look somewhere else ;)

PAB 10-27-2004 06:23 AM

Sorry, Hammett, I'm such a newbie that I needed the extra handholding of the other post. You're right - your post says the same thing, just didn't have all the extra (seemingly simple) steps that the other post had.

Thanks for you help!

PAB


All times are GMT -5. The time now is 11:32 PM.