LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-25-2004, 09:49 PM   #1
PAB
Member
 
Registered: Jun 2003
Posts: 44

Rep: Reputation: 15
Sound Card - can hear sounds and test fine - no cd sound


I have a soundblaster live card. When I do a soundcard detection, i can hear the test sound (although it lists 3 different sound cards). I can also hear system sounds (beeps, other noises when I shut down, etc). However, when I try to play a CD, I get no sound. The CD player functions (ie when I input the CD, the CD player starts and the track begins). However, no sound.

I am using Fedora 2 on a Pentium 4 system. lspci lists the sound card. I cannot, however, run sndconfig (it says command not found). I have tried adjusting the volume for all three listed sound cards and all different things (even headphone, line1, etc), and nothing works.

Does anyone have any help?

Thanks.

Paul
 
Old 10-25-2004, 10:20 PM   #2
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 46
Are you sure that mixer setting is turned up? Try this command:
alsamixer
Then look for a slider that says CD and turn it up to the max.
 
Old 10-26-2004, 12:56 AM   #3
Lenard Spencer
Member
 
Registered: Sep 2004
Location: Florida
Distribution: Slackware, Linux from Scratch
Posts: 174

Rep: Reputation: 20
Is the audio cable installed between the CD-ROM and the sound card? I know Windoze allows digital reading through the IDE bus, but I haven't yet seen that feature in Linux....
 
Old 10-26-2004, 02:21 AM   #4
fatblueduck
Member
 
Registered: Dec 2003
Location: Long Beach, CA
Distribution: haven't settled on one.
Posts: 251

Rep: Reputation: 30
if the command "alsamixer" or "amixer" doesn't bring any information, then you seriously need to install the ALSA driver. You can go here
www.alsa-project.org
 
Old 10-26-2004, 04:00 AM   #5
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,037

Rep: Reputation: 54
Quote:
Originally posted by Lenard Spencer
Is the audio cable installed between the CD-ROM and the sound card? I know Windoze allows digital reading through the IDE bus, but I haven't yet seen that feature in Linux....
I use digital reading for audio CD with xmms 1.2.10 and works perfectly.
 
Old 10-26-2004, 06:54 AM   #6
PAB
Member
 
Registered: Jun 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks everyone for the input! I checked alsamixer, and the CD was all the way up. Now, I have two cd players in my computer and I have tried with both and neither works. Just an idea - my motherboard came with integrated sound, and I also installed the SB Live card. Could Linux be using the wrong sound card (say, for example, the integrated one) while the CD players are using the SBLive card? If that's the case, how do I tell Linux which card to use?

I don't think that I need to install the alsa drivers since the other sounds work on my computer, and the soundcard detection plays the test sound. I haven't checked the audio cable (not sure what I'm looking for there and find it difficult to believe that is the problem since Windows works fine, although the point about digital is well taken), but will do it if no one can come back with a better idea.

Any other suggestions? Thanks.

PAB
 
Old 10-26-2004, 04:20 PM   #7
PAB
Member
 
Registered: Jun 2003
Posts: 44

Original Poster
Rep: Reputation: 15
I've done a bit more searching and thought that the best way to find out if Linux can handle the digital connection is to use xmms 1.2.10. However, I have no idea how to get it or if I have it, how to start it. I'll do a bit more searching, but if anyone wants to help me out on this, I would appreciate it.
 
Old 10-26-2004, 05:46 PM   #8
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,037

Rep: Reputation: 54
You can get xmms at www.xmms.org.

Once you have it installed (via source code or rpm), do:
Options ---> Preferences
On Audio I/O Plugins (name may vary, I have it in Spanish and translation may be diferent), select CD player [libcdaudio.so] and press configure button
Now you can select which way you want to play audio CDs. Also put the device and mount point.
Once you're done with that, it should work.
 
Old 10-26-2004, 05:56 PM   #9
Kilahchris
Member
 
Registered: Jan 2003
Location: NY
Distribution: Suse 9.0
Posts: 202

Rep: Reputation: 30
Quote:
I use digital reading for audio CD with xmms 1.2.10 and works perfectly.

It depends on the version of xmms you are using. I have used xmms with both RedHat 8 and 9 (I dont remember version) and i was unable to hear sound from cdrom with xmms. only after plugging in my audio cable i heard.
 
Old 10-26-2004, 10:12 PM   #10
PAB
Member
 
Registered: Jun 2003
Posts: 44

Original Poster
Rep: Reputation: 15
It is solved! It seems that it is due to the fact that I am using the digital connection. For anyone else who had this problem, this is what I did:
In terminal, type xmms, then press enter
press Ctrl+P, select the input plugin 'CD Audio Player' and press the configure button. Select 'digital audio extraction' and press the ok button. Click on the Apply button followed by the OK button. Press the Shift_L key combo and select the /mnt/cdrom(1,2,3) to play the audio CD.
This is courtesy of another forum, and solved the problem. Now if I can just get my modem to work!

PAB
 
Old 10-27-2004, 03:51 AM   #11
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,037

Rep: Reputation: 54
Quote:
Originally posted by Kilahchris
It depends on the version of xmms you are using. I have used xmms with both RedHat 8 and 9 (I dont remember version) and i was unable to hear sound from cdrom with xmms. only after plugging in my audio cable i heard.
If you read carefully my post, you'll see that I've already said which version of xmms has digital extraction...

Quote:
Originally posted by PAB
In terminal, type xmms, then press enter
press Ctrl+P, select the input plugin 'CD Audio Player' and press the configure button. Select 'digital audio extraction' and press the ok button. Click on the Apply button followed by the OK button. Press the Shift_L key combo and select the /mnt/cdrom(1,2,3) to play the audio CD.
This is courtesy of another forum, and solved the problem
This is actually what I've said in my previous post....you didn't need to look somewhere else

Last edited by Hammett; 10-27-2004 at 03:53 AM.
 
Old 10-27-2004, 06:23 AM   #12
PAB
Member
 
Registered: Jun 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Sorry, Hammett, I'm such a newbie that I needed the extra handholding of the other post. You're right - your post says the same thing, just didn't have all the extra (seemingly simple) steps that the other post had.

Thanks for you help!

PAB
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound not working in GNOME but sound card test works saravkrish Linux - Hardware 3 02-08-2006 11:03 AM
Cannot hear sounds from Kopete, or Gaim but all others sound s are OK izquierdista Suse/Novell 3 09-25-2005 12:58 PM
Sound Card on Fedora Core 2 only playing test sound silverado0103 Linux - Hardware 0 07-29-2004 03:23 PM
sound card configured. can hear testsound. cant hear cd's tdr_nj Red Hat 2 04-19-2004 09:36 PM
CD's play no sound- other sounds are fine turls Linux - Hardware 10 01-06-2004 01:45 PM


All times are GMT -5. The time now is 05:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration