-   Linux - Hardware (
-   -   Modprobe option issue (

nuubuntu 01-08-2007 12:06 AM

Modprobe option issue
I'm running Ubuntu 6.02 on a P4 2GHz system.

I just installed a PVR WinTV 150 card using the following how to:

I was wondering how I would add the option "tuner=50" option to the boot time mod probe commands (aliases, i guess). I knew how to do this with FC3 once upon a time, but no idea how to do it on a Ubuntu system. Here are the commands I issue to get my card operating.

"rmmod ivtv

modprobe ivtv tuner=50"

How do I get my system to do these automatically in the aliases file?


Brian1 01-08-2007 05:04 PM

Check this link on options.


nuubuntu 01-09-2007 08:04 AM

got it
I was just confussed by the way ubuntu handled modprobe options. I solved the problem by just placing an option tuner=50 line in the aliases.conf file.

jschiwal 01-09-2007 08:09 AM

You can include these options in /etc/modprobe.conf. You may even have commented examples for your module. Also, if you have the kernel-docs installed look for a text file which may have information on all options.

snippit from my modprobe.conf:

# options bttv    pll=1 radio=0 card=0
# options tuner  type=0
# options msp3400 once=1 simple=1

# install bttv /sbin/modprobe --ignore-install bttv && { /sbin/modprobe -k tuner; /sbin/modprobe -k msp3400; }

Is ivtv a modprobe alias?

Brian1 01-09-2007 02:53 PM

Glad to see you have it resolved.


All times are GMT -5. The time now is 01:49 PM.