LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   hybrid 7 ircd (http://www.linuxquestions.org/questions/linux-general-1/hybrid-7-ircd-138477/)

Crunch 01-25-2004 01:38 PM

hybrid 7 ircd
 
I installed hybrid 7 ircd on my box last night I've been trying to figure this out for awhile. I configured everything (I'm still thinking what i'm looking for is in the config) The directory resides in /usr/local/ircd

When I run it; it will tell me this

---------
haled@locho: /usr/local/ircd/bin$./ircd
ircd: version hybrid-7.0
ircd: pid 2347
ircd: running in background mode from /usr/local/ircd
---------

So I'm going to assume that it's actually running.
But whenever I try to connect to the server via irssi & bitchX it says that localhost does not have port 6667 open. When I use nmap the port doesn't show up. I tried opening the port via inetd.conf that didn't work out to well..

Does anyone have any suggestions?

trickykid 01-25-2004 01:47 PM

I tried the same server daemon and got the same thing. There is no verbose mode either to try and debug why it won't start. You might be better off just getting ircd or dancer-ircd which I got both to work with no problems.

green_dragon37 01-25-2004 01:49 PM

Does it show up if you run 'ps -e | grep irc' ?

Ian

Crunch 01-25-2004 01:51 PM

Nope it doesn't show-up, I tried IRCD and I don't even know what the funk happend there, everything got scattered around, it was kinda funny but a hassle at the sametime. I'll try out this .. dancer-ircd, thanks guys.

green_dragon37 01-25-2004 01:52 PM

Heh, well in the example ircd.conf, there is a line that hat to be removed before it will start, they check if you are paying attention or not.

Ian

green_dragon37 01-25-2004 01:55 PM

Um, I should probably mention, It looks like this:

Code:

/* REMOVE ME.  The following line checks you've been reading. */
        havent_read_conf = 1;

Ian

Crunch 01-25-2004 02:03 PM

Oof; That makes me feel like a dirty banus; Thanks

trickykid 01-25-2004 06:20 PM

Haha.. I feel dumb now.. that's most likely what I missed as well. Oh well, stupid little annoyances I would have to say that is and quite simply.. stupid.

Cheers.

Kristijan 07-02-2004 08:16 AM

I've spent around 2 hours tweaking this config trying to figure out what the hell was wrong with it. All it came down to is removing one stupid line. STUPID! Still I laugh :)

Kristijan

dtism 07-21-2004 06:56 AM

Hi, I'm new here, so forgive me for barging in to your thread.

I have YDL 3.0 and installed hybrid 7 yesterday, using:

./configure
make && make install

Which appeared to go smoothly (to my untrained eyes anyway)

I now seem to have an /usr/local/ircd dir but I can't seem to find an ircd.conf anywhere. I have however got an example.conf (I have removed - havent_read_conf = 1; )

Should I simply rename it to ircd.conf

And can anyone help me with setting up ircd as a service (in the same way that httpd is a service, i.e. loads at boot time, can be stopped and re-started)

Thanks,

Doug.

trickykid 07-21-2004 07:07 AM

Quote:

Originally posted by dtism
Hi, I'm new here, so forgive me for barging in to your thread.

I have YDL 3.0 and installed hybrid 7 yesterday, using:

./configure
make && make install

Which appeared to go smoothly (to my untrained eyes anyway)

I now seem to have an /usr/local/ircd dir but I can't seem to find an ircd.conf anywhere. I have however got an example.conf (I have removed - havent_read_conf = 1; )

Should I simply rename it to ircd.conf

And can anyone help me with setting up ircd as a service (in the same way that httpd is a service, i.e. loads at boot time, can be stopped and re-started)

Thanks,

Doug.

You can most likely copy the example.conf and customize it for your own ircd.conf file. To start on bootup, I've added it to my rc.local file using Slackware, not sure where would be best for YDL, never used it before ;)

But somewhere in your startup scripts will do just fine. Also note that ircd can't or shouldn't be started as root, so in my rc.local file I put something like this to start it as the user nobody:

su nobody -c /usr/local/ircd/bin/ircd

dtism 07-21-2004 07:39 AM

/\ Thanks for that trickykid. It seems to be working, although when I try to connect to the server, it tells me I need to install identd to use the server :confused: time for a bit of :study:

trickykid 07-21-2004 07:55 AM

Quote:

Originally posted by dtism
/\ Thanks for that trickykid. It seems to be working, although when I try to connect to the server, it tells me I need to install identd to use the server :confused: time for a bit of :study:
The identd man page which explains what it is and does: http://hegel.ittc.ukans.edu/topics/l....identd.8.html

I do believe you can configure IRCD to disable this feature. If its going to be a public IRC Server though, I'd suggest enabling it.

trickykid 07-21-2004 07:57 AM

Yeah, should look something like this in your conf file under the auth section, last line there, just make the yes a no:

Code:

auth {
        user = "*@*";
        class = "users";

        /* restricted: stop the client sending mode changes */
        #restricted = yes;

        /* have ident: require the user has identd to connect (OLD I: + flag) */
        have_ident = yes;
};

Cheers,

-trickykid

dtism 07-21-2004 09:32 AM

/\ Cool trickykid, that's a big help. I probably will disable the identd as I'm not planning to make this server public, at least not yet. ;)

:D

Doug


All times are GMT -5. The time now is 07:56 PM.