LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-25-2004, 12:38 PM   #1
Crunch
Member
 
Registered: Feb 2003
Location: York, PA
Distribution: Slackware, FreeBSD, OpenBSD
Posts: 162

Rep: Reputation: 30
hybrid 7 ircd


I installed hybrid 7 ircd on my box last night I've been trying to figure this out for awhile. I configured everything (I'm still thinking what i'm looking for is in the config) The directory resides in /usr/local/ircd

When I run it; it will tell me this

---------
haled@locho: /usr/local/ircd/bin$./ircd
ircd: version hybrid-7.0
ircd: pid 2347
ircd: running in background mode from /usr/local/ircd
---------

So I'm going to assume that it's actually running.
But whenever I try to connect to the server via irssi & bitchX it says that localhost does not have port 6667 open. When I use nmap the port doesn't show up. I tried opening the port via inetd.conf that didn't work out to well..

Does anyone have any suggestions?
 
Old 01-25-2004, 12:47 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
I tried the same server daemon and got the same thing. There is no verbose mode either to try and debug why it won't start. You might be better off just getting ircd or dancer-ircd which I got both to work with no problems.
 
Old 01-25-2004, 12:49 PM   #3
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
Does it show up if you run 'ps -e | grep irc' ?

Ian
 
Old 01-25-2004, 12:51 PM   #4
Crunch
Member
 
Registered: Feb 2003
Location: York, PA
Distribution: Slackware, FreeBSD, OpenBSD
Posts: 162

Original Poster
Rep: Reputation: 30
Nope it doesn't show-up, I tried IRCD and I don't even know what the funk happend there, everything got scattered around, it was kinda funny but a hassle at the sametime. I'll try out this .. dancer-ircd, thanks guys.
 
Old 01-25-2004, 12:52 PM   #5
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
Heh, well in the example ircd.conf, there is a line that hat to be removed before it will start, they check if you are paying attention or not.

Ian
 
Old 01-25-2004, 12:55 PM   #6
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
Um, I should probably mention, It looks like this:

Code:
/* REMOVE ME.  The following line checks you've been reading. */
	havent_read_conf = 1;
Ian

Last edited by green_dragon37; 01-25-2004 at 01:00 PM.
 
Old 01-25-2004, 01:03 PM   #7
Crunch
Member
 
Registered: Feb 2003
Location: York, PA
Distribution: Slackware, FreeBSD, OpenBSD
Posts: 162

Original Poster
Rep: Reputation: 30
Oof; That makes me feel like a dirty banus; Thanks
 
Old 01-25-2004, 05:20 PM   #8
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Haha.. I feel dumb now.. that's most likely what I missed as well. Oh well, stupid little annoyances I would have to say that is and quite simply.. stupid.

Cheers.
 
Old 07-02-2004, 07:16 AM   #9
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
I've spent around 2 hours tweaking this config trying to figure out what the hell was wrong with it. All it came down to is removing one stupid line. STUPID! Still I laugh

Kristijan
 
Old 07-21-2004, 05:56 AM   #10
dtism
LQ Newbie
 
Registered: Jul 2004
Location: UK
Distribution: YDL 3.0
Posts: 3

Rep: Reputation: 0
Hi, I'm new here, so forgive me for barging in to your thread.

I have YDL 3.0 and installed hybrid 7 yesterday, using:

./configure
make && make install

Which appeared to go smoothly (to my untrained eyes anyway)

I now seem to have an /usr/local/ircd dir but I can't seem to find an ircd.conf anywhere. I have however got an example.conf (I have removed - havent_read_conf = 1; )

Should I simply rename it to ircd.conf

And can anyone help me with setting up ircd as a service (in the same way that httpd is a service, i.e. loads at boot time, can be stopped and re-started)

Thanks,

Doug.
 
Old 07-21-2004, 06:07 AM   #11
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally posted by dtism
Hi, I'm new here, so forgive me for barging in to your thread.

I have YDL 3.0 and installed hybrid 7 yesterday, using:

./configure
make && make install

Which appeared to go smoothly (to my untrained eyes anyway)

I now seem to have an /usr/local/ircd dir but I can't seem to find an ircd.conf anywhere. I have however got an example.conf (I have removed - havent_read_conf = 1; )

Should I simply rename it to ircd.conf

And can anyone help me with setting up ircd as a service (in the same way that httpd is a service, i.e. loads at boot time, can be stopped and re-started)

Thanks,

Doug.
You can most likely copy the example.conf and customize it for your own ircd.conf file. To start on bootup, I've added it to my rc.local file using Slackware, not sure where would be best for YDL, never used it before

But somewhere in your startup scripts will do just fine. Also note that ircd can't or shouldn't be started as root, so in my rc.local file I put something like this to start it as the user nobody:

su nobody -c /usr/local/ircd/bin/ircd
 
Old 07-21-2004, 06:39 AM   #12
dtism
LQ Newbie
 
Registered: Jul 2004
Location: UK
Distribution: YDL 3.0
Posts: 3

Rep: Reputation: 0
Talking

/\ Thanks for that trickykid. It seems to be working, although when I try to connect to the server, it tells me I need to install identd to use the server time for a bit of
 
Old 07-21-2004, 06:55 AM   #13
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally posted by dtism
/\ Thanks for that trickykid. It seems to be working, although when I try to connect to the server, it tells me I need to install identd to use the server time for a bit of
The identd man page which explains what it is and does: http://hegel.ittc.ukans.edu/topics/l....identd.8.html

I do believe you can configure IRCD to disable this feature. If its going to be a public IRC Server though, I'd suggest enabling it.
 
Old 07-21-2004, 06:57 AM   #14
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Yeah, should look something like this in your conf file under the auth section, last line there, just make the yes a no:

Code:
auth {
        user = "*@*";
        class = "users";

        /* restricted: stop the client sending mode changes */
        #restricted = yes;

        /* have ident: require the user has identd to connect (OLD I: + flag) */
        have_ident = yes;
};
Cheers,

-trickykid
 
Old 07-21-2004, 08:32 AM   #15
dtism
LQ Newbie
 
Registered: Jul 2004
Location: UK
Distribution: YDL 3.0
Posts: 3

Rep: Reputation: 0
/\ Cool trickykid, that's a big help. I probably will disable the identd as I'm not planning to make this server public, at least not yet.



Doug
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux - DOS - hybrid? HitmanIP7 Linux - General 31 02-20-2010 08:06 AM
hybrid network problems BigCdaAnswer3 Linux - Networking 1 05-04-2004 09:39 PM
mount hybrid fs (mac os) CD? carboncopy Slackware 3 03-12-2004 04:22 AM
anyone here using hybrid 6.3.1? kublador Linux - Software 1 09-21-2003 11:24 AM
ircd-hybrid server installing problems _stef_ Linux - General 4 06-26-2002 09:12 AM


All times are GMT -5. The time now is 06:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration