LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (http://www.linuxquestions.org/questions/linux-games-33/)
-   -   Quake 1 & 2 installs to Debian laptop (http://www.linuxquestions.org/questions/linux-games-33/quake-1-and-2-installs-to-debian-laptop-377478/)

Grimmi- 10-27-2005 02:01 PM

Quake 1 & 2 installs to Debian laptop
 
Ok, been searching a lot and read alot, but im now asking to know, how to get Quake 1 & 2 installed to Debian Sarge, I have the windows cd's. What do I need to download and copy from the CD's, or a link to a tutorial (read: how-to) would allso be nice.

mammlouk 10-27-2005 03:16 PM

Quake 1:

http://liflg.org/?catid=6&gameid=12

Quake 2:

http://liflg.org/?catid=6&gameid=55

Grimmi- 10-27-2005 04:51 PM

thanks to mammlouk for the links, now I have some problems.

Quake1 lag's like hell and Quake2 crashes when I try to set up a open gl option, my GFX card is, by lspci,
0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 340M

It uses shared memory. I havent downloadet any ATI drivers for it, should I download or is there something else that would fix the problem?

The processor on my laptop is 1700Mhz pentium, with 256mb. I think this should be enough for Q1 and for Q2, but it seems not, any help?

mammlouk 10-27-2005 07:38 PM

First thing you should do is definitely install ati's drivers. Without them you will not get any 3d acceleration at all. That is definitely why Quake1 lags, and most likely why Quake 2 crashes.

Grimmi- 10-27-2005 08:26 PM

Now that I have the ati drivers, I still get major lagging, special when I set the game to use OpenGL as engine, and the equake is giving me this:

grimmi@Amy:~$ equake
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Error: FuhQuake couldn't load the required "libz.so" library. You must either:
i) (recommended) download the required libraries from www.fuhquake.net, or
ii) specify "-nolibpng" on the cmdline to disable png image features.

Checked the site out and didn't find the libz.so file anywhere


All times are GMT -5. The time now is 06:48 PM.