LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices



Reply
 
Search this Thread
Old 10-27-2005, 02:01 PM   #1
Grimmi-
Member
 
Registered: Oct 2005
Location: Finland
Distribution: Debian Lenny
Posts: 32

Rep: Reputation: 15
Quake 1 & 2 installs to Debian laptop


Ok, been searching a lot and read alot, but im now asking to know, how to get Quake 1 & 2 installed to Debian Sarge, I have the windows cd's. What do I need to download and copy from the CD's, or a link to a tutorial (read: how-to) would allso be nice.
 
Old 10-27-2005, 03:16 PM   #2
mammlouk
Member
 
Registered: May 2005
Location: Colorado
Distribution: Suse 10.0 OSS RC1
Posts: 100

Rep: Reputation: 15
Quake 1:

http://liflg.org/?catid=6&gameid=12

Quake 2:

http://liflg.org/?catid=6&gameid=55
 
Old 10-27-2005, 04:51 PM   #3
Grimmi-
Member
 
Registered: Oct 2005
Location: Finland
Distribution: Debian Lenny
Posts: 32

Original Poster
Rep: Reputation: 15
thanks to mammlouk for the links, now I have some problems.

Quake1 lag's like hell and Quake2 crashes when I try to set up a open gl option, my GFX card is, by lspci,
0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 340M

It uses shared memory. I havent downloadet any ATI drivers for it, should I download or is there something else that would fix the problem?

The processor on my laptop is 1700Mhz pentium, with 256mb. I think this should be enough for Q1 and for Q2, but it seems not, any help?
 
Old 10-27-2005, 07:38 PM   #4
mammlouk
Member
 
Registered: May 2005
Location: Colorado
Distribution: Suse 10.0 OSS RC1
Posts: 100

Rep: Reputation: 15
First thing you should do is definitely install ati's drivers. Without them you will not get any 3d acceleration at all. That is definitely why Quake1 lags, and most likely why Quake 2 crashes.
 
Old 10-27-2005, 08:26 PM   #5
Grimmi-
Member
 
Registered: Oct 2005
Location: Finland
Distribution: Debian Lenny
Posts: 32

Original Poster
Rep: Reputation: 15
Now that I have the ati drivers, I still get major lagging, special when I set the game to use OpenGL as engine, and the equake is giving me this:

grimmi@Amy:~$ equake
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Error: FuhQuake couldn't load the required "libz.so" library. You must either:
i) (recommended) download the required libraries from www.fuhquake.net, or
ii) specify "-nolibpng" on the cmdline to disable png image features.

Checked the site out and didn't find the libz.so file anywhere
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
debian php installs without mysql Red Squirrel Linux - Software 10 11-06-2005 08:10 AM
Default Debian Install installs Gnome and KDE microsoft/linux Debian 2 04-26-2005 03:10 PM
Nightmares....demudi/ubuntu/debian installs.. chrisj26 Debian 2 03-30-2005 03:33 AM
Getting a laptop: touchpad locking & bios conflicts & other possible laptop problems? mandrakemikael Linux - Laptop and Netbook 2 12-09-2004 08:15 AM
RH 9.0 installs but won't boot on a packard bell iGo 6000 laptop paupach Red Hat 2 03-19-2004 04:40 PM


All times are GMT -5. The time now is 07:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration