LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Incognito (http://www.linuxquestions.org/questions/incognito-85/)
-   -   Strange graphical problem on bootup (http://www.linuxquestions.org/questions/incognito-85/strange-graphical-problem-on-bootup-737622/)

Sylvester 07-03-2009 09:54 PM

Strange graphical problem on bootup
 
if I boot incognito onto an Asus EEE PC 900, after choosing my language it gives me a second choice of which graphical mode I wish to use. I simply hit spacebar, and everything boots perfectly.

However on the newer model (901), I never get the second choice. It straight away goes into some graphical mode that is wrong. For example as all of the system checks scroll by, each line of text starts in the middle of the screen and wraps around. And when the incognito / tor logo is displayed, it does not show the whole thing. it is as if the image is too big to fit on the screen, and so it just shows a window, but even this window jumps around - there is also some wrapping happening in the same way as with the text.

this seems very strange; the machines must be very similar in hardware and both support the maximum resolution of 1024 x 600.

This isn't really important, But it is a bit ugly - and on a distribution that is so clean and perfect looking, I am keen to put in the extra effort to keep it polished. but I have no idea how to fix this... any ideas?

also, how can I make it automatically boot in particular graphics mode? I can see it is very easy to automatically choose the language, by simply modifying the batch file. But how to do the samefor selecting the graphics mode?

Many thanks,

Sy

anonym 07-04-2009 06:38 AM

Quote:

Originally Posted by Sylvester (Post 3596118)
also, how can I make it automatically boot in particular graphics mode? I can see it is very easy to automatically choose the language, by simply modifying the batch file. But how to do the samefor selecting the graphics mode?

You change the vga kernel command-line parameter. Right now it's "vga=791", which corresponds to 1024x768 with 16-bit colour depth. For alternative modes, check the list by pressing SPACE instead of ENTER. The number will be displayed in hexadecimal (base 16) notation, e.g. 317 for 1024x768x16, so you'll have to convert it to base 10.

Sylvester 07-04-2009 10:03 AM

Thanks for the Info, Anonym.

Changing the kernel command line parameter 'vga=791' to 'vga=normal' solves it.

But how can I change the commandline parameter for good? I don't want to type it every time the computer boots, just so I have a nice tidy graphical boot process.

Wouldn't it make more sense to use the 'vga=normal' setting as a default?

Would you consider implementing this on the next release?

I still can't figure out why on the old notebook it causes the boot process waiting for keyboard input from me to choose graphics mode, whereas on the newer one it simply jumps into the wrong mode. It is the same thumbdrive.

Sy

anonym 07-04-2009 10:30 AM

Quote:

Originally Posted by Sylvester (Post 3596552)
But how can I change the commandline parameter for good? I don't want to type it every time the computer boots, just so I have a nice tidy graphical boot process.

This is pretty trivial for Incognito on a USB drive (otherwise it's not so trivial). Insert it and edit the syslinux/syslinux.cfg file, changing the vga value for the language option of you choice.

Quote:

Originally Posted by Sylvester (Post 3596552)
Wouldn't it make more sense to use the 'vga=normal' setting as a default?

That would break the Incognito splash theme since it's made for 1024x768 only.

business_kid 07-18-2009 03:47 AM

The old one asked for a mode probably because it had the boot parameter

vga-ask after the kernel in grub, or whatever your system uses.


All times are GMT -5. The time now is 06:02 PM.