LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Incognito
User Name
Password
Incognito This forum is for the discussion of Incognito Linux.

Notices

Reply
 
Search this Thread
Old 07-03-2009, 09:54 PM   #1
Sylvester
LQ Newbie
 
Registered: Jun 2009
Posts: 27

Rep: Reputation: 15
Strange graphical problem on bootup


if I boot incognito onto an Asus EEE PC 900, after choosing my language it gives me a second choice of which graphical mode I wish to use. I simply hit spacebar, and everything boots perfectly.

However on the newer model (901), I never get the second choice. It straight away goes into some graphical mode that is wrong. For example as all of the system checks scroll by, each line of text starts in the middle of the screen and wraps around. And when the incognito / tor logo is displayed, it does not show the whole thing. it is as if the image is too big to fit on the screen, and so it just shows a window, but even this window jumps around - there is also some wrapping happening in the same way as with the text.

this seems very strange; the machines must be very similar in hardware and both support the maximum resolution of 1024 x 600.

This isn't really important, But it is a bit ugly - and on a distribution that is so clean and perfect looking, I am keen to put in the extra effort to keep it polished. but I have no idea how to fix this... any ideas?

also, how can I make it automatically boot in particular graphics mode? I can see it is very easy to automatically choose the language, by simply modifying the batch file. But how to do the samefor selecting the graphics mode?

Many thanks,

Sy
 
Old 07-04-2009, 06:38 AM   #2
anonym
Incognito Maintainer
 
Registered: Oct 2008
Distribution: Gentoo
Posts: 100

Rep: Reputation: 26
Quote:
Originally Posted by Sylvester View Post
also, how can I make it automatically boot in particular graphics mode? I can see it is very easy to automatically choose the language, by simply modifying the batch file. But how to do the samefor selecting the graphics mode?
You change the vga kernel command-line parameter. Right now it's "vga=791", which corresponds to 1024x768 with 16-bit colour depth. For alternative modes, check the list by pressing SPACE instead of ENTER. The number will be displayed in hexadecimal (base 16) notation, e.g. 317 for 1024x768x16, so you'll have to convert it to base 10.
 
Old 07-04-2009, 10:03 AM   #3
Sylvester
LQ Newbie
 
Registered: Jun 2009
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks for the Info, Anonym.

Changing the kernel command line parameter 'vga=791' to 'vga=normal' solves it.

But how can I change the commandline parameter for good? I don't want to type it every time the computer boots, just so I have a nice tidy graphical boot process.

Wouldn't it make more sense to use the 'vga=normal' setting as a default?

Would you consider implementing this on the next release?

I still can't figure out why on the old notebook it causes the boot process waiting for keyboard input from me to choose graphics mode, whereas on the newer one it simply jumps into the wrong mode. It is the same thumbdrive.

Sy
 
Old 07-04-2009, 10:30 AM   #4
anonym
Incognito Maintainer
 
Registered: Oct 2008
Distribution: Gentoo
Posts: 100

Rep: Reputation: 26
Quote:
Originally Posted by Sylvester View Post
But how can I change the commandline parameter for good? I don't want to type it every time the computer boots, just so I have a nice tidy graphical boot process.
This is pretty trivial for Incognito on a USB drive (otherwise it's not so trivial). Insert it and edit the syslinux/syslinux.cfg file, changing the vga value for the language option of you choice.

Quote:
Originally Posted by Sylvester View Post
Wouldn't it make more sense to use the 'vga=normal' setting as a default?
That would break the Incognito splash theme since it's made for 1024x768 only.
 
Old 07-18-2009, 03:47 AM   #5
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,299

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
The old one asked for a mode probably because it had the boot parameter

vga-ask after the kernel in grub, or whatever your system uses.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange message on Fedora 7 bootup , also Firefox problem RetiredInMaine Fedora 4 08-31-2007 02:14 PM
I don't get a graphical bootup in Suse 10 coolblue Suse/Novell 6 04-22-2006 03:08 AM
Graphical screen during suse bootup linuxprogrammer Suse/Novell 1 01-31-2005 04:01 AM
disable graphical bootup? evilchild Mandriva 16 04-17-2004 01:39 PM
Nice graphical bootup....gone avatarpalin Mandriva 5 09-10-2003 08:57 PM


All times are GMT -5. The time now is 05:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration