LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Yum update fails - Missing Dependency (http://www.linuxquestions.org/questions/fedora-35/yum-update-fails-missing-dependency-609075/)

godisadj 12-25-2007 03:58 PM

Yum update fails - Missing Dependency
 
Hi,

I have newly installed Fedora 8 and I'm trying to update my software with a yum update. The process fails with the error:

Code:

--> Processing Dependency: gnome-vfs2 = 2.20.0-3.fc8 for package: gnome-vfs2-smb
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-vfs2 = 2.20.0-3.fc8 is needed by package gnome-vfs2-smb

Typing "rpm -qa | grep gnome-vfs2" gives the output:

Code:

gnome-vfs2-smb-2.20.1-1.fc8
gnome-vfs2-2.20.0-3.fc8
gnome-vfs2-obexftp-0.4-2.fc8
gnome-vfs2-smb-2.20.0-3.fc8

So presumably I already have the required dependency installed? Any ideas why the update is knocking me back and how to sort it?

Much thanks.

Glennzo 12-25-2007 08:44 PM

Silly as it may seem, updating yum itself, yum update yum, may help. Apparently the is a bug with yum-3.2.7.

godisadj 12-26-2007 07:01 AM

Thank you for your reply. I should have mentioned that I have already updated yum after reading of a similar problem here on the forums. I am running yum-3.2.8-2.fc8, and the problem still persists.

I've added gnome-vfs2 to the exclude list in yum.conf as a temporary work-around. Now yum knocks me back with the error:

Code:

Finished Dependency Resolution
Error: Missing Dependency: samba-common = 3.0.26a-6.fc8 is needed by package samba-client
Error: Missing Dependency: rpm = 4.4.2.2-3.fc8 is needed by package rpm-python
Error: Missing Dependency: rpm = 4.4.2.2-3.fc8 is needed by package rpm-libs

Again, these packages exist on my system with the required version, according to "rpm -qa | grep samba-common" and "rpm -qa | grep rpm" respectively.

I'll continue to add these problem packages to the excludes line in yum.conf. Obviously it would be nice to get this working though!

Any more ideas?

Cheers.

misc 12-31-2007 07:14 PM

Your conclusions are wrong. More often than not, during a yum update it doesn't matter at all what packages are installed already, because yum often replaces or erases packages. This can break dependencies and causes a transaction test to fail. So, to analyse your problems, you need to show what updates wait in the repository.

Quote:

Originally Posted by godisadj (Post 3001341)
gnome-vfs2-smb-2.20.1-1.fc8
gnome-vfs2-2.20.0-3.fc8
gnome-vfs2-obexftp-0.4-2.fc8
gnome-vfs2-smb-2.20.0-3.fc8

Did you notice that you have two copies of gnome-vfs2-smb and that you don't have the newer gnome-vfs2 package yet? Erase the older one and update gnome-vfs2 before trying to continue: rpm --erase --justdb --nodeps gnome-vfs2-smb-2.20.0-3.fc8 ; yum -y update gnome-vfs2

Glennzo 01-01-2008 05:26 PM

Except when it tells you that you can't install kmod-nvidia-1.2.3, for example, because you need kernel-1.2.3, but you can't install kernel-1.2.3 because you don't have kmod-nvidia-1.2.3 installed, or kernel-1.2.3 is already installed but yum doesn't seem to know about it. Quit common lately.

misc 01-02-2008 05:44 AM

True, but kernel and kmod packages are a special case. Not only because there is extra code for them in yum (and with F8 a bug in yum broke livna's kmod packages). By default two kernel packages are kept before a kernel update removes an old package. That's very different from normal packages.


All times are GMT -5. The time now is 07:24 PM.