LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-25-2007, 04:58 PM   #1
godisadj
LQ Newbie
 
Registered: Dec 2007
Distribution: Fedora 8
Posts: 2

Rep: Reputation: 0
Yum update fails - Missing Dependency


Hi,

I have newly installed Fedora 8 and I'm trying to update my software with a yum update. The process fails with the error:

Code:
--> Processing Dependency: gnome-vfs2 = 2.20.0-3.fc8 for package: gnome-vfs2-smb
--> Finished Dependency Resolution
Error: Missing Dependency: gnome-vfs2 = 2.20.0-3.fc8 is needed by package gnome-vfs2-smb
Typing "rpm -qa | grep gnome-vfs2" gives the output:

Code:
gnome-vfs2-smb-2.20.1-1.fc8
gnome-vfs2-2.20.0-3.fc8
gnome-vfs2-obexftp-0.4-2.fc8
gnome-vfs2-smb-2.20.0-3.fc8
So presumably I already have the required dependency installed? Any ideas why the update is knocking me back and how to sort it?

Much thanks.
 
Old 12-25-2007, 09:44 PM   #2
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
Silly as it may seem, updating yum itself, yum update yum, may help. Apparently the is a bug with yum-3.2.7.
 
Old 12-26-2007, 08:01 AM   #3
godisadj
LQ Newbie
 
Registered: Dec 2007
Distribution: Fedora 8
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you for your reply. I should have mentioned that I have already updated yum after reading of a similar problem here on the forums. I am running yum-3.2.8-2.fc8, and the problem still persists.

I've added gnome-vfs2 to the exclude list in yum.conf as a temporary work-around. Now yum knocks me back with the error:

Code:
 Finished Dependency Resolution
Error: Missing Dependency: samba-common = 3.0.26a-6.fc8 is needed by package samba-client
Error: Missing Dependency: rpm = 4.4.2.2-3.fc8 is needed by package rpm-python
Error: Missing Dependency: rpm = 4.4.2.2-3.fc8 is needed by package rpm-libs
Again, these packages exist on my system with the required version, according to "rpm -qa | grep samba-common" and "rpm -qa | grep rpm" respectively.

I'll continue to add these problem packages to the excludes line in yum.conf. Obviously it would be nice to get this working though!

Any more ideas?

Cheers.
 
Old 12-31-2007, 08:14 PM   #4
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Your conclusions are wrong. More often than not, during a yum update it doesn't matter at all what packages are installed already, because yum often replaces or erases packages. This can break dependencies and causes a transaction test to fail. So, to analyse your problems, you need to show what updates wait in the repository.

Quote:
Originally Posted by godisadj View Post
gnome-vfs2-smb-2.20.1-1.fc8
gnome-vfs2-2.20.0-3.fc8
gnome-vfs2-obexftp-0.4-2.fc8
gnome-vfs2-smb-2.20.0-3.fc8
Did you notice that you have two copies of gnome-vfs2-smb and that you don't have the newer gnome-vfs2 package yet? Erase the older one and update gnome-vfs2 before trying to continue: rpm --erase --justdb --nodeps gnome-vfs2-smb-2.20.0-3.fc8 ; yum -y update gnome-vfs2
 
Old 01-01-2008, 06:26 PM   #5
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
Except when it tells you that you can't install kmod-nvidia-1.2.3, for example, because you need kernel-1.2.3, but you can't install kernel-1.2.3 because you don't have kmod-nvidia-1.2.3 installed, or kernel-1.2.3 is already installed but yum doesn't seem to know about it. Quit common lately.
 
Old 01-02-2008, 06:44 AM   #6
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
True, but kernel and kmod packages are a special case. Not only because there is extra code for them in yum (and with F8 a bug in yum broke livna's kmod packages). By default two kernel packages are kept before a kernel update removes an old package. That's very different from normal packages.
 
  


Reply

Tags
update, yum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum update fails because of faad2 dependency alabamaman Linux - Software 1 09-11-2007 11:41 PM
yum update gives 'Error: Missing Dependency:" on fresh install tightface Linux - Software 4 07-04-2007 03:10 AM
How to tell yum missing dependency is actually there decrepit Fedora 2 02-04-2007 06:36 AM
yum missing dependencY puppet Linux - Software 6 10-26-2005 11:20 AM
FC4: "yum update libcddb" fails -- missing dependancy problem: MattCrypto Fedora 2 07-28-2005 07:47 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration