LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   graphical boot not working with Fedora 7 (http://www.linuxquestions.org/questions/fedora-35/graphical-boot-not-working-with-fedora-7-a-558535/)

ruffles 06-02-2007 04:10 AM

graphical boot not working with Fedora 7
 
I installed fedora 7 yesterday and it seems like rhgb is not working correctly.

At boot, screen flickers once the moment rhgb should start, but continues to boot in text mode.

grub.conf:
title Fedora 7
root (hd0,4)
kernel /boot/vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.21-1.3194.fc7.img

/etc/sysconfig/desktop:
DESKTOP="KDE"
DISPLAYMANAGER="KDE"

yum:
yum list installed | grep rhgb
rhgb.i386 0.17.6-1.fc7 installed
yum list installed | grep kmod-nvidia
kmod-nvidia.i686 1.0.9755-3.2.6.21_1.31 installed

"desktop" file was added manually, but when it's deleted (gdm starts instead of kdm) - nothing changes.
After the boot, normal X server starts with the login prompt and there seems to bo nothing of interest in /var/log/messages and /var/log/Xorg.0.log, but i'll post them here if needed.

Thanks

reddazz 06-02-2007 11:37 PM

Moved: This thread is more suitable in the Fedora forum and has been moved accordingly to help your thread/question get the exposure it deserves.

Guardian9978 06-06-2007 07:09 AM

I had this exact same problem and the way I fixed it was by installing:

"xorg-x11-fonts-base"

using Yum Extender

and it worked just fine.

Hope this helps.

ruffles 06-06-2007 08:28 AM

Well, that worked like a charm. Actually, that and adding:
Option "HWCursor" "false"
to the /etc/X11/xorg.conf section "Device" (nvidia card), because the mouse cursor was gone.

Thank you.

wmakowski 06-06-2007 08:41 AM

This sounds more like a video mode or framebuffer problem than something to do with X11. The reason I say this is because we haven't reach the point where the X server takes over. We're still booting and the kernel is in charge so to speak. It is more likely that the kernel doesn't know exactly how to deal with your graphics card/monitor combination so it goes back to the basics.

The vga= and video= are two kernel parameters may resolve this problem. Essentially they set your screen resolution and refresh rate. Here is the text from kernel-parameters.txt
Code:

        video=          [FB] Frame buffer configuration
                        See Documentation/fb/modedb.txt.

        vga=            [BOOT,IA-32] Select a particular video mode
                        See Documentation/i386/boot.txt and
                        Documentation/svga.txt.
                        Use vga=ask for menu.
                        This is actually a boot loader parameter; the value is
                        passed to the kernel using a special protocol.

More info: Linux Kernel Documentation, Framebuffer HOWTO

Bill

ruffles 06-06-2007 01:17 PM

installing xorg-x11-fonts-base solved the problem. Additionally adding HWcursor to xorg.conf and copying xorg.conf to /etc/rhgb solved also disappearing cursor and resolution of the rhgb boot screen.
And since rhgb starts it's own full x server, it's exactly the point where it takes over.
http://dailypackage.fedorabook.com/i...ot-Screen.html

Thanks again


All times are GMT -5. The time now is 12:54 AM.