LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-02-2007, 05:10 AM   #1
ruffles
LQ Newbie
 
Registered: Apr 2007
Location: usually in front of the keyboard
Distribution: Redhat, Fedora, Centos, Ubuntu, Debian, Solaris
Posts: 15

Rep: Reputation: 0
Unhappy graphical boot not working with Fedora 7


I installed fedora 7 yesterday and it seems like rhgb is not working correctly.

At boot, screen flickers once the moment rhgb should start, but continues to boot in text mode.

grub.conf:
title Fedora 7
root (hd0,4)
kernel /boot/vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.21-1.3194.fc7.img

/etc/sysconfig/desktop:
DESKTOP="KDE"
DISPLAYMANAGER="KDE"

yum:
yum list installed | grep rhgb
rhgb.i386 0.17.6-1.fc7 installed
yum list installed | grep kmod-nvidia
kmod-nvidia.i686 1.0.9755-3.2.6.21_1.31 installed

"desktop" file was added manually, but when it's deleted (gdm starts instead of kdm) - nothing changes.
After the boot, normal X server starts with the login prompt and there seems to bo nothing of interest in /var/log/messages and /var/log/Xorg.0.log, but i'll post them here if needed.

Thanks
 
Old 06-03-2007, 12:37 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Moved: This thread is more suitable in the Fedora forum and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 06-06-2007, 08:09 AM   #3
Guardian9978
LQ Newbie
 
Registered: Jun 2007
Posts: 1

Rep: Reputation: 0
I had this exact same problem and the way I fixed it was by installing:

"xorg-x11-fonts-base"

using Yum Extender

and it worked just fine.

Hope this helps.
 
Old 06-06-2007, 09:28 AM   #4
ruffles
LQ Newbie
 
Registered: Apr 2007
Location: usually in front of the keyboard
Distribution: Redhat, Fedora, Centos, Ubuntu, Debian, Solaris
Posts: 15

Original Poster
Rep: Reputation: 0
Well, that worked like a charm. Actually, that and adding:
Option "HWCursor" "false"
to the /etc/X11/xorg.conf section "Device" (nvidia card), because the mouse cursor was gone.

Thank you.
 
Old 06-06-2007, 09:41 AM   #5
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
This sounds more like a video mode or framebuffer problem than something to do with X11. The reason I say this is because we haven't reach the point where the X server takes over. We're still booting and the kernel is in charge so to speak. It is more likely that the kernel doesn't know exactly how to deal with your graphics card/monitor combination so it goes back to the basics.

The vga= and video= are two kernel parameters may resolve this problem. Essentially they set your screen resolution and refresh rate. Here is the text from kernel-parameters.txt
Code:
        video=          [FB] Frame buffer configuration
                        See Documentation/fb/modedb.txt.

        vga=            [BOOT,IA-32] Select a particular video mode
                        See Documentation/i386/boot.txt and
                        Documentation/svga.txt.
                        Use vga=ask for menu.
                        This is actually a boot loader parameter; the value is
                        passed to the kernel using a special protocol.
More info: Linux Kernel Documentation, Framebuffer HOWTO

Bill
 
Old 06-06-2007, 02:17 PM   #6
ruffles
LQ Newbie
 
Registered: Apr 2007
Location: usually in front of the keyboard
Distribution: Redhat, Fedora, Centos, Ubuntu, Debian, Solaris
Posts: 15

Original Poster
Rep: Reputation: 0
installing xorg-x11-fonts-base solved the problem. Additionally adding HWcursor to xorg.conf and copying xorg.conf to /etc/rhgb solved also disappearing cursor and resolution of the rhgb boot screen.
And since rhgb starts it's own full x server, it's exactly the point where it takes over.
http://dailypackage.fedorabook.com/i...ot-Screen.html

Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Complete graphical boot for Fedora gangaraju Fedora 2 10-21-2005 12:41 AM
Complete graphical boot for Fedora gangaraju LinuxQuestions.org Member Intro 2 10-20-2005 02:08 PM
Network not working under Fedora, but does under gentoo boot CD BrianK Fedora 7 04-08-2005 05:18 PM
Fedora Graphical boot jimmmac Fedora 5 11-10-2003 04:24 AM
Fedora Graphical Boot-up Bobmeister Red Hat 0 10-29-2003 02:25 PM


All times are GMT -5. The time now is 05:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration