LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Gnome disappeared after installing FUSE (http://www.linuxquestions.org/questions/fedora-35/gnome-disappeared-after-installing-fuse-535416/)

jasontn 03-07-2007 11:59 AM

Gnome disappeared after installing FUSE
 
I yum installed ntfs-3g successfully onto my FC6. But GNOME disappeared the next time i rebooted my pc. Now, when i startx (since i'm using level 3 inittab), i get a different window environment - very basic functions and very high screen resolution. Not sure if its xfce or something else.

I ran gdm and i got the standard log in screen. When i log in, it's back to this new desktop.

How do i restore my sessions back to GNOME?

Junior Hacker 03-08-2007 05:06 AM

Did you try to remove Fuse & ntfs-3g to see if things come back to normal? you can always re-install them after. I installed fuse from source and then ntfs-3g after from source also because I read somewhere the Fedora packages had problems with Selinux or something. The source packages work great and did not upset anything.

If you want to try the source packages use the link below, on that page under the word "Download" in the first sentence is the highlighted word "Fuse", click it to get it. Follow instructions on the ntfs-3g page to install and set up fstab. You need kernel-devel & kernel-headers installed. NOTE: (I had to remove the original line in fstab for the NTFS partition).

http://www.ntfs-3g.org/

PTrenholme 03-08-2007 09:55 AM

When you boot, there should be a "Menu" button on the login screen. Press it, and you should have a "Window Manager" selection. Pick "GNOME," and then login. (The default is specified in /etc/sysconf/desktop, but installing FUSE should not have changed it.)

Junior Hacker 03-08-2007 01:07 PM

I ran into a similar situation when I first got FC6, I installed both Gnome & KDE. Then tried to remove Gnome via the Add & Remove software GUI. The very basic login kind of had me thinking it was an Xorg login and the Gnome display manager had been un-installed. The basic windows you see may also just be an X environment, meaning there is something wrong/missing with Gnome. I just reinstalled because it was a fresh installation anyway, but that does'nt help your situation. And I don't know what to suggest, just mentioning a similar experience I had and what I thought the problem was.

jasontn 03-09-2007 01:46 AM

Quote:

Originally Posted by PTrenholme
When you boot, there should be a "Menu" button on the login screen. Press it, and you should have a "Window Manager" selection. Pick "GNOME," and then login. (The default is specified in /etc/sysconf/desktop, but installing FUSE should not have changed it.)

My /etc/sysconf/desktop is an empty file. Looking at my other working pc's file - also contains nothing.

What should I do next?

PTrenholme 03-09-2007 08:18 AM

Quote:

Originally Posted by jasontn
My /etc/sysconf/desktop is an empty file. Looking at my other working pc’s file–also contains nothing.

What should I do next?

Oops. That should be sysconfig not sysconf. Here’s what mine looks like, but I use mostly KDE, and prefer the KDM to the GNOME desktop manager because it supports (on KDE) a “Switch User” command that lets me start a different users or windowing system in a separate X session on my system. (Once you’ve started them, you can switch using Ctrl-Alt-F7 ... Ctrl-Alt-F12, so you can, e.g., leave GNOME running and easily switch back to KDE)
Code:

$ cat /etc/sysconfig/desktop
DESKTOP=KDE
#DISPLAYMANAGER=GNOME
DISPLAYMANAGER=KDE
#DISPLAYMANAGER=XDM

<edit>
If the desktop file is really missing, then the default code in /etc/X11/xinit/Xclients is run, and the default display manager stuff is used:
Code:

# Argh! Nothing good is installed. Fall back to twm
{
    # gosh, neither fvwm95 nor fvwm2 is available;
    # fall back to failsafe settings
    [ -x /usr/bin/xsetroot ] && /usr/bin/xsetroot -solid '#222E45'

    if [ -x /usr/bin/xclock ] ; then
        /usr/bin/xclock -geometry 100x100-5+5 &
    elif [ -x /usr/bin/xclock ] ; then
        /usr/bin/xclock -geometry 100x100-5+5 &
    fi
    if [ -x /usr/bin/xterm ] ; then
        /usr/bin/xterm -geometry 80x50-50+150 &
    fi
    if [ -x /usr/bin/firefox -a -f /usr/share/doc/HTML/index.html ]; then
        /usr/bin/firefox /usr/share/doc/HTML/index.html &
    fi
    if [ -x /usr/bin/twm ] ; then
        exec /usr/bin/twm
    fi
}

</edit>

jasontn 03-10-2007 02:24 AM

Quote:

Originally Posted by PTrenholme
Oops. That should be sysconfig not sysconf. Here’s what mine looks like, but I use mostly KDE, and prefer the KDM to the GNOME desktop manager because it supports (on KDE) a “Switch User” command that lets me start a different users or windowing system in a separate X session on my system. (Once you’ve started them, you can switch using Ctrl-Alt-F7 ... Ctrl-Alt-F12, so you can, e.g., leave GNOME running and easily switch back to KDE)
Code:

$ cat /etc/sysconfig/desktop
DESKTOP=KDE
#DISPLAYMANAGER=GNOME
DISPLAYMANAGER=KDE
#DISPLAYMANAGER=XDM

<edit>
If the desktop file is really missing, then the default code in /etc/X11/xinit/Xclients is run, and the default display manager stuff is used:
Code:

# Argh! Nothing good is installed. Fall back to twm
{
    # gosh, neither fvwm95 nor fvwm2 is available;
    # fall back to failsafe settings
    [ -x /usr/bin/xsetroot ] && /usr/bin/xsetroot -solid '#222E45'

    if [ -x /usr/bin/xclock ] ; then
        /usr/bin/xclock -geometry 100x100-5+5 &
    elif [ -x /usr/bin/xclock ] ; then
        /usr/bin/xclock -geometry 100x100-5+5 &
    fi
    if [ -x /usr/bin/xterm ] ; then
        /usr/bin/xterm -geometry 80x50-50+150 &
    fi
    if [ -x /usr/bin/firefox -a -f /usr/share/doc/HTML/index.html ]; then
        /usr/bin/firefox /usr/share/doc/HTML/index.html &
    fi
    if [ -x /usr/bin/twm ] ; then
        exec /usr/bin/twm
    fi
}

</edit>

Yes, it's exactly this default display manager stuff that i am getting, i.e. one clock, one terminal and one firefox.

I edited /etc/sysconfig/desktop to:
DISPLAYMANAGER=GNOME
DISPLAYMANAGER=XDM

but i still get back the same basic stuff above. I've tried yum update gnome but nothing to update.

Should i yum remove gnome and then reinstall?

PTrenholme 03-12-2007 03:45 PM

Quote:

Originally Posted by jasontn
Yes, it’s exactly this default display manager stuff that i am getting, i.e. one clock, one terminal and one firefox.

I edited /etc/sysconfig/desktop to:
DISPLAYMANAGER=GNOME
DISPLAYMANAGER=XDM

but i still get back the same basic stuff above. I’ve tried yum update gnome but nothing to update.

Should i yum remove gnome and then reinstall?

Did you try GDM and/or KDM as your display manager? GDM is the prefered display manager if you’re running GNOME, although I prefer KDM. I’ve never tried XDM.

Did you look at the part of Xinit that preceeds the section I quoted?
Code:

GSESSION="$(which gnome-session 2>/dev/null)"
STARTKDE="$(which startkde 2>/dev/null)"

# check to see if the user has a preferred desktop
PREFERRED=
if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED="$GSESSION"
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED="$STARTKDE"
    fi
fi

if [ -n "$PREFERRED" ]; then
    exec "$PREFERRED"
fi

# now if we can reach here, either no desktop file was present,
# or the desktop requested is not installed.

if [ -n "$GSESSION" ]; then
    # by default, we run GNOME.
    exec "$GSESSION"
elif [ -n "$STARTKDE" ]; then
    # if GNOME isn't installed, try KDE.
    exec "$STARTKDE"
fi

# Failsafe.

# these files are left sitting around by TheNextLevel.
rm -f $HOME/Xrootenv.0

# Argh! Nothing good is installed. Fall back to twm

Note that the defaults are defined by the which commands. On my system (with both GNOME and KDE installed) I get
Code:

$ which gnome-session
/usr/bin/gnome-session
$ which startkde
/usr/bin/startkde

when I run the commands by hand. If you don’t get any output from the which command, you either don’t have GNOME (or KDE) installed, or you installed them to some very strange location.

If you do a whereis gdm do you get
Code:

$ whereis gdm
gdm: /usr/sbin/gdm /etc/gdm /usr/share/gdm /usr/share/man/man1/gdm.1.gz

?

jasontn 03-13-2007 10:12 PM

My /etc/X11/xinit/Xclients looks the same as yours.

I've tried DISPLAYMANAGER=GDM but received the same failsafe X.

which gnome-session returns no gnome-session
which startkde returns no startkde (i didn't install kde)

whereis gdm returns same answer as yours.

system-config-display starts the GUI configuratin form. I changed the colour depth to thousands of colour, then started x again. Now I get lower resolution (800x600 as selected) but still the same failsafe window.

PTrenholme 03-14-2007 12:36 PM

The fact that the which gnome-session returned nothing implies, I believe, that your GNOME installation has been corrupted.

First, try a locate gnome-session to see it it somehow got misplaced. It should return some like this:
Code:

# locate -r gnome-session$
/home/Judy/.gconf/apps/gnome-session
/home/peter/.gconf/apps/gnome-session
/usr/bin/gnome-session

(You may need to do a updatedb to get the locate data base initalized, which can take quite a while to finish.)

What happens if you do a yum update gnome-session? (I suspect nothing but a “No updates” message.)

If yum thinks it’s up to date, try a
Code:

rpm --replacepkgs -ihv http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/gnome-session.rpm
which should re-install the gnome-session package.
Note: I’ve never had to do this, so I’m just guessing from the rpm documentation.

Alternatively, install KDE and yumex, remove GNOME (and everything that depends on GNOME, and then reinstall GNOME et alas. (yumex is a nice GUI frount-end for yum that makes reinstalling GNOME much easier.)

jasontn 03-15-2007 12:56 AM

I've yum removed gnome-desktop.i386. It removed 20+ packages that also depended on it. Then i yum installed gnome-desktop.i386 and it installed only one package. Startx still gives the same problem.

Installed yumex, then used it to installed eog. It installed only one package without problem. So it looks like didn't do much.

I did this as well:
[root@localhost ~]# locate gnome-session
/root/gnome-session.txt
/usr/share/icons/Bluecurve/16x16/apps/gnome-session.png
/usr/share/icons/Bluecurve/24x24/apps/gnome-session.png
/usr/share/icons/Bluecurve/32x32/apps/gnome-session.png
/usr/share/icons/Bluecurve/36x36/apps/gnome-session.png
/usr/share/icons/Bluecurve/48x48/apps/gnome-session.png
/usr/share/icons/HighContrast-SVG/scalable/apps/gnome-session.svg
/usr/share/icons/HighContrastLargePrint/48x48/apps/gnome-session.png
/usr/share/icons/HighContrastLargePrintInverse/48x48/apps/gnome-session.png
/usr/share/icons/gnome/16x16/apps/gnome-session.png
/usr/share/icons/gnome/22x22/apps/gnome-session.png
/usr/share/icons/gnome/24x24/apps/gnome-session.png
/usr/share/icons/gnome/48x48/apps/gnome-session.png


[root@localhost ~]# rpm --replacepkgs -ihv http://download.fedora.redhat.com/pu...me-session.rpm
Retrieving http://download.fedora.redhat.com/pu...me-session.rpm
error: open of <!DOCTYPE failed: No such file or directory
error: open of HTML failed: No such file or directory
error: open of PUBLIC failed: No such file or directory
-//IETF//DTD HTML 2.0//EN>: not an rpm package (or package manifest):

PTrenholme 03-15-2007 10:55 AM

Sorry, I left the machine type out ot the path:

Try http://download.fedora.redhat.com/pu...1.fc6.i386.rpm if you have a 32-bit processor, and http://download.fedora.redhat.com/pu...fc6.x86_64.rpm if you have a 64 bit one.

Since you uninstalled GNOME, you'll also need to re-install it.

Try a yum install gnome.

jasontn 03-19-2007 03:50 AM

I tried all the suggestions but to no avail.

In the end, i started X, then ran pirut and installed GNOME. And it worked!! GNOME is back.

Thank you all for the suggestions. It helped me to learn more about my system.

Junior Hacker 03-19-2007 06:15 AM

I have two copies of Fedora 6, in the test side I installed Fuse & ntfs-3g from source and it all worked great, I originally avoided the ones from Fedora because I heard there may be problems with Selinux.
Well, yesterday I re-built another copy of Fedora for the heck of it and installed the Fedora versions, also edited fstab to have the ntfs partition auto-mounted at boot. After re-boot I had major problems, could not do anything with yum, could not access System Services to try disabling Selinux, many administrative tasks were unavailable, things were freezing up.
So I had to wipe that partition and re-load an image of a fresh install and this time I disabled Selinux first, then installed the Fedora Fuse & ntfs-3g packages. She's stable now, so I made another image of the OS. Now I plan on tampering with Selinux settings to see if I can have both as it only takes 8 or so minutes to wipe the partition and re-load the working copy with Selinux disabled.
I kind of prefer to have the Fedora packages over the source only for the possible compatibility with updates, but it won't be long before updates end for FC 6 any way, so I'm wondering if I should just use the source packages and have Selinux without headaches.

Junior Hacker 03-23-2007 03:25 AM

Well
I gave up on using the Fedora packages, not only did I have to disable SELinux, Fedora could not resume the swap partition, no swap. Kind of tough on memory when you like 6 or 8 desktops showing personal photos. I went back to using Fuse & ntfs-3g from source, using them, I have it all, and it's solid as sandstone.


All times are GMT -5. The time now is 04:39 PM.