LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   FC6 updates - Another application is running ... (http://www.linuxquestions.org/questions/fedora-35/fc6-updates-another-application-is-running-503773/)

Micro420 11-21-2006 10:49 PM

FC6 updates - Another application is running ...
 
**NEVERMIND! I rebooted and the problem went away. I was able to update.**
-----------------

I got a pop-up balloon on my FC6 desktop saying that there were some packages available for update. I click on it and then I get a popup that says, "Another application is running which is accessing software information." I have to click 'ok' and close it.

Now what do I do? I tried accessing it minutes later but I still get the same error. What's going on????

FredGSanford 11-21-2006 11:43 PM

Just a thought. Do you have a terminal open with root access? If so exit out as root.

Micro420 11-21-2006 11:50 PM

No I did not have anything open. For some reason it just needed a reboot to download the updates. Everything is working fine now. Had me scared for awhile! Oh yeah, and I am running FC6 in VMware so maybe that had something to do with it.

wonkydonk 11-23-2006 08:12 AM

i get this error when i try and run the add/remove software application

i'm not logged in as root in terminal any ideas?

reddazz 11-23-2006 08:18 AM

The problem is caused by the yum-updatesd daemon running in the background. I disabled it and I've never had that problem since.
Code:

#chkconfig yum-updatesd off

wonkydonk 11-23-2006 09:44 AM

that code don't work it says bash chkconfig

reddazz 11-23-2006 10:05 AM

Quote:

Originally Posted by wonkydonk
that code don't work it says bash chkconfig

The "#" sign means that you need to be root. Cheers.

wonkydonk 11-23-2006 11:02 AM

thanks i am logged in as root but still saying bash chkconfig

reddazz 11-23-2006 11:07 AM

Quote:

Originally Posted by wonkydonk
thanks i am logged in as root but still saying bash chkconfig

Can you post the full error message please?

b0uncer 11-23-2006 11:14 AM

The problem occurs because yum is built so that only one instance of the program may run at once (to prevent situations where you might be installing some software while removing it at the same time, or installing some software twice at the same moment). All yum processes are considered to be "the same" in this sense, so if you're running a manual yum-install, using the automatic update manager which uses yum, installing software using the graphical tool which lets you choose packets or anything else, you can only run one of these at a time.

Quote:

thanks i am logged in as root but still saying bash chkconfig
Don't be logged in as root, it's unsafe if not stupid. Instead use sudo (first you must probably configure it to let your preferred user use it) if you just can, it's safer than logging in as root, or use just su to become root and exit it when you don't need it anymore.

Quote:

thanks i am logged in as root but still saying bash chkconfig
Try this first:
Code:

su
type root password and hit ENTER
chkconfig bash yum-updatesd off

And if it's not found, find out where this program lies (if it's installed):
Code:

sudo updatedb && locate chkconfig
..or if you can't use sudo because you haven't configured it,
Code:

su
type root password and hit ENTER
updatedb && locate chkconfig && exit

The updatesd is probably a "needed" process if it's installed, so I'm not sure if you really should disable it; instead, find out if it should really be running all the time, or why is it running and when should it be running -- does it do something at the moment or has it jammed?

Also, if you can't figure out which yum process is the "problem", try
Code:

ps -e | grep yum
to see if any are running. If yes, see if you do want to run it and if not, use kill to stop it. If no yum processes are running but yum claims so, the pid file might not be removed for some reason (like a crash of some kind) so yum thinks it's running though it isn't. In this case remove the pid file.

dnguyen 01-29-2007 01:55 PM

I am new to Linux/FC too and I faced the same problem. I did exactly what bouncer said and it worked. Now I can run Add/Remove software or Software Update, thanks a lot.

decrepit 01-30-2007 04:58 AM

you can also turn off updatedb from "system settings" "server settings" "services" just unclick the box next to updatedb

jimgblk 05-14-2007 03:28 AM

Quote:

Originally Posted by decrepit
you can also turn off updatedb from "system settings" "server settings" "services" just unclick the box next to updatedb

and following what 'Decreipt' said, if you don't find the updatedb service, look for the yum-updatesd service. You can stop it temporarily using the 'stop' button if you want.

yngmike 09-18-2007 12:44 PM

Hey guys, I'm a big newb but yum appeared to continue to run after the fact of stopping it under services.. I actually had to remove yum all together but this worked great

# Stop the yum-updatesd daemon:

su -c 'service yum-updatesd stop'


# Remove the yum-updatesd package:

su -c 'yum remove yum-updatesd'

# You may now update using pup and install software via pirut. However because you will not be notified when updates are available, be sure to run yum update regularly:

su -c 'yum update'


All times are GMT -5. The time now is 05:26 AM.