LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-21-2006, 09:49 PM   #1
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
FC6 updates - Another application is running ...


**NEVERMIND! I rebooted and the problem went away. I was able to update.**
-----------------

I got a pop-up balloon on my FC6 desktop saying that there were some packages available for update. I click on it and then I get a popup that says, "Another application is running which is accessing software information." I have to click 'ok' and close it.

Now what do I do? I tried accessing it minutes later but I still get the same error. What's going on????

Last edited by Micro420; 11-21-2006 at 09:51 PM.
 
Old 11-21-2006, 10:43 PM   #2
FredGSanford
Member
 
Registered: Nov 2005
Location: USA
Distribution: Mageia Cauldron & Salix 14
Posts: 943
Blog Entries: 5

Rep: Reputation: 88
Just a thought. Do you have a terminal open with root access? If so exit out as root.
 
Old 11-21-2006, 10:50 PM   #3
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Original Poster
Rep: Reputation: 45
No I did not have anything open. For some reason it just needed a reboot to download the updates. Everything is working fine now. Had me scared for awhile! Oh yeah, and I am running FC6 in VMware so maybe that had something to do with it.
 
Old 11-23-2006, 07:12 AM   #4
wonkydonk
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Rep: Reputation: 0
i get this error when i try and run the add/remove software application

i'm not logged in as root in terminal any ideas?
 
Old 11-23-2006, 07:18 AM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
The problem is caused by the yum-updatesd daemon running in the background. I disabled it and I've never had that problem since.
Code:
#chkconfig yum-updatesd off
 
Old 11-23-2006, 08:44 AM   #6
wonkydonk
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Rep: Reputation: 0
that code don't work it says bash chkconfig
 
Old 11-23-2006, 09:05 AM   #7
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by wonkydonk
that code don't work it says bash chkconfig
The "#" sign means that you need to be root. Cheers.
 
Old 11-23-2006, 10:02 AM   #8
wonkydonk
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Rep: Reputation: 0
thanks i am logged in as root but still saying bash chkconfig
 
Old 11-23-2006, 10:07 AM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by wonkydonk
thanks i am logged in as root but still saying bash chkconfig
Can you post the full error message please?
 
Old 11-23-2006, 10:14 AM   #10
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
The problem occurs because yum is built so that only one instance of the program may run at once (to prevent situations where you might be installing some software while removing it at the same time, or installing some software twice at the same moment). All yum processes are considered to be "the same" in this sense, so if you're running a manual yum-install, using the automatic update manager which uses yum, installing software using the graphical tool which lets you choose packets or anything else, you can only run one of these at a time.

Quote:
thanks i am logged in as root but still saying bash chkconfig
Don't be logged in as root, it's unsafe if not stupid. Instead use sudo (first you must probably configure it to let your preferred user use it) if you just can, it's safer than logging in as root, or use just su to become root and exit it when you don't need it anymore.

Quote:
thanks i am logged in as root but still saying bash chkconfig
Try this first:
Code:
su
type root password and hit ENTER
chkconfig bash yum-updatesd off
And if it's not found, find out where this program lies (if it's installed):
Code:
sudo updatedb && locate chkconfig
..or if you can't use sudo because you haven't configured it,
Code:
su
type root password and hit ENTER
updatedb && locate chkconfig && exit
The updatesd is probably a "needed" process if it's installed, so I'm not sure if you really should disable it; instead, find out if it should really be running all the time, or why is it running and when should it be running -- does it do something at the moment or has it jammed?

Also, if you can't figure out which yum process is the "problem", try
Code:
ps -e | grep yum
to see if any are running. If yes, see if you do want to run it and if not, use kill to stop it. If no yum processes are running but yum claims so, the pid file might not be removed for some reason (like a crash of some kind) so yum thinks it's running though it isn't. In this case remove the pid file.

Last edited by b0uncer; 11-23-2006 at 10:18 AM.
 
Old 01-29-2007, 12:55 PM   #11
dnguyen
LQ Newbie
 
Registered: Jan 2007
Location: US
Distribution: FC6
Posts: 5

Rep: Reputation: 0
I am new to Linux/FC too and I faced the same problem. I did exactly what bouncer said and it worked. Now I can run Add/Remove software or Software Update, thanks a lot.
 
Old 01-30-2007, 03:58 AM   #12
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Rep: Reputation: 34
you can also turn off updatedb from "system settings" "server settings" "services" just unclick the box next to updatedb
 
Old 05-14-2007, 02:28 AM   #13
jimgblk
LQ Newbie
 
Registered: May 2007
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by decrepit
you can also turn off updatedb from "system settings" "server settings" "services" just unclick the box next to updatedb
and following what 'Decreipt' said, if you don't find the updatedb service, look for the yum-updatesd service. You can stop it temporarily using the 'stop' button if you want.
 
Old 09-18-2007, 11:44 AM   #14
yngmike
LQ Newbie
 
Registered: Sep 2007
Posts: 10

Rep: Reputation: 2
Hey guys, I'm a big newb but yum appeared to continue to run after the fact of stopping it under services.. I actually had to remove yum all together but this worked great

# Stop the yum-updatesd daemon:

su -c 'service yum-updatesd stop'


# Remove the yum-updatesd package:

su -c 'yum remove yum-updatesd'

# You may now update using pup and install software via pirut. However because you will not be notified when updates are available, be sure to run yum update regularly:

su -c 'yum update'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 - Unable to startx after initial updates Linux31 Fedora - Installation 3 12-27-2006 05:59 PM
FC6 problem and running out of hairs to pull golpemortal Fedora 6 11-06-2006 05:33 AM
FC6 beta3 upgrade to Final FC6 thyraios Fedora 1 09-18-2006 07:55 PM
Lost MCC when running updates dolphans1 Mandriva 3 01-21-2006 04:14 PM
running an application JSP Linux - General 0 03-12-2002 10:44 PM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration