LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   digikam install fails on dependecy (http://www.linuxquestions.org/questions/debian-26/digikam-install-fails-on-dependecy-536279/)

ZaphyR 03-10-2007 11:09 AM

digikam install fails on dependecy
 
I have just installed Debian Etch with Gnome, and then try to install Digikam to view my photos. I do this with Synaptic.

I just get this error:
Code:

digikam:
 Depends: libgphoto2-2-dev but it is not going to be installed

what's this all about??

JackieBrown 03-10-2007 11:11 AM

you'll know more from the output of installing libgphoto2-2-dev

You probably just need to enable sid.

ZaphyR 03-10-2007 12:09 PM

Quote:

Originally Posted by JackieBrown
you'll know more from the output of installing libgphoto2-2-dev

You probably just need to enable sid.


installing that gave this output

Code:

libgphoto2-2-dev:
 Depends: libexif-dev but it is not going to be installed
 Depends: libc6-dev but it is not going to be installed

and if I try those I get:

Code:

libexif-dev:
 Depends: libc6-dev but it is not going to be installed

Code:

libc6-dev:
  Depends: libc6 (=2.3.6.ds1-11) but 2.3.6.ds1-13 is to be installed

it complains about unresolved deps every time, so perhaps I'm missing some repositories?

JackieBrown 03-10-2007 12:14 PM

try enabling the sid repos

ZaphyR 03-10-2007 01:55 PM

ok, I think I managed to add the repo alright, at least the program is installed now.
thx for the tip!


All times are GMT -5. The time now is 09:04 AM.