LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2007, 10:09 AM   #1
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Rep: Reputation: 32
digikam install fails on dependecy


I have just installed Debian Etch with Gnome, and then try to install Digikam to view my photos. I do this with Synaptic.

I just get this error:
Code:
digikam:
 Depends: libgphoto2-2-dev but it is not going to be installed
what's this all about??
 
Old 03-10-2007, 10:11 AM   #2
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
you'll know more from the output of installing libgphoto2-2-dev

You probably just need to enable sid.
 
Old 03-10-2007, 11:09 AM   #3
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by JackieBrown
you'll know more from the output of installing libgphoto2-2-dev

You probably just need to enable sid.

installing that gave this output

Code:
libgphoto2-2-dev:
 Depends: libexif-dev but it is not going to be installed
 Depends: libc6-dev but it is not going to be installed
and if I try those I get:

Code:
libexif-dev:
 Depends: libc6-dev but it is not going to be installed
Code:
libc6-dev:
  Depends: libc6 (=2.3.6.ds1-11) but 2.3.6.ds1-13 is to be installed
it complains about unresolved deps every time, so perhaps I'm missing some repositories?
 
Old 03-10-2007, 11:14 AM   #4
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
try enabling the sid repos
 
Old 03-10-2007, 12:55 PM   #5
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Original Poster
Rep: Reputation: 32
ok, I think I managed to add the repo alright, at least the program is installed now.
thx for the tip!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] digiKam Install Problem - Missing Plugins? BeerIsGood Slackware 7 10-12-2006 06:11 AM
A-L-M-O-S-T There!!! Digikam, KAudioCreator, system bell install problems joeaverage Mandriva 5 01-05-2006 10:01 PM
Debian Dependecy Problems - Grrrrrrrrrrrr doctorwebbox Debian 21 12-05-2005 01:02 PM
digikam source install on Slack 10.0 rhb327 Slackware 4 08-20-2005 04:06 PM
glib dependecy problem ALInux Linux - Software 4 08-04-2005 03:05 AM


All times are GMT -5. The time now is 07:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration