LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Zorin OS (https://www.linuxquestions.org/questions/zorin-os-107/)
-   -   Zorin OS Has terrible screen tearing, AMD GPU drivers not working right (https://www.linuxquestions.org/questions/zorin-os-107/zorin-os-has-terrible-screen-tearing-amd-gpu-drivers-not-working-right-4175655982/)

Dunked0n 06-18-2019 05:02 PM

Zorin OS Has terrible screen tearing, AMD GPU drivers not working right
 
Hi, I have a AMD radeon RX 570. Zorin OS won't use the GPU right. The OS comes with some amd drivers by default, but they are not working right. The desktop is suffering screen tearing and won't play some animations. The computer also boots to a black screen unless I use "nomodeset" in GRUB. Is there anything that I could do to stop and?

mrmazda 06-19-2019 02:36 AM

No AMD RX user can expect decent behavior when booting with nomodeset. Nomodeset is a troubleshooting option, available primarily for rescue and testing purposes. Instead of booting with nomodeset, try disabling graphical boot by using plymouth.enable=0 instead. If it doesn't make the black screen go away, possibly the messages that should appear during boot will provide a clue what could be failing.

Zorin's X server and kernel aren't particularly new. Is it possible that RX 570 is a newer model than Zorin software supports? Maybe you need a newer kernel and/or DDX and/or server from a PPA. Part of the answer to this might be found via the PCI ID of the Radeon. To get it, do in an X terminal:
Code:

inxi -GxxSM
and paste result here using code tags. If you can get booted using nomodeset on a boot immediately following an attempt to boot without it, sharing the Xorg.0.log from the prior boot might provide a needed clue. Do:
Code:

pastebinit /var/log/Xorg.0.log.old
and paste the resulting URL here.

Dunked0n 06-19-2019 02:00 PM

I've managed to get Zorin to a point where It doesn't screen tear as much when moving windows as well as being able to boot up without using nomodeset by adding "amdgpu.dc=0" to the grub options. But the display manager is suffering a bunch of weird Artifacts. And the whole desktop flickers when I try to use the 75hz option on my monitor and in settings. How could I fix this?

mrmazda 06-19-2019 02:06 PM

Please paste here the ouput from:
Code:

xrandr

Dunked0n 06-19-2019 02:15 PM

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
1920x1080 74.97 + 60.00* 50.00 59.94
1920x1080i 60.00 50.00 59.94
1680x1050 59.88
1280x1024 60.02
1440x900 59.90
1280x800 59.91
1152x864 75.00
1280x720 60.00 50.00 59.94
1024x768 70.07 60.00
800x600 60.32 56.25
720x576 50.00
720x480 60.00 59.94
640x480 66.67 60.00 59.94
720x400 70.08
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DVI-D-1 disconnected (normal left inverted right x axis y axis)

mrmazda 06-20-2019 02:23 AM

Quote:

Originally Posted by Dunked0n (Post 6007224)
HDMI-A-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
1920x1080 74.97 + 60.00* 50.00 59.94

The "+" indicates the current mode is 1920x1080@75

The "*" indicates the display's preferred mode is 1920x1080@60

Refresh rates higher than 60 are an anachronism since disuse of CRTs began.

@60 is the preferred refresh for the vast majority of panel displays.

Why do you wish to use a 75 refresh? Do you have the same tearing when using 60 refresh?

Dunked0n 06-20-2019 08:40 AM

I wish to 75 but it really doesn't matter. And I don't suffer the same screen tearing and/or artifacts on 60 Hz. However, the display manager is suffering from flickering and I cant seem to force It to go to 60Hz.

mrmazda 06-20-2019 03:27 PM

It should automatically use 60 as long as you have not made manual configuration changes that prevent it. Does /etc/X11/xorg.conf exist? If yes, remove it.

Create a new user and login as that user, or login as root briefly, just long enough to test. Does it then use 60? If yes, then your regular user's settings have been modified and need to be reset.

Dunked0n 06-20-2019 04:42 PM

I just created a new user. And the new user used 75 Hz as a default so I don't think that its regular user settings. I had to manually set my user refresh rate to 60 for me to fix it. So how could I make my display manager (gdm3) use 60 Hz as a default?

mrmazda 06-20-2019 08:58 PM

Quote:

Originally Posted by Dunked0n (Post 6007535)
So how could I make my display manager (gdm3) use 60 Hz as a default?

That might depend on the answers to the /etc/X11/ questions I asked that you didn't answer. If none of those files exist, add the following as 20-monitor.conf in /etc/X11/xorg.conf.d/:
Code:

Section "Monitor"
    Identifier "D0monitor"
        HorizSync        29-71
        VertRefresh        59-61
        Option        "PreferredMode"        "1920x1080"
EndSection

If /etc/X11/xorg.conf.d/ does not already exist, create it. It's optional.

If it doesn't help, please paste here output from:
Code:

sudo hwinfo --monitor

Dunked0n 06-20-2019 09:29 PM

I managed to get the system to run stable and go perfect at 75Hz without artifacting by downgrading the kernel to 4.15. But on bootup, the display manager looks scrambled and distorted. What should I do? Also I’m sorry if I’m ignoring advice, I’ve been doing a lot of research


All times are GMT -5. The time now is 05:58 PM.