LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zorin OS
User Name
Password
Zorin OS This forum is for the discussion of Zorin OS Linux.

Notices


Reply
  Search this Thread
Old 03-17-2020, 03:05 AM   #1
Pingvin1
LQ Newbie
 
Registered: Mar 2020
Distribution: Zorin OS 15
Posts: 8

Rep: Reputation: Disabled
The bug: feature to show the invisible cursor on the screen in Linux


It is likely that each computer user could not always find the cursor position on the screen. At the same time, there is an active movement of the mouse, or driving a finger on the touchpad in an attempt to find it.
Linux systems have a built-in feature that will help you locate the cursor on the screen by pressing the assigned key. By default, this feature is not enabled in all shells, so it often has to be enabled.
I found the locate-pointer function in the dconf editor at
Code:
org/gnome/settings-daemon/peripherals/mouse
and made it active (in Russian): https://cloud.mail.ru/public/CanK/9fwbEnJNv .
By default, it will be enough to press the Ctrl key and the cursor will be highlighted on the screen, but I have a bug in Gnome 3.30.2 or in ZORIN OS 15.2 based on 18.04.1-Ubuntu and this does not happen (the cursor does not change its shape and not highlight when pressing left and right Ctrl).
What to do other than wait for an update?

P.S. View of the editor dconf (Translation from Russian into English phrases with the screenshot):
Summary Подсвечивает текущее положение указателя при нажатие клавиши Ctrl. = Summary Highlights the current position of the pointer when you press Ctrl.
Type Логическое = Type Logical

Last edited by Pingvin1; 03-17-2020 at 03:35 AM.
 
Old 03-18-2020, 03:51 AM   #2
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 1,456

Rep: Reputation: Disabled
Have you tried to do this from the command line?
Code:
gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true
 
1 members found this post helpful.
Old 03-18-2020, 06:10 AM   #3
Pingvin1
LQ Newbie
 
Registered: Mar 2020
Distribution: Zorin OS 15
Posts: 8

Original Poster
Rep: Reputation: Disabled
I activated the "locate-pointer" function by another method:
Code:
$ dconf write "/org/gnome/settings-daemon.peripherias/mouse/locate-pointer" true
, but there is no difference. After all, after the command I gave, the value of the "locate-pointer" function changed, I checked it and showed it in a screenshot.

Last edited by Pingvin1; 03-18-2020 at 07:09 AM.
 
Old 03-18-2020, 07:10 AM   #4
Pingvin1
LQ Newbie
 
Registered: Mar 2020
Distribution: Zorin OS 15
Posts: 8

Original Poster
Rep: Reputation: Disabled
What 's your Operating System, shruggy?
Does the cursor highlight when you press ctrl?
 
Old 03-18-2020, 07:24 AM   #5
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 1,456

Rep: Reputation: Disabled
Code:
$ grep -Po '^PRETTY.*=\K.*' /etc/os-release
"CentOS Linux 8 (Core)"
$ rpm -q gnome-shell
gnome-shell-3.32.2-9.el8.x86_64
It works in an X11 session, but doesn't in the default Wayland session.
 
Old 03-18-2020, 09:12 AM   #6
Pingvin1
LQ Newbie
 
Registered: Mar 2020
Distribution: Zorin OS 15
Posts: 8

Original Poster
Rep: Reputation: Disabled
Can the cursor position be displayed in a X11 session or in a Wayland session?
Now I 'm studying how to switch?
 
Old 03-19-2020, 08:23 AM   #7
Pingvin1
LQ Newbie
 
Registered: Mar 2020
Distribution: Zorin OS 15
Posts: 8

Original Poster
Rep: Reputation: Disabled
I have Xorg (x11) by default. Switched from Xorg (x11) to Wayland. The cursor is not highlighted, the same way.
 
Old 03-19-2020, 09:34 AM   #8
Pingvin1
LQ Newbie
 
Registered: Mar 2020
Distribution: Zorin OS 15
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by shruggy View Post
It works in an X11 session, but doesn't in the default Wayland session.
This means that the cursor is highlighted (when pressing Ctrl) in an X11 session, but doesn't in Wayland session?
 
Old 03-19-2020, 09:37 AM   #9
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 1,456

Rep: Reputation: Disabled
Yes, on CentOS 8.
 
Old 03-20-2020, 04:43 AM   #10
Pingvin1
LQ Newbie
 
Registered: Mar 2020
Distribution: Zorin OS 15
Posts: 8

Original Poster
Rep: Reputation: Disabled
Surprisingly, after using your
Quote:
Originally Posted by shruggy View Post
Have you tried to do this from the command line?
Code:
gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true
command in x11 session, when you press Ctrl, the cursor is highlighted and in Wayland session is not highlighted.
Thank you very much, shruggy!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Linux Mint 9 Cursor Invisible GJQ Linux - Newbie 5 10-12-2010 10:18 AM
invisible mouse cursor sharapchi Linux - General 2 12-13-2006 03:26 PM
Invisible cursor - but mouse works fine mouldy_punk SUSE / openSUSE 3 10-18-2006 05:36 PM
The amazing invisible cursor rockman Linux - Newbie 5 04-22-2004 10:49 AM
Invisible Mouse Cursor roie Linux - Newbie 1 12-06-2001 01:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zorin OS

All times are GMT -5. The time now is 01:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration