LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Zorin OS (https://www.linuxquestions.org/questions/zorin-os-107/)
-   -   The bug: feature to show the invisible cursor on the screen in Linux (https://www.linuxquestions.org/questions/zorin-os-107/the-bug-feature-to-show-the-invisible-cursor-on-the-screen-in-linux-4175671479/)

Pingvin1 03-17-2020 03:05 AM

The bug: feature to show the invisible cursor on the screen in Linux
 
It is likely that each computer user could not always find the cursor position on the screen. At the same time, there is an active movement of the mouse, or driving a finger on the touchpad in an attempt to find it.
Linux systems have a built-in feature that will help you locate the cursor on the screen by pressing the assigned key. By default, this feature is not enabled in all shells, so it often has to be enabled.
I found the locate-pointer function in the dconf editor at
Code:

org/gnome/settings-daemon/peripherals/mouse
and made it active (in Russian): https://cloud.mail.ru/public/CanK/9fwbEnJNv .
By default, it will be enough to press the Ctrl key and the cursor will be highlighted on the screen, but I have a bug in Gnome 3.30.2 or in ZORIN OS 15.2 based on 18.04.1-Ubuntu and this does not happen (the cursor does not change its shape and not highlight when pressing left and right Ctrl).
What to do other than wait for an update?

P.S. View of the editor dconf (Translation from Russian into English phrases with the screenshot):
Summary Подсвечивает текущее положение указателя при нажатие клавиши Ctrl. = Summary Highlights the current position of the pointer when you press Ctrl.
Type Логическое = Type Logical

shruggy 03-18-2020 03:51 AM

Have you tried to do this from the command line?
Code:

gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true

Pingvin1 03-18-2020 06:10 AM

I activated the "locate-pointer" function by another method:
Code:

$ dconf write "/org/gnome/settings-daemon.peripherias/mouse/locate-pointer" true
, but there is no difference. After all, after the command I gave, the value of the "locate-pointer" function changed, I checked it and showed it in a screenshot.

Pingvin1 03-18-2020 07:10 AM

What 's your Operating System, shruggy?
Does the cursor highlight when you press ctrl?

shruggy 03-18-2020 07:24 AM

Code:

$ grep -Po '^PRETTY.*=\K.*' /etc/os-release
"CentOS Linux 8 (Core)"
$ rpm -q gnome-shell
gnome-shell-3.32.2-9.el8.x86_64

It works in an X11 session, but doesn't in the default Wayland session.

Pingvin1 03-18-2020 09:12 AM

Can the cursor position be displayed in a X11 session or in a Wayland session?
Now I 'm studying how to switch?

Pingvin1 03-19-2020 08:23 AM

I have Xorg (x11) by default. Switched from Xorg (x11) to Wayland. The cursor is not highlighted, the same way.

Pingvin1 03-19-2020 09:34 AM

Quote:

Originally Posted by shruggy (Post 6101860)
It works in an X11 session, but doesn't in the default Wayland session.

This means that the cursor is highlighted (when pressing Ctrl) in an X11 session, but doesn't in Wayland session?

shruggy 03-19-2020 09:37 AM

Yes, on CentOS 8.

Pingvin1 03-20-2020 04:43 AM

Surprisingly, after using your
Quote:

Originally Posted by shruggy (Post 6101809)
Have you tried to do this from the command line?
Code:

gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true

command in x11 session, when you press Ctrl, the cursor is highlighted and in Wayland session is not highlighted.
Thank you very much, shruggy!


All times are GMT -5. The time now is 04:56 PM.