LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Zorin OS (https://www.linuxquestions.org/questions/zorin-os-107/)
-   -   Sudden loss of functionality, and hang ups on reset. (https://www.linuxquestions.org/questions/zorin-os-107/sudden-loss-of-functionality-and-hang-ups-on-reset-4175626317/)

Asno 03-25-2018 01:13 PM

Sudden loss of functionality, and hang ups on reset.
 
Hello, I'm both new to here, and using linux.

I'm currently using Zorin OS 12.3

It was running fine until this morning when suddenly chrome stopped loading pages, and discord just cut out. I closed them thinking maybe it was just a small mess up, but the computer wouldn't re-open them, and many of the buttons were missing their icons in the start menu. They worked, and I managed to get to log out, and then decided to shut down and give it a moment before starting up again and it got hung on a screen saying this:

Zorin OS 12.3 Ivans tty1

Ivans login:

[11769.354257] print_req_error: I/0 error, dev sda sector 194221112

I tried providing my password like it suggests, but that just starts another line repeating the print error.

Thank you for you time.

hazel 03-25-2018 01:26 PM

Looks like a fault on your hard drive. Try booting from your installation disc and run fsck on your root partition.

Asno 03-25-2018 02:02 PM

I just remembered I forgot to post my laptops specs

It is a Lenovo T440
Audio
HD Audio
Realtek® ALC3232 codec
Dolby® Advanced Audio™ v2 / stereo speakers
1W x 2 / dual array microphone
Combo audio/microphone jack
8 GB of ddr3 ram
4th Gen Intel® Core™ i7-4600U (Up to 3.30 GHz, 4MB, L3, 1600 MHz FSB)


440's don't have a disk drive. So I've installed with a flash drive using the instructions provided by the Zorin website. Do I run the install to reach the FSCK option?

Sorry again, I'm very new to all of this.

Asno 03-25-2018 02:13 PM

Thank you for answering so quickly.

I forgot to say what I'm running this on. I'm on a lenovo T440. There is no disk drive in this model. So I've used a usb drive using etchr like the zorin website suggested. Do I run the install option to reach the FSCK option.

hazel 03-25-2018 02:41 PM

So you have your installation image on a usb key, not a CD. That shouldn't make any difference. Boot from it but don't use the install option; your system is already installed and there's probably nothing wrong with it. You just have a hardware problem so that some of the installed files can't be read.

Open a terminal and use the fsck command to find and fix your disk errors. Read the man page first so you know how to use it. fsck has to be run on unmounted partitions; that's why you need to do it from outside your system.

Asno 03-25-2018 03:01 PM

I keep looking around to find a guide, but just end up with threads where people knew how to use it already.

I found a guide giving the commands, but when I put them in I'm just given the lines:
fsck from util-linux 2.27.1
e2fsck 1.42.13 (17-may-2015)
fsck.ext2: Permission denied while trying to open /dev/sda2
you must have r/w access to the filesystem or be root.

ondoho 03-26-2018 02:41 AM

read
Code:

man fdisk
and when you start using it, put 'sudo' in front of the command.

and i'm getting plenty of good results for my searches.

hazel 03-26-2018 04:40 AM

I'm surprised. I thought that installation images made you root automatically, like SystemRescue does.


All times are GMT -5. The time now is 07:32 AM.