Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Zorin OS
User Name
Zorin OS This forum is for the discussion of Zorin OS Linux.


  Search this Thread
Old 07-18-2017, 03:04 PM   #1
LQ Newbie
Registered: Apr 2010
Posts: 27

Rep: Reputation: 4
Question Stop auto mount of partitions

Just installed Zorin 12 and on startup it mounts and opens a number of my other distros on my hard drive. It's mostly annoying but I would like to prevent this from happening. Any way to stop the auto mount??
Old 07-18-2017, 03:13 PM   #2
Registered: Jan 2009
Location: Maryland-Pennsylvania border, USA
Distribution: openSUSE 42.3, Tumbleweed, OS X 10.10, Ubuntu 17.10, and Linux Mint 17.3/18.1
Posts: 689
Blog Entries: 10

Rep: Reputation: 95
Using your favorite plain text editor (gedit, pluma, xedit, nano, vim, emacs,....) and with superuser privileges ("sudo su /etc/fstab" will suffice), comment out what you don't want mounted in /etc/fstab with a hashtag at the beginning of the line.

Be careful and don't comment out this distro's root, swap, home, or anything desirable
Old 07-18-2017, 08:37 PM   #3
Mill J
Registered: Feb 2017
Location: Sweet
Distribution: Void, LFS,Tahrpup, Quirky on Rpi and many others
Posts: 624
Blog Entries: 1

Rep: Reputation: 211Reputation: 211Reputation: 211

Here's some more info.
Old 07-18-2017, 08:44 PM   #4
LQ Guru
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 13,196
Blog Entries: 18

Rep: Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475Reputation: 3475
. . . or change the settings for the partitions in question from "auto" to "noauto."

See man fstab for more.
Old 11-17-2017, 02:27 PM   #5
LQ Newbie
Registered: Mar 2009
Location: mid south
Distribution: more than three
Posts: 7

Rep: Reputation: 1
Since the question isn't too old, I thought I'd add my 2 cents worth. This problem may have been fixed in free release version 12.2 which I've recently installed on my 64-bit laptop. I have one other linux distro and a Windows distro on my hard drive which don't automatically mount. File manager shows:
+ other locations
in nautilus file manager. If I right click the other partitions the context menu shows "mount". Otherwise you can do a search for disks which will bring up the utility that has a graph of your partition lay out. Select a partition and you can choose the gear icons below "additional partition options" "edit mount options" and turn the slider from "automatic mount options" from "on" to "off". Mine is set to "on" and only affects hot plug thumb drives.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to Auto Mount Partitions at Linux Startup the Easy Way LXer Syndicated Linux News 0 09-06-2011 10:50 AM
Stop USB Auto Mount x360539 Solaris / OpenSolaris 3 07-07-2011 01:42 AM
fedora 11 do not auto mount some of fat32 partitions in my hard drive. akram Linux - Newbie 4 10-14-2009 03:05 AM
FC-8, how to stop win partitions from automatic mount prabhatsoni Linux - Software 4 04-23-2008 01:15 AM
Way to not auto mount HD partitions; Mandriva One 2008 Spring Live CD RHTopics Mandriva 9 03-28-2008 02:00 AM > Forums > Linux Forums > Linux - Distributions > Zorin OS

All times are GMT -5. The time now is 11:38 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration