LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk
User Name
Password
Zenwalk This forum is for the discussion of Zenwalk Linux.

Notices


Reply
  Search this Thread
Old 01-14-2015, 10:40 AM   #1
samuser91
LQ Newbie
 
Registered: Jan 2015
Distribution: Debian, Zenwalk, Ubuntu
Posts: 4

Rep: Reputation: Disabled
wrong keyboard map


Hello there!
I finally made it and installed Zenwalk 7.4 on my Asus eeePC 1201n.
So before I can start it the first time I create a new user etc. and then I see the desktop asking me to put in the user name and after that the password.
Now what happens is this:
I want to put in my username and the keyboard is just working from the middle to the left side. Everything from the line u j m (up to down) are numbers or symbols but I can't get the letters. This means I can't put in the right username.
During installation the keyboard works fine. It only does that as soon as I enter the desktop environment.
Does anybody know why this is happening and what I can do about it?
I hope someone can help me.
Thank you!
 
Old 01-14-2015, 01:19 PM   #2
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 160

Rep: Reputation: 35
Given that Zenwalk is based on Slackware the following link might help
http://docs.slackware.com/howtos:win...eyboard_layout
I guess that you should either try to use the command line to login and change the keyboard layout from there.
Otherwise, you might even need a live CD/USB.
 
Old 01-14-2015, 09:30 PM   #3
Thane
Member
 
Registered: Aug 2006
Location: Ontario,Canada
Distribution: Linux Mint18 Cinnamon 64bit
Posts: 200

Rep: Reputation: Disabled
keybd maps

Remembered seeing this in my past bookmarks. Maybe there will be something of interest here. cheers

http://www.win.tue.nl/~aeb/linux/kbd/scancodes-6.html
 
Old 01-16-2015, 01:51 AM   #4
samuser91
LQ Newbie
 
Registered: Jan 2015
Distribution: Debian, Zenwalk, Ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hoes View Post
Given that Zenwalk is based on Slackware the following link might help
http://docs.slackware.com/howtos:win...eyboard_layout
I guess that you should either try to use the command line to login and change the keyboard layout from there.
Otherwise, you might even need a live CD/USB.
Thanks for the help.
Can you please tell me how to enter the command line? And how I will be able to login and change the keyboard there?
Thank you!
 
Old 01-16-2015, 04:23 AM   #5
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 160

Rep: Reputation: 35
On most linux systems I used you could use a combination of ctrl-alt-F1 to ctrl-alt-F6 to get to a terminal.
Hopefully this terminal has the keyboard setup in the right way.
In that case you can just use your regular username and password.
You might require root access to change the files.

If you cannot get a terminal using ctrl-alt-F1 (or similar) you might try booting in single user mode.
How you do this depends on your bootmanager.

If you can boot in single mode or load a terminal, but also have the wrong keyboard layout. There is another option.
You can boot your computer form a live CD/USB and mount the harddisk of your system.
In that case you should also be able to edit the files.
 
Old 01-28-2015, 08:03 PM   #6
liltux
Member
 
Registered: Mar 2011
Posts: 45

Rep: Reputation: 2
Same problem here.

I am having the exact same issue as samuser91. I am currently using an Acer laptop with Ubuntu and was wanting to try other distro on spare partition. I have used Slackware before and was wanting to try something out there slack based, that is how I got to Zenwalk. Anyways, I have tried cntrl+alt+F1 for a new tty terminal and I still get incorrect keyboard map. I have also gone on to the partition via ubuntu and created the rc.keymap file per slackdocs and verified that X11 is already setup for us map. However I may have missed something on install and will try a fresh install. Other wise could it be a kernel issue from distro and my hardware?
 
Old 01-29-2015, 09:44 AM   #7
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 160

Rep: Reputation: 35
Problems with the keymap are a software problem.
Especially if it is working on ubuntu.
You say that you created the rc.keymap.
Are you sure it is read at boot time?
Have a look at the init scripts that are called.
This may point to were you have to make the change.
 
1 members found this post helpful.
Old 01-29-2015, 09:52 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,733
Blog Entries: 58

Rep: Reputation: Disabled
I had the same problem with Salix on my eeepc 1001ha, and discovered NumLk was being switched on at boot.
 
1 members found this post helpful.
Old 01-29-2015, 09:56 AM   #9
liltux
Member
 
Registered: Mar 2011
Posts: 45

Rep: Reputation: 2
Lightbulb

Quote:
Originally Posted by hoes View Post
Problems with the keymap are a software problem.
Especially if it is working on ubuntu.
You say that you created the rc.keymap.
Are you sure it is read at boot time?
Have a look at the init scripts that are called.
This may point to were you have to make the change.
Yes, I will look into it. I was assuming the call was already there. I will try soon and post back here. I am using salixOS right now.
 
Old 01-29-2015, 11:29 AM   #10
liltux
Member
 
Registered: Mar 2011
Posts: 45

Rep: Reputation: 2
Thumbs up

Quote:
Originally Posted by brianL View Post
I had the same problem with Salix on my eeepc 1001ha, and discovered NumLk was being switched on at boot.
Spot On! It was the numlock, as now I am posting from my working zenwalk distro. I remembered that when installing salixOS it asked at setup to activate or deactivate numlock at startup. would this be a setting in inittab or a specific script? I guess I was overlooking the numlock due to the fact that I have never had the numlock on on this computer. Thanks again for the help. Problem solved on my end, for the most part.
 
Old 01-29-2015, 11:46 AM   #11
samuser91
LQ Newbie
 
Registered: Jan 2015
Distribution: Debian, Zenwalk, Ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
Sorry but where do I deactivate NumLk?
 
Old 01-29-2015, 08:43 PM   #12
liltux
Member
 
Registered: Mar 2011
Posts: 45

Rep: Reputation: 2
I looked all over the startup scripts and did not see a call for numlock. rc.M calls rc.local last prior to rc.4. I tried putting a line in rc.local to turn off numlock however when xdm would load it always turned numlock on. For now just know you have to turn numlock off via the keyboard. I plan on looking into salix to see how it may be done different in its startup. I am a hobbyist at best so if anyone else has more info feel free to share. Thanks.
 
Old 01-30-2015, 09:03 PM   #13
cesarbergara
Member
 
Registered: Feb 2012
Location: Buenos Aires, Argentina
Distribution: Debian, Suse, Mandrake,
Posts: 58

Rep: Reputation: Disabled
Hi. You can try with this trick:

ls /usr/bin/*kdb*

or:

ls /usr/bin/*keyb*

Those list commands which can configure keyboard.
Then use man 'commad' to know how each one works, and their options.
Time ago i installed knoppix on HD. Then the keyboard work fine with liveCD, work fine in X, but was wrong in terminal.
With /usr/bin/keyboard i can configure terminal keyboard (putting the command /usr/bin/keyboard es_ES in the /home/user/.bashrc file)

I hope this can help you to find a future solution.
 
1 members found this post helpful.
Old 02-01-2015, 07:17 PM   #14
liltux
Member
 
Registered: Mar 2011
Posts: 45

Rep: Reputation: 2
Quote:
Originally Posted by cesarbergara View Post
Hi. You can try with this trick:

ls /usr/bin/*kdb*

or:

ls /usr/bin/*keyb*

Those list commands which can configure keyboard.
Then use man 'commad' to know how each one works, and their options.
Time ago i installed knoppix on HD. Then the keyboard work fine with liveCD, work fine in X, but was wrong in terminal.
With /usr/bin/keyboard i can configure terminal keyboard (putting the command /usr/bin/keyboard es_ES in the /home/user/.bashrc file)

I hope this can help you to find a future solution.
Excellent suggestion. It brings up the gui for keyboard settings, which I have already tried to set it to save settings, but it never keeps the numlock off at the login screen. I have tried turning numlock on and off again to monitor different scripts ran/loaded with xdm. no help. I added a line in the Xsetup_0 file to use rc.numlock. This works at turning the numlock off after I login, not before. I have been doing a lot of searchs on google for any help but all point to Xsetup_0 or .xinitrc or other login scripts, which are executed once logged in. Dont get me wrong, system works, I would just like to understand. It seems as if coded in the xdm install. I have become slightly obsessed.
 
Old 02-01-2015, 09:44 PM   #15
liltux
Member
 
Registered: Mar 2011
Posts: 45

Rep: Reputation: 2
Lightbulb Found it!!

OK, so I was under the assumption that Zenwalk was using xdm. wrong. default rc.4 was running a link from gdm to lxdm. googled lxdm and found a configuration file for it. so now I am numlock free at the login screen.

Quote:
Originally Posted by samuser91 View Post
Sorry but where do I deactivate NumLk?
samuser91:

locate this file:
/etc/lxdm/lxdm.config

edit the line in that file that reads:

numlock=1 ; to read:
numlock=0

save file.

That should keep numlock from activating on the login screen.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to match X keyboard layout with the the kernel keyboard map? Didier Spaier Slackware 11 03-24-2013 02:40 PM
keyboard map neilcpp Slackware 1 01-16-2006 03:16 PM
Keyboard map Noido Linux - General 10 06-14-2005 02:41 AM
Wrong Keyboard Map and resolution too fine Grouse SUSE / openSUSE 2 11-12-2004 04:35 AM
keyboard map logicport Linux - Software 1 07-26-2004 11:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk

All times are GMT -5. The time now is 06:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration