-   Zenwalk (
-   -   Unable to make Opera work (

fuelinux 04-29-2008 09:17 AM

Unable to make Opera work
hi there
I feel kind of confused. I had never have problems with installing Opera on Vector 5.8, but now i'm stuck with ZW5.0. Both packages (from Opera's download page and from ZW repo) get installed but when I try to run Opera (either from terminal <opera> or from "Menu" >> Network >> Opera, all I get is


root[opera-9.27-20080331.6-shared-qt.i386-en-709]# opera
ERROR: object '' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: object '' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.27-20080331.6/opera: error while loading shared libraries: cannot open shared object file: No such file or directory

Then I looked at Distrowatch and ZW has no QT installed out of the box. Is this a problem?

If is related to JRE, then I do have jre1.6.0_05 installed.

Any ideas?

guth 04-29-2008 12:17 PM

netpkg qt-3.3
netpkg jre
netpkg opera

fuelinux 04-29-2008 12:45 PM

So, is it a qt problem indeed?
jre is already installed.
and there is no way i could install opera from package from their site?
i'm confused with way zen installs programs.

oh, and btw, I have never managed to get netpkg connected to repo either. perhaps, corporate network with it's weird architecture is responsible for that

gapan 04-29-2008 06:24 PM

You installed opera manually without taking care of the dependencies which include the qt-base package. Had you used netpkg to install opera you wouldn't have any such problems because qt-base along with all other extra dependencies would have been installed for you. You can always search for dependencies and install them manually in any case. would be very useful in that respect because you can see each package's dependencies and download the ones you're missing. However, the best solution would be to use netpkg.

You can enter proxy settings in /etc/netpkg.conf to get netpkg working from inside your corporate network. ;)

fuelinux 04-30-2008 05:06 AM

I'd never thought ZW doesn't include qt. Anyways, I'll try it and get back to this thread.
Thanks for advices :)

fuelinux 05-05-2008 07:54 AM

installed qt-3.4.3 but still no result :( very same error message is displyed in terminal


thanks to gapan i've made netpkg to work and it shows that opera from extra/xap is already installed. even not a slight idea what to do :O

gapan 05-06-2008 04:40 PM

Now that netpkg works can you do

netpkg opera
and reinstall it? You should select to install or upgrade any missing dependencies. I don't know which qt package you installed exactly but it was probably not the right one which should be qt-base.

unSpawn 05-06-2008 05:43 PM

If all fails there's always the static Opera tarball.

fuelinux 05-17-2008 12:27 PM

Sorry for not answering for so long.
I've switched back to VL since ZW was way heavy for my 1,8 GHz pentium. VL just flies on it.
Thank you for your suggestions anyways :)

All times are GMT -5. The time now is 06:57 PM.